Make Dolphin Use Recoll "kio_recoll" Installed

I just made a fresh install, BTRFS on the first of the month.
I disabled Baloo because it does not play well with BTRFS (many posts here)
Finally the discussions concluded I can use Recoll to search for files by content.
As per this theread (Install "kio_recoll"?) I already installed “kio_recoll”

I assumed installing “kio_recoll” would enable me to search file content in Dolphi via Recoll.

Still, it is not working in Dolphin.

What should I do to make Dolphin search for file contents using Recoll?

As usual during my EOS life (1 month) and BTRFS life (4 days) I expect - as usual - great help.
Thanks in advance.

1 Like

I could be wrong, but skimming through the manual (section 3.3 starting on page 35), it seems to me that KDE4 KIO Slave module is used for integration with Konqueror, not Dolphin.

Maybe it works with Dolphin, too, but I doubt it.

KDE’s search functionality is based on Baloo, I don’t think anything can be a drop-in replacement for it.

I read it on the Recoll website!

Yes… this seems the defaults for Dolphin.

But what I thought of:

  • In Dolphin, there are already a few other search engines (Kfind, Fsearch…), so maybe there is a file (configuration or so) to let Dolphin “know” there is somethin as well called “Recoll”. Same as Baloo is an addon (not built in with Dolphin) there might be a way as well to make Recoll the default.
  • This is Open source anyway, source code is there… so why not.

Just hoping the experts can find a way to do it.

I was reading, recollrunner seems might help. But I wonder if it is worth it.

Needs to have kio_recoll installed as well for kio Slave integration i think.

Ah… here comes the expert @ricklinux

I have a feeling you have something…

  • kio_recoll installed already as mentioned in my first post.
  • I read something about the kio slave
    but… is there something I should install in addition to kio_recoll?

I’ll have to look at it later…as i go work now!

1 Like

Thank you very much.
Have a nice day!

Maybe another search engine that integrates with Dolphin?

I found this in German

Reading it through Google Translate I figured out someone had Recoll working (but has a problem)

I hope this with google translate can help!

I tried

yay -Syu recollrunner

and I got

-> kio_recoll: local (1.32.5-1) is newer than AUR (1.21.6-1)
 -> Flagged Out Of Date AUR Packages:  kio_recoll
 -> Could not find all required packages:
        kdebase-workspace (Wanted by: recollrunner)
[limo@lenovo ~]$ 

"kdebase-workspace (Wanted by: recollrunner)

Always check the AUR page before installing a new AUR package.

Last Updated: 2015-06-23 08:52 (UTC)

It hasn’t been updated in over 7 years. That is why it depends on a package that no longer exists.

How are you trying to use it? It looks like you need to put recoll:/ in the address bar.

Did you read this from the readme:

You need to build/update the index with recollindex, the KIO slave
doesn’t deal with indexing for now.

Didn’t work. On their website they say for Konqueror. But I tried anyway.

So I should purge Recoll index and reindex?

I see the problem. Give me a bit to figure out how to fix it.

1 Like

It is getting installed to the wrong location. But even when installed to the right location, it doesn’t seem to work.

It just says, “loading folder…” forever. My index only has 131 files in it so it should be instant.

@dalto as usual… is always available for the rescue…

I highly appreciate it.

The Recoll app itself or Recoll in Dolphin?
The screen shot is strange for me, it is neither the app nor Dolphin!

Would the solution be here? ($HOME/.recoll-customconfig)
Or the website above (in German)?

WOW!
Recoll WebUI is a Python-based web interface for Recoll text search tool for Unix/Linux.

Out of curiosity, I searched github for “recoll dolphin”, I hope this can help.

Reading now about CatFish, it is in Dolphin… but first impression I saw a few reports that though installed Dolphin does not recognize it… (maybe noob users like me).
Will keep reading!