Issues with Baloo (stalled + no balooctl command anymore)

Hi,
I was waiting for this bug about baloo and btrfs not playing well together being resolved in KDE Frameworks 6 (in fact it has already been backported since 5.111), using Recoll as an alternative in the meantime,

thanks to these posts

Indexed Search with BTRFS (not Baloo)
Make Dolphin Use Recoll "kio_recoll" Installed

from @limotux and @dalto.

So, I have reactivated baloo indexing (from an empty index), but after a full night running, it has stopped at 29%. I purged the index and started it again: same result, stalled at 29%.
I have tried to find helpful commands in the arch wiki, but no luck, the balooctl command does not exist anymore!

Any idea for troubleshooting this?

Thanks!

Add a 6 to it. balooctl6.

1 Like

Nice, the output is:

balooctl6 status
Baloo File Indexer is not running
Total files indexed: 105.116
Files waiting for content indexing: 74.591
Files failed to index: 1
Current size of index is 1,04 GiB

I have a failed file, I will try to rename it.

Depending on what the file is. Maybe it just doesn’t support that kind of file. Anyways, I have the best luck with baloo when I don’t index everything. I try not to index git repositories, databases, icon sets, and hidden files since I don’t normally need to see those.

OK, I will try to exclude and filter a bit.
Is there a way to exclude, say, all */.git folders?

There was a “,” in a folder name, hence the failed file. However, renaming it has not changed anything, I cannot make baloo resume indexing…

If it has indexed everything, what else is there for it to do. For me it says it is in the idle state.

Edit: I don’t think there is a way to blanket specify all .git folders. I do it on an individual bases and keep all git projects in the same subfolder.

Ok, I have reinstalled it and excluded some large data folders, and the indexation has completed!
I think I have also got confused because the indexation stops when the laptop is on battery.
Apparently, .git files are filtered by default, according to the config file .config/baloofilerc
Thanks for the help :grinning:

Glad to be of service.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.