Desktop Search (file content)

It has been long time I was using Recoll to index my file content and search for the file content in Dolphin. Make Dolphin Use Recoll "kio_recoll" Installed
It worked fine since then. But I noticed today it is not working anymore. It does not find files by content. Dolphin could find only .txt files containing the keyword, but it seems to me it is a normal search not indexed search as I noticed it took a little while. It did not return a single PDF file that I am sure there are.

Doing the same search in the Recoll app itself it returns all files as expected.

Is the problem with Dolphin?
What can I do to fix this and get Dolphin to search again for content as it did before.

I am on KDE Plasma, BTRFS, Snapper…
I am using systemd-boot.

Would it be better to revert back to EXT4 and uninstall/disable Snapper (I would not like that as a matter of principle I should be using the latest technology whenever possible, but I won’t care about it if it doesn’t work for me)

Another option that came to my mind after I did some searches and readings, Gnome has built in Tracker that indexes file contents by default and works fine with BTRFS and Snapper. I do not mind doing a fresh install with Gnome if this is the best solution.

I hope there is a simple way to get Dolphin to do the search as before.
If not I am open to other solutions (Gnome or back to EXT4 and uninstall Snapper).

Any Ideas or discussions are welcome.
Thanks for your support.

It looks like kio-recoll is out of date.

I will take a look at it after work.

@dalto for the rescue as usual.

Thank you very much for your prompt reply and support.
(just out of curiosity and to learn more, even if it is out of date it is already there and installed, shouldn’t it just run as it used to do?!)


[limo@asus ~]$ yay kio-recoll
[limo@asus ~]$ yay -S kio-recoll
 -> No AUR package found for kio-recoll
 there is nothing to do

It depends what changed.

You could try rebuilding the current version to see if that fixes it. If not, it is possible the versions need to match.


14 aur/kio_recoll 1.34.0-1 (+5 0.00) (Installed)
    KIO Slave for recoll a full text search tool based on Xapian backend

kio-recoll (which is what you typed) is not the package name (which is kio_recoll).

Underscore, not hyphen.

Sorry, my bad, it is in the title of the thread on my first post with underscore.
Anyway, just reinstalled

yay -S kio_recoll

and rebooted, still the same.

I just pushed the latest version 1.35.0.

Although, for me, it was working prior to updating.

Thank you @dalto
I noticed there was an update

libtool: link: ( cd ".libs" && rm -f "" && ln -s "../" "" )
[  0%] Built target rcllib
[ 14%] Automatic MOC for target kio_recoll
[ 14%] Built target kio_recoll_autogen
[100%] Built target kio_recoll
Install the project...
-- Install configuration: "Release"
-- Installing: /home/limo/.cache/yay/kio_recoll/pkg/kio_recoll/usr/share/kio_recoll/welcome.html
-- Installing: /home/limo/.cache/yay/kio_recoll/pkg/kio_recoll/usr/share/kio_recoll/help.html
-- Installing: /home/limo/.cache/yay/kio_recoll/pkg/kio_recoll/usr/lib/qt/plugins/kf5/kio/
-- Set runtime path of "/home/limo/.cache/yay/kio_recoll/pkg/kio_recoll/usr/lib/qt/plugins/kf5/kio/" to ""
make: Leaving directory '/home/limo/.cache/yay/kio_recoll/src/build'
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> WARNING: Package contains reference to $srcdir
==> Creating package "kio_recoll"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: kio_recoll 1.35.0-1 (Fri Aug 11 10:42:30 2023)
==> Cleaning up...
loading packages...
resolving dependencies...
looking for conflicting packages...

Package (1)  Old Version  New Version  Net Change

kio_recoll   1.34.0-1     1.35.0-1       0.01 MiB

Total Installed Size:  3.46 MiB
Net Upgrade Size:      0.01 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                      [---------------------------] 100%
(1/1) checking package integrity                    [---------------------------] 100%
(1/1) loading package files                         [---------------------------] 100%
(1/1) checking for file conflicts                   [---------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 10193
:: Processing package changes...
(1/1) upgrading kio_recoll                          [---------------------------] 100%
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Checking which packages need to be rebuilt
foreign python-coloredlogs
(3/3) Performing snapper post snapshots for the following configurations...
==> root: 10194
[limo@asus ~]$ 

I did the update, rebooted, but still not working as it did before.

I installed Caja, it is working as expected and retrieving all files when I search by content.
Maybe the problem is with Dolphin (as Recoll as an app is working as well)?

It is working fine for me with dolphin. How are you doimg the search in dolphin?

If you remember I had a shortcut recoll:/ in Dolphin, from it I could do the search and it used to retrieve all files containing the word I am searching for, but now it does not seem it is using any indexed search and retrieving only .txt, .csv files (maybe it would retrieve some other text files)

It was working fine a few days ago.
Should I perhaps reinstall Dolphin?

I would run dolphin from the terminal and see if there are any errors that show up in the terminal when you do the search.

1 Like

It appears there are some errors

From that output, you aren’t doing any search with recoll.

I wonder if the issue is your shortcut.

What happens if you type recoll:/then into the address bar?

1 Like

Wow! I got some search results including PDF. .txt, .html…!

Well, again if you remember the last thread when I just added recoll:/ as a place and I could search with it. The place is still there and I still there.
I tried another search for other keywords but adding the keyword after recoll:/ and it worked.

Thanks a lot @dalto for the trick. Though I wonder why it just does not work from the search bar.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.