Update issues with mesa and xf86-video-intel

Several people have reported that the latest release of mesa causes issues when you are using intel graphics and have xf86-video-intel installed.

xf86-video-intel is only needed for very old Intel hardware (15+ years old). In most cases, you can remove xf86-video-intel to resolve the issue.

If you have very old hardware, the modesetting driver is supported on Gen4 or newer hardware. You can see the list of generations here:

If this solution doesn’t work, there are two options:

  1. Downgrade mesa
  2. Configure early KMS loading for your GPU as described in the wiki.

EDIT: This issue should be fixed in the latest mesa package 23.3.2-2


It says so much that it’s new years eve, and as ever, you’re around and supporting the Linux community constantly, incredibly grateful for the time and effort you put in.


Especially for the extra reason mentioned just above, I wish I had more than two thumbs, @dalto . :clap: :clap: :clap: :+1:


GNU/Linux is the most important thing!!


I salute our forum’s most advanced A.I. @dalto !


Yeah, my 14+ year old laptop with mesa and xf86-video-intel (i915) won’t start the graphics session. Xorg just segfaults. TTY works fine.

I’m too drunk to troubleshoot it right now, as my New Year’s party just finished, but it’s something that awaits me later today.

Off topic, I’m a bit pissed off at it, because I couldn’t tune my harpsichord properly for the party (because the tuner program I wrote runs on this laptop). So I had a party with a slightly out of tune harpsichord! What a scandal, can you imagine? I had to explain to my friends that I use Arch.


That probably isn’t old enough that it requires xf86-video-intel.

Are you sure that wasn’t caused by the alcohol? :rofl:

1 Like

Good point!

Let’s see, @Kresimir, how many :clown_face:s do you see?

I’m not sure, if the case is the same, but downgrading mesa was the solution for my AMD CPU with NVIDIA GPU Updated mesa package causes Xorg segmentation fault `reached target graphical interface`
And off course I don’t have xf86-video-intel installed.

I’m having the same issue on my laptop with Intel HD 4000 + NVIDIA GeForce GT 740M (currently powered off). xf86-video-intel is not installed. Had to downgrade mesa for now.

i see some users reporting the same on telegram… intel GPU but no xf86 driver installed and downgrading mesa is bringing x starting again…
If someone find a BUG report on mesa or arch please link here so we can investigate more.

1 Like

downgrade mesa

thanks to Philip posting this on calamares channel :wink:


A short time fix for some might be to try running mesa-amber. This worked for me as Virtualbox was failing to load X on a recent arch based vm.



684d11421c30c0f8230ccbcc8dcc94a457eb5f44 is the first bad commit
commit 684d11421c30c0f8230ccbcc8dcc94a457eb5f44
Author: Jesse Natalie jenatali@microsoft.com
Date: Mon Dec 18 10:44:25 2023 -0800

d3d12: Only destroy the winsys during screen destruction, not reset

Fixes: 81c8e89f ("d3d12: Fix screen->winsys leak in d3d12_screen")
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/26744>
(cherry picked from commit 325fb6e26b62326c86514d263ffedd241fd36865)

.pick_status.json | 2 ±
src/gallium/drivers/d3d12/d3d12_screen.cpp | 8 +++±—
2 files changed, 5 insertions(+), 5 deletions(-)


i have no such issue even using xf86 package…

Had a machine with AMD cpu and NVIDIA gpu with the same message at boot. Not sure if it is the same issue exactly but i fixed it with:


Login at the prompt, and then:

sudo nvidia-xconfig (enter)


Had this issue on a Thinkpad with NVIDIA. Didn’t see the top of this post on my phone at first, but pacman -R xf86-video-intel and reboot fixed the issue.

[joe@mars ~]$lspci -k |grep -EA3 ‘VGA|3D|Display’
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
DeviceName: Onboard IGD
Subsystem: Dell HD Graphics 620
Kernel driver in use: i915

The only option for me that worked was downgrading mesa 23.3.2 back to 23.3.1.