Update issues with mesa and xf86-video-intel

Pretty much my oldest intel i3 wth maybe an intel 3500 graphics card broke with the Mesa update. Symtoms in Gnome:

  1. Login screen showed staticy rainbow when you choose dropdown to switch between x11 and Wayland.

  2. Nautilus will start and crash (x11 and Wayland).

  3. Gnome session will crash in 10 mins with an unexpected error.

I used downgrade to go back to previous version of mesa and everything is working again.

1 Like

Seems mesa released another release, all my VMs now working without downgrading.
mesa version 1:23.3.2-2

4 Likes
1 Like

can someone validate that it is recommended if using xf86-video-intel to go with mesa-amber ? will get complicated to support legacy intel if so…

I was able too boot my VirtualBox VM by enabling the KMS thing on dracut.

I created a /etc/dracut.conf.d/vmware.conf file with this

force_drivers+=" vmware "

Since some posts were saying the KMS thing was the correct option, and the wiki didn’t include this driver, I think this is worth posting.

It should be fixed with the most recent version of mesa at this point.

1 Like

I have a old laptop that could run a test or two that doesn’t support UEFI. At this time one is running Arch without using xf86-video-intel or mesa-amber without issue after yesterdays update. I actually booted it yesterday and updated the old toy.

I can confirm that the latest mesa update has fixed my setup.

Hi Joe,

I wanted to let you know that the latest Mesa did not full fix my Intel i3 laptop with intel 4500 graphics on Gnome. The rainbow static effect around the change between x11 and wayland was gone. But I was unable to launch Nautilus. So I downgraded again.

Not tried start in terminail for error feeeback? Check journalctl mayby forbfeedback

is this very early i3 ? like i do not see it here:

These are the specs on that specific laptop:

System:
  Kernel: 6.1.69-1-lts arch: x86_64 bits: 64 Desktop: GNOME
    v: 45.2 Distro: EndeavourOS
Machine:
  Type: Laptop System: Acer product: Aspire 5741 v: V1.23
    serial: <superuser required>
  Mobo: Acer model: Aspire 5741 v: V1.23 serial: <superuser required>
    BIOS: Acer v: 1.23 date: 04/25/2011
CPU:
  Info: dual core Intel Core i3 M 350 [MT MCP] speed (MHz): avg: 2261
    min/max: 933/2266
Graphics:
  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
  Device-2: Chicony 1.3M Webcam driver: uvcvideo type: USB
  Display: wayland server: X.Org v: 23.2.3 with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: X: loaded: intel unloaded: modesetting
    dri: i965 gpu: i915 resolution: 1366x768~60Hz
  API: OpenGL v: 4.5 compat-v: 2.1 vendor: intel mesa v: 23.2.1-arch1.2
    renderer: Mesa Intel HD Graphics (ILK)

2010 released… but Gen5 already…

so you are using modesetting driver from kernel? and not the xf86-video-intel package…

i have an even older intel gpu:

[joe@joe-t60 ~]$ inxi -Gaz
Graphics:
  Device-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics
    vendor: Lenovo ThinkPad R60/T60/X60 series driver: i915 v: kernel
    arch: Gen-3.5 process: Intel 90nm built: 2005-06 ports: active: LVDS-1
    empty: DVI-D-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:27a2 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 compositor: Picom v: git-b700a
    driver: X: loaded: intel dri: i915 gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.63x7.99")
    s-diag: 338mm (13.3")
  Monitor-1: LVDS-1 mapped: LVDS1 model: Apple Color LCD built: 2002
    res: 1024x768 hz: 60 dpi: 86 gamma: 1.2 size: 304x228mm (11.97x8.98")
    diag: 380mm (15") ratio: 4:3 modes: 1024x768
  API: EGL v: 1.5 hw: drv: intel i915 platforms: device: 0 egl: 1.4
    drv: i915 device: 1 drv: swrast gbm: egl: 1.4 drv: i915 surfaceless:
    egl: 1.4 drv: i915 x11: egl: 1.4 drv: i915 inactive: wayland
  API: OpenGL v: 4.5 compat-v: 2.1 vendor: mesa v: 23.3.2-arch1.1 glx-v: 1.4
    direct-render: yes renderer: i915 (: 945GM) device-ID: 8086:27a2
    memory: 187.5 MiB unified: yes

this is only working with the package installed, and it will always have glitches on wayland when running GNOME or KDE even on X11 in KDE with effects enabled it will have problems, i can run fine on sway, cinnamon (wayland) and indeed i3wm lxde lxqt budgie…

On the Acer I mentioned, It is using the xf86-video-intel driver.

I just started testing on my development laptop (Lenovo T450) and changed from the xf86-video-intel to modset kernel settings through dracut:

 CPU: Intel i5-5300U (4) @ 2.900GHz
 GPU: Intel HD Graphics 5500

Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: DP-3
    off: eDP-1 empty: DP-1, DP-2, DP-4, DP-5, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300

/etc/dracut.conf.d/eos-defaults.conf contents:

omit_dracutmodules+=" network cifs nfs brltty "
force_drivers+=" i915 "
compress="zstd"

The only concern is there is 2 or 3 flashes on initial boot (After picking LTS Kernel in Grub) like it is changing refresh rates or resolutions. So I have not found a solution for this yet.

Performance does not seem to change.

Looks like this issue isn’t fully fixed yet.
Today, after starting my laptop, I got a screen full of noise instead of the login screen.
Using the fallback initramfs worked, so I updated my system but I still got the same behavior.
I removed xf86-video-intel and now it’s working again.