Unusually terrible performance with an RX 570

As some of you know, I recently switched to a PowerColor RX 570 4GB. I was hoping to get better game performance with that GPU since it’s much stronger than my old GTX 750 Ti 1GB, but to say it was a disappointment is… an understatement. Not only is the 570 underperforming on EndeavourOS compared to many benchmark videos and reports I’ve seen, but in at least two cases the 570 is actually somehow performing worse than my 750 Ti did, despite how it should by all logic be massively outperforming the 750 Ti (not least because it has four times the VRAM of that old card!).

  • Need for Speed: Hot Pursuit 2 (2002):
    • 750 Ti framerate: 120+ FPS
    • RX 570 framerate: 16-26 FPS + mild stuttering
  • Portal 2 (2011):
    • 750 Ti framerate: 60 FPS
    • RX 570 framerate: 27 FPS + heavy stuttering

Most other games still have better performance than the 750 Ti, but still heavily underperform:

  • Subnautica: Below Zero:
  • Euro Truck Simulator 2:
    • Expected framerate: 200+ FPS @ Ultra
    • Actual framerate: 45-60 FPS @ High (GPU consistently runs at 95-100% usage and extremely hot, near-80°C temperatures; if the GPU goes over 100% usage, the framerate immediately tanks and the game stutters very heavily)
  • The Outer Worlds:
    • Expected framerate: 56-80 FPS @ Ultra
    • Actual framerate: 29 FPS @ Medium + mild stuttering

I could provide more benchmarks, but I think these speak for themselves. My GPU is pretty clearly gimped because it shouldn’t be struggling so much with these games, let alone be overperformed by a budget GPU from several years ago that was also being severely held back by glitchy drivers.

I’ve tried everything I could possibly think of. I double-checked to see if I’m running the correct drivers (AMDGPU, Mesa and Vulkan-Radeon), installed all the necessary Wine and GloriousEggroll dependencies needed, disabled window compositing, tried the LTS kernel and am currently running on the Zen kernel, but no dice - I still get horrible performance that makes me question whether shelling out huge figures for a new GPU was worth it when it’s barely any better than the one I replaced.

I went as far as to installing CoreCtrl and creating several profiles for my games cranking up my fan power to 100% at 65°C and my GPU’s core clock speed up to its maximum of 1250 MHz, but no dice - those games still run horribly and I didn’t really get any better performance compared to what I had without CoreCtrl.

Computer specs:

  • OS: EndeavourOS Linux x86_64
  • Kernel: 5.15.11-zen1-1-zen
  • CPU: AMD Ryzen 5 3600 (12) @ 3.600GHz
  • GPU: AMD ATI Radeon RX 570 4GB
  • RAM: 16 GB
  • Resolution: 1920x1080
  • Desktop Environment: XFCE 4.16

inxi -Ga:

  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Tul driver: amdgpu v: kernel bus-ID: 08:00.0 chip-ID: 1002:67df
    class-ID: 0300
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: amdgpu unloaded: modesetting alternate: ati,fbdev,vesa
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102
    size: 480x270mm (18.9x10.6") diag: 551mm (21.7")
  OpenGL: renderer: AMD Radeon RX 570 Series (POLARIS10 DRM 3.42.0
    5.15.11-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.2 direct render: Yes

lspci -k | grep -PA3 ‘HDMI|Display’:

08:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
	Subsystem: Tul Corporation / PowerColor Device aaf0
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

inxi -Fxxxza --no-host: Pastebin Link

pacman -Q / Video drivers I have installed:

$ pacman -Q | grep amd
amd-ucode 20211027.1d00989-1
xf86-video-amdgpu 21.0.0-2

$ pacman -Q | grep amdgpu
xf86-video-amdgpu 21.0.0-2

$ pacman -Q | grep radeon
lib32-vulkan-radeon 21.3.2-1
radeontop 1.4-1
vulkan-radeon 21.3.2-1

$ pacman -Q | grep vulkan
lib32-vulkan-icd-loader 1.2.202-1
lib32-vulkan-radeon 21.3.2-1
vulkan-icd-loader 1.2.202-1
vulkan-radeon 21.3.2-1

$ pacman -Q | grep mesa
lib32-mesa 21.3.2-1
mesa 21.3.2-1
mesa-utils 8.4.0-6

cat /sys/class/drm/card0/device/pp_dpm_mclk:

0: 400Mhz 
1: 1000Mhz 
2: 1500Mhz *

cat /sys/class/drm/card0/device/pp_dpm_sclk:

0: 300Mhz 
1: 588Mhz *
2: 952Mhz 
3: 1046Mhz 
4: 1112Mhz 
5: 1174Mhz 
6: 1215Mhz 
7: 1250Mhz

I’m guessing the problem may be related to this? It seems the GPU is brute-forcing itself to run underclocked at 588 Mhz and rejecting any attempts to raise the clock speed (trying to change it with echo '7' | sudo tee /sys/class/drm/card0/device/pp_dpm_sclk just gave me tee: /sys/class/drm/card0/device/pp_dpm_sclk: Invalid argument). But, again, I’m running CoreCtrl and set the GPU to run at 1250 Mhz and it reports itself as running at that speed, to it shouldn’t be causing my bad performance…

I apologize in advance for constantly flooding this forum with threads asking for help… I’ve tried to resolve this on my own (even went as far as reinstalling the entire OS hoping it was just a borked installation), but I just couldn’t get it to work and had no option but to ask for assistance here. :c

1 Like

I have switched from RX460 to GTX1660S this year, with the same problem. Now i’m my no means an expert but after 3 months of sending parts back and forth multiple times for service, it was my motherboard that was faulty (i also changed the motherboard). If you still can try to put your GTX750Ti and measure again, just to be safe.

That’s impossible. I’ve had this motherboard for less than a year (since March 2021) and it always worked just fine.

My 750 Ti ran just fine on Windows, but was immediately gimped on Linux as well and ran horribly. When I switched to my RX 570, it seemed to run pretty well on Linux Mint but was immediately gimped when I switched to EndeavourOS.

Can a motherboard really die in less than a year? It’s an Asus B450M-Gaming, if that helps. It glows an orange light when it’s powered on, but I’ve read that it’s normal and just indicates the motherboard is receiving power.

Yes, 100%. Pretty much anything can break at any time. The probability just gets higher the older it is.

That being said, I think it is a bit early to point fingers at the hardware here.

If you are getting substantially better performance on Linux Mint than EndeavourOS, it seems more likely it is an issue with the drivers or other missing packages/configuration.

Hopefully someone more familiar with gaming performance will jump in.

1 Like

Sounds like it may not be getting enough power. What model power supply do you have? Also links for the exact model of gpu both old and new?

My Rx 580 was under performing as well. You can read about it here
Long story short is that the power limit was not set correctly for me.
I see you’ve installed corectrl. Have you gone to advanced and increased your power limit?

1 Like

I have a Corsair CX600, which supplies 600 W of power. I’ve run my setup in PCPartPicker before upgrading (don’t mind the CPU compatibility warning, my Mobo already has an updated BIOS), and it consistently reported me as using a wattage well under the maximum amount of power my PSU can supply (314 W), so I really don’t want to believe that the issue is with my PSU. After shelling out so much money for my GPU, I simply don’t have the money to buy a new PSU. Sadly, it is from 2017…

I have no idea what was the specific model of my 750 Ti since it’s been so long, I didn’t know anything about computer parts back then, and I no longer have the box for it. However, my current GPU is a PowerColor Radeon RX 570 Red Dragon (with 4 GBs of VRAM, and clocking up to 1250 MHz).

The Power Limit on CoreCtrl was always set to its default maximum of 120 W, and I never decreased it. I also set the Power profile to “3D Fullscreen”. CoreCtrl always reported my GPU as using up to 120 W of power and with the voltage really high up when I’m playing a game with a profile on it, so I don’t think it’s that. For what it’s worth, here’s my Radeontop feedback while running Euro Truck Simulator 2 (with my GPU killing itself running at nearly 90°C with both fans blasting at 100% power and very heavy stuttering and visual artifacts everywhere) - I don’t understand most of what’s in it…

Since the GPU is getting adequate wattage and the voltage on it is running high, as well as CoreCtrl’s clock speed change function seemingly working as intended, I sincerely don’t know what’s wrong. At this point I’m worried I was sold a counterfeit card or something like that.

I’ve been pointed to a thread in the LTT forums mentioning a switch on the RX 570 that supposedly toggles the GPU’s clock boost into an overclocked mode with higher power, but a post implied that might be specifically for the Red Devil model (which is stronger than mine). Not only that, but I found another thread from someone asking about it for the Red Dragon model, and a moderator said it’s really just a way to switch into a backup BIOS mode in case the GPU’s main BIOS gets broken or something like that, and has nothing to do with overclocking and OP shouldn’t change it. So I’m rather confused and skeptical that my GPU may even have a performance/economy switch.

EDIT: I took screenshots of some benchmarks I ran on Subnautica: Below Zero, both on CoreCtrl + my profile settings, and in-game with MangoHud. My GPU’s fans were pretty much on near-full blast the whole time due to how much they were ovrheating from 100% usage plus the constant stuttering and lag.

Okay, so you say it’s reaching 90°C. That’s max temp. It will shutdown if it hits 94°C so it’s automatically throttling. I’d say you’re have cooling issues.

It could be the fans, it could be the thermal paste or it could be both. Maybe low airflow is causing it, I’m not sure.

80-85°C is normal gaming temps for most stock coolers on these cards. But if you’re reaching 90 that’s where I’d start looking


That’s just on ETS2, other games don’t overheat it as much - I was able to keep my GPU around 65°C on Subnautica with maximum fan powers and around 70°C on The Outer Worlds, yet the GPU still underperforms. Need for Speed: Hot Pursuit 2 has the absolute coolest temperature out of all of them (56°C, never above 60°C), yet that game still lags hard.

I don’t think it’s thermal paste because this card is factory stock.

Maybe try amdvlk instead of RADV?

Already tried AMDVLK before, it actually ran slightly worse.

Well, I’m out of immediate ideas. I’ll think about it some more and maybe someone else has some.
I’ve never tried those games myself so don’t know exactly what you should be seeing performance wise for them on linux.
You could check this out and download the openbenchmarks to have a good comparison. Maybe the games you tried are just poorly optimized for linux?

I’ve always checked ProtonDB reports for their performances. For example, ETS2 has a native Linux port, but it’s known to have severe performance issues compared to the Proton version. Subnautica: Below Zero has a Platinum rating on ProtonDB and everyone says it runs just like native (with some saying it runs better than Windows), yet here I am getting severe lag and stuttering on it in the Medium graphics settings despite the RX 570 being listed as a Recommended card for it and thus entitling me for the highest possible settings. Even some games that have an actually good Native port like Hearts of Iron IV visibly lag for me on my GPU.

So I’m heavily disinclined to believe the issue is with poor optimization. Especially considering how NFS Hot Pursuit 2 actually ran better on my 750 Ti than on my RX 570.

Plus, don’t forget: the GPU seemed to run just fine on Linux Mint. It only got heavily throttled and underclocked when I switched to Endeavour.

My point is a lot of GTX 750 Ti gpu’s can run solely off of the power provided by the pcie slot on the motheboard, some require a 1x6 pcie cable from the power supply. The RX570 on the other hand can often require a 1x8 pcie power connector. Verify that you are using the correct connector, and that it is fully seated.

This comment makes very little sense. If the card is factory stock, it now has 4-5 year old paste on the GPU, which means it is likely dried up and not very thermally conductive. Re-paste it with some good thermal paste. I usually use Thermal Grizzly Kryonaut or Noctua NT-H2 either should work. Thernal Grizzly is better for temps but does not last as long. I have a fairly regular maintenance plan on all my equipment and tend to replace it every two years regardless.

Voltage running high = producing more heat. If you can adjust this down without causing stability issues you should see better performance.

Are you turning off XFWM compositing while gaming. It won’t do it automatically unless you scripted it to do so. Reason I ask is that you mentioned Linux Mint not having this problem, which brought to mind 1) Xfce or Cinnamon. Cinnamon does not have this issue. or 2) Linux Mint has a lot of built in automation, and I doubt their Xfce edition is any different. It may be doing this for you automatically.

Also I would use the lts kernel for initial troubleshooting, once you have satisfactory performance there, then I would play around with alternative kernels. I have tested a lot of different kernels on a lot of different distros over the years, and the headaches that come with using only a non standard kernel are never really worth it. The ROI is minimal and often negative. Always keep lts available, and outside of extremely new hardware the likelihood of a drastic difference with a tuned kernel is unlikely.

As a sidenote, Xfce is not well optimized for gaming, at least without some tinkering.
Cinnamon is a better choice, since its compositor can un-redirect fullscreen windows.
(ie. desktop compositing always on without performance loss in games).

Crap. Uh, is there any way to verify it without opening the case?

I… guess that does make sense. That said, I feel the temperature issues may be related to poor ventilation rather than the thermal paste, because my CPU also regularly gets extremely hot and runs around 90°C as well. Unless my CPU also has bad thermal paste… Hopefully this issue can be resolved by getting a new cooler (I only have stock ones) since I really don’t want to go through the hassle of reapplying thermal paste on it :confused:

Is there a way to reduce voltage without reducing the power limit? On CoreCtrl, I only have the option to reduce the power limit to control my voltage by proxy, and while decreasing it to 100 W or less did help with the overheating, it also messes too much with the card’s power - at one point it’s overheating too much and making the card throttle itself, but decreasing it by a few W means it’s no longer getting the power it needs to maintain the clock speed running at maximum efficiency.

I suppose there is the amdgpu-clocks script KDen shared, but it looks rather complicated to manage and setup for a dumbass like me…

…Wow. It seems that disabling compositing does indeed help! I went from struggling at 25-29 FPS to getting 42-60 FPS in Subnautica Below Zero:

Sadly, it still seems to leave plenty to be desired despite the improvement, as the framerate is still unstable sometimes (running around 50 FPS with VSync that often drops to the low 40s and massively increases GPU usage and temperature; disabling VSync consumes less GPU power but has choppy frames and screen tearing) and some games (like Forza Horizon 5) display severe graphical issues when running with compositing disabled - FH5 in particular had the screen flicker to pitch black every other second, making it rather unplayable. Plus, the desktop looks rather ugly with window compositing disabled…

I’m really disappointed that XFCE isn’t optimized for gaming, I came to really like it since it hits the exact sweet spot between customizability and usability I want :frowning: I love Cinnamon, but it’s not as tweakable and has an incredibly annoying issue where image thumbnails refuse to display, and KDE Plasma is absurdly complicated, convoluted and buggy. Are there any tweaks I can do to make XFCE play nice with my graphics card?

I find it weird that it’s apparently unoptimized; I have a friend who runs Arch on XFCE and she never had any issues like this with compositing.

You can test this theory without buying a cooler. Just run it with the case open.

1 Like

Your card does have an 8 pin PCIE connector.

Quick_install_Guide.pdf (630.7 KB)

Edit: Since you said you took the computer in to have it installed with a drive i would assume they hooked it up so i doubt that it is an issue.


Just my 2 cents…This article is an interesting read. Apparently Gnome/Wayland is the better gaming DE.

KDE/GNOME Wayland vs. X.Org Radeon Linux Gaming Performance - Phoronix

I would be very wary of any Phoronix benchmarks. Every test I have ever read from them has been setup in some fundamentally flawed way. I eventually just stopped reading them.

I would be very cautious about drawing conclusions for their tests.

They have a great Linux news feed though. :wink: