Severe performance drop after upgrade (6.3.4 -> 6.3.5)


I’m hoping someone might have ideas for me, as I’m frustrated beyond belief. I run EndeavourOS with Hyprland (Wayland) on a Nvidia RTX 3070 (My system stats say it’s a Ti, but I’m pretty sure that’s wrong). I had previous problems with performance in certain games (notably Satisfactory and DOOM, but also a builder called Fabledom and Timberborn) which were solved by installing the lib32 mesa and vulkan drivers detailed in the solution to this post; suddenly I was hitting 144 FPS on ultra settings at 1080p – which is all I really need to play at right now. Every game I had worked wonderfully.

Then, yesterday, I upgraded my system. Kernel went from 6.3.4 to 6.3.5, with the relevant libraries and etc updated as well. And like magic, I’m back to unable to produce even 30 FPS consistently. Satisfactory is lucky to get 27 FPS on Ultra 1080p, while DOOM runs the medium settings at ~45-55 FPS. Killing prefixes does nothing, changing Proton versions doesn’t work, and moving to different rendering engines in Satisfactory makes no difference. (I’ve tried Vulkan, DX12 and DX11, no differences in practice. Boot screen goes to 450 FPS in DX12, but once it gets into the main menu it drops to 22 FPS and stays about there.) Fabledom can’t get more than 19 FPS, while Tiomberborn stutters like mad and gets ~ 45fps.

If anyone has any ideas, I’d appreciate it. Or even if anyone else is seeing it, just so I don’t feel so alone, lol. I saw that another person in Reddit was having FPS hits when they moved to 6.3.4, but they had an AMD card, so I’m not sure it’s related. I can confirm that the Nvidia card stays at 100% utilization the entire time, for all the good that’s doing. I know Nvidia isn’t recommended for Linux, but I really can’t afford to buy a new setup just for an AMD card – particularly as I have to have a laptop for work, and this fits the bill.

The results of: inxi -FAZ --no-host | eos-sendlog

I’m not 100% sure how to post just the list of what’s been upgraded via the command line but I can copy the packages upgraded from the pacman.log to a pastebin as well if that would be helpful. Help or sympathy would be greatly appreciated, but if not, no worries, it’s not really your jobs. Just figured I’d ask! I’m not a Linux newbie exactly, but I’m far from a Developer either, so I’m not really sure how to go about downgrading or further troubleshooting.

Device-2: NVIDIA GA104M [Geforce RTX 3070 Ti Laptop GPU] driver: nvidia
    v: 530.41.03
API: OpenGL v: 4.6 Mesa 23.1.1 renderer: Mesa Intel Graphics (ADL GT2)

It is an Nvidia RTX 3070 Ti. I doubt very much it would be reporting that if it wasn’t. You are not rendering on the Nvidia card. It’s using the Intel graphics. Have you never switched graphics to run games?

Oddly, Dell doesn’t actually list the card as a Ti in my purchase order… which I suppose shouldn’t surprise me. I used to work for them, and it wouldn’t be the first time I’ve seen them mess up a spec sheet. Works out for me though! I’ll definitely take a Ti over a base 3070!

Re switching, honestly I haven’t. The Optimus configuration has always been finicky for me no matter what distro I’m running, but usually it ‘just works’ – sometimes I have to generate config files for Nvidia to get the second screen working, but that’s been the extent of it. Or at least it was until the latest update. I’m honestly not sure what changed.

I just tried using __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia %command% in Satisfactory’s launch options, as well as prime-run steam and launching, but neither seems to make an impact.

The Arch Wiki for Prime lists a way of setting up X11 to use the Nvidia card, but I don’t see anything for Wayland specifically. I’m kind of new to using Wayland, so I’m looking around now. I’lm also downloading Envycontrol to try that – I’ll let you know my results. Thank you for the help!

I’m not sure that Wayland would have an impact on switching? :thinking: Wayland does work with nvidia as far as i know using EGL streams. Not sure what desktop you are using and I’m also not sure about the hybrid hardware on the Dell how it is set up to work. There aren’t any settings in the Bios to set integrated, dedicated or hybrid are there?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.