Unable to launch CS GO

I moved from Pop to EOS, installed Steam and I’m unable to launch EOS.

This might be related to Counter Strike - black screen and closes (unless it doesnt)

I tried

  • no Proton => Game starts with a black screen
  • Proton experimental => Launcher Error
  • Proton 8 ( latest stable? ) => Launcher Error

and some launch options ( taken from ProtonDB ), e.g.

-vulkan -novid -nojoy

but that didn’t help. Do you have any ideas what might be missing?

Make sure you meet requirements

CSGO won’t work via Proton. You need to run it natively.

I’ve had the black screen issues as well. You just have to keep trying to open it until it eventually opens normally.

There is a nice flatpak steam client. It works fine for me. You could give it a try.

Hm the day before it worked with POP, perfectly fine…

Tried multiple times now :confused:

P.S. other games like GTFO or Mechabellum work perfectly fine. I think this problem is related to CSGO only.

I am fairly certain that that’s not true.

Trying to launch CSGO via Proton results in Steam error message every single time.

No, sorry. I didn’t try to launch it with Proton. But CS GO worked fine on Pop

My bad, I thought you misspelled POP and wanted to say Proton :slight_smile:

Interesting question since I have it on steam and this is exactly my scenario trying to use it. . .

What should I do to be able to play it?

You need to run it natively, meaning this:

Right click on the game, Compatibility tab and then make sure it’s not running any compatibility tool as in my screenshot.


Still crashes :frowning: I get this right before the crash report - Fedora 38, updated, steam flatpak, pretty much every other game still works.


I’ll post more relevant info if needed later.

Lenovo Legion
AMD Ryzen 7 5800
AMD Radeon 6600x GPU

Sounds like the same issue I had. Try the command below and reboot once done. Then csgo should launch fine.

sudo pacman -S mesa lib32-mesa mesa-vdpau lib32-mesa-vdpau lib32-vulkan-radeon vulkan-radeon glu lib32-glu vulkan-icd-loader lib32-vulkan-icd-loader

Well, it’s on Fedora so it’s dnf. . . But I’ll compare notes. I use steam client via flatpak though so it should be all self contained…

Check out this guide. It’s a bit dated, but the information here solved my same issue that you are having. Go to the ‘GPU Drivers section’ to get the commands needed to download and apply the files you need for it to load.

I do find some sort of irony that it’s more difficult to play a native Linux game on Linux than the Windows counter part lol. I’ll take a look. I’m neck deep in cyberpunk currently so it’s not a very high priority.

Sorry to bother you, but did you manage to fix this?

I have the same error and I have tried those 3 launch options, but it didn’t work.

I’m not sure how this is still not addressed, but the answer lies in the screenshot below. Enter the command for your hardware and it will fix the steam game launching issues.


Omg thank you so much! I’m going to install it right now and try to start CSGO!

sudo pacman -S nvidia nvidia-settings nvidia-utils lib32-nvidia-utils lib32-opencl-nvidia opencl-nvidia libvdpau libxnvctrl vulkan-icd-loader lib32-vulkan-icd-loader