Strange fonts in Firefox (space and characters)


I obviously tried other fonts besides Noto Sans (Dejavu, Cantarell).
I also tried to use fc-cache --really-force
The font of the numbers and space is also very strange

Slightly related :

Thanks for the reply. I’ve tried but the result doesn’t change (and changing that systemwide setting makes the fonts a bit blurry anyway)

To be precise, I put “none” for character hinting

I found this :

Here @keybreak provided detailed explanation for this issue. This whole topic is worth a try.

It’s not that issue, i think…spacing that wide i have no clue except problems with font / specific de font rendering engine :man_shrugging:

I felt there is something to do with rendering of the fonts as the last image is describing irregular spacing of the fonts.

Similar issue :

Might be worth a try: create a fresh profile and see if you still have the issue.

1 Like

In the aforementioned link, there was discussion that after removing specific fonts, the issue can be fixed…

I got this from Mozilla website:

I made a few attempts

I added

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "urn:fontconfig:fonts.dtd">
  <match target="font">
    <edit name="embeddedbitmap" mode="assign">

in the file /home/salvatore/.config/fontconfig/20-no-embedded.conf and nothing has changed

I tried going to give

sudo ln -fs /usr/share/fontconfig/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/


fc-cache --force

But it did not work

I created a new user with all settings clean, and the fonts are still the same


The folder ~ / .fonts is not in my home, but I tried to look for the fonts named in the topic but they are not in my system

Hardware acceleration is not active in my firefox

PS: Thunderbird doesn’t have this problem. Which is weird. Obviously I tried to put the same fonts as in Thunderbird, but it hasn’t changed.

In any case, the problem is not that urgent. it’s very annoying but I can live with it

Weird question, but are you 100% sure that Noto fonts are actually installed? :sweat_smile:
What’s your de?

Gimme a break! Even i can’t live with your problem :cold_face:

They are installed, my DE (KDE Plasma) has the default Noto Sans fonts. Do I have to install Noto-sans-extra as well?

1 Like


Take a screenshot of:
Settings → Appearance → Fonts


I also tried with full

1 Like

Looks good to me, but:

  1. Fixed width should be set to Noto Mono, not Noto Sans :wink:

  2. Try to disable Force font DPI see if it makes difference

Removing “force font DPI” made firefox shrink but fonts always have a strange space

By strange you mean as huge spaces as it were in op? :upside_down_face:



Yep. is it strange that only Firefox has them and not Thunderbird, in theory they are not “similar” programs?

I would suggest to start from a clean user profile, if you want really to find the problem and not just playing around Sherlock :mag_right: :wink:

1 Like