Font rendering in Firefox and Chromium looks very different

I have done my research, I initially tried fixing CJK fonts rendering looking shit, I fixed that with the following .conf file in ~/.config/fontconfig/conf.d

Below is my problem, see the characters i and I (capital i)



I tried in Firefox (Arch repo), Firefox (Flatpak) and Librewolf(Flatpak), I am using Librewolf(Flatpak) at the moment. To compare, I opened the same page in Brave (Flatpak) and you can see clearly Firefox did not render as good as Brave. I enabled LCD filter as per suggestion by @keybreak but that didn’t fix the problem for me.

I also have to add that it does not seem to be a generic problem across all websites, but some website here and there. For example, the Endeavour OS forum does not seem to have this issue:

Now if I disabled the Firefox option “Allow pages to choose their own fonts, instead of your selection above”, everything looks cleaner again(Firefox):

I am not sure where to look into or what keywords I need to fix this annoying problem. Here is my font configuration in both browsers if it’ll help.

Here is output of pacman -Qs font

As you report, there is no issue. It is just a setting/preference.

The normal setting for this is to be enabled, so you see the websites as designed from their devs.
IIUC, you disabled this, so you have your local fonts FF selection displayed on all websites.

One possible reason for the bad rendering could be the display resolution (dpi), in combination with your FF selected font.
Maybe do some testing altering these settings to find a better result. :person_shrugging:

:point_up: :wink:

Thank you for the input. I tried everything you suggested long before I decided to take it to the Endeavour OS forum. After fighting this nuance for a month I finally decided to post as this seem to plague even my 1920x1080 laptop. I am using a 3440x1440 34" screen on desktop (and where I took my screenshots in OP). What I could not figure out is back on Ubuntu and Kubuntu, this problem did not occur, even with Global Scale on 100% instead of 125%.

I also have to add that adjusting DPI did not fix the problem for me. It was only after adjusting Global Scale from 100% to 125% the fonts become bearable.

Font render at 125% Global Scale 100% zoom in Librewolf:

1 Like

Then it could be a font setting, but it’s not fair :cry: to propose something I don’t bother/am lazy to do myself. There are plenty of instructions in Archwiki/fonts article that might improve your issue. :zipper_mouth_face:

Quick headsup
After fiddling with the settings more, I find that setting font hinting to none fixed the problem for me(was slight as per suggestion on various other websites on how to make font render normal on KDE/arch), reproducible on my laptop as well. Thanks for helping.

1 Like

Please, post exact actions of implementing this.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.