[SOLVED] Emojis don't render

It seems that in Linux you need to use a particular font (e.g. noto-emoji) to be able to get emojis rendered.

Why is it that on my Mac it does not matter which font I use, emojis are always rendered?

Possibly because the emoji font is installed?

Also not really sure how this is EndeavourOS-related…

No, because if I install a different font, and I have done so, the emojis are always rendered.

Good point. It is probably not specific to EndeavourOS, although it does seem to be specific to Linux, in my experience. And since I have now opted for EndeavourOS as my go-to Linux distro, I thought I’d raise it here.

However, if this issue is not something for this forum, you may close it or delete it altogether, and I apologize to have raised it.

On macOS? The emoji isn’t rendered using the current font, it’s rendered using an emoji font. This is the same on Linux distros too, which is why you need noto-emoji (or similar) installed.

I may have misunderstood what you were asking, I thought your question was this:

which seems to be a question about macOS.

sudo pacman -S noto-fonts-emoji

No, that was not what I meant. However, the issue seems to be Librewolf on Linux. With Librewolf on a Mac emojis are rendered fine, but using the same font in Linux does not render.

Anyway, that is not an EndeavourOS issue, I got carried away in my enthusiasm. Let’s close this issue, and if you can, please delete it altogether.


What the heck I need emojis for?!

:frog: :interrobang: :crazy_face:

In Linux?!




Oh, of course! :joy:

1 Like


1 Like

It would be more interesting to know how to get rid of the whole emoji catalog completely without damaging anything else.

But it doesn’t really matter, you can simply hide the nonsense in the menu.

1 Like

Thing is…

…me no like type long thought in (long) sentence…

…plus me hate long paragraph…

Me love show emoji!

…so you understand me without much word!


Intelligence receding I heard!
IQ of father greater than of son…

…because many people no know the power of emoji?

Maybe it’s from the translation, but I can’t do too much with your writing, at least I can’t find any reference to my thoughts above.


. :ok: .

Thanks for the link to your mini tutorial on the other page, that answers a few questions I have. :+1:

I am sorry to bother you again, but I still cannot get it to work, undoubtedly because I am not doing some things right.

In the Cinnamon system settings I have set everything to Victor Mono simply because I really like the font.


I use Espanso text expander, and in its file I have a smiley emoji that should get inserted in text when I type smx. That works well e.g. on this site: I typed smx to get this :grinning:. I am not even sure it is thanks to Twemoji.

However, when I type those 3 letters in e.g. a Disqus box, or in XED, nothing happens.

This is the contents of font.config file I compiled on the basis of your tutorial:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
     <family>Noto Sans</family>
     <family>Noto Color Emoji</family>
     <family>Noto Emoji</family>

     <family>Noto Serif</family>
     <family>Noto Color Emoji</family>
     <family>Noto Emoji</family>

    <family>Victor Mono</family>
    <family>Noto Color Emoji</family>
    <family>Noto Emoji</family>

I suspect it has something to do with your text expander program or with the programs this is used in (maybe a GTK vs Qt thing?). No idea.

You should open a new thread for that.