Second external monitor suddely stopped working after Kernel Update

Hey folks, hope you all do fine and have a nice day!

I run a Lenovo Ideapad 5 Pro 14ACN6 plugged into a Lenovo Universal USB-C . To that dock is connected a LG UltraGear 34GN850-B and a ASUS MG279Q as a second external monitor. Both are connected via display port.
I installed Endeavouros OS 2 weeks ago with KDE Plasma. Laptop and Dock have the latest firmware updates. The Kernel version back then was 5.19.something.
Everything was working perfect and as expected. After the kernel update to 6.0 a couple of days ago, my second external monitor “stopped” working. It works fine on my Windows work laptop (Lenovo t14 AMD version). Also it works fine on my windows 11 gaming rig. I tried different display port cables, nothing changed.
When I start the laptop there is some kind of linux/arch logo with a loading animation or something for a second or two which gets displayed on all three screens.
xrandr also recognizes both external monitors:

I reinstalled the whole thing because I thought I bricked something but after the kernel update it’s the same again, one monitor not showing any output even tho it gets recognized by the OS.

I then waited for a couple of days and some kernel patches plus I searched arch and linux related subreddits and this forum and waited for others with the same problem to emerge…but nothing :stuck_out_tongue:

I’m out of ideas because no one seems to have this problem after upgrading to 6.x. My last option seems to be to revert to the LTS kernel.

Maybe someone here can help me, thanks in advance and have a good day!

KDE Framework got an update from 5.98 to 5.99 and Plasma was updated to 5.26 all during the same period when Kernel 6.0 was released. You can of course try a LTS Kernel to see if it works out better. But Plasma and KDE could be the culprit as well…

Have you tried the LTS kernel to rule out kernel issues? As @PeterRies mentioned there have been a few updates to plasma also

Thanks for your answers! Yes at the time I also updated KDE. I initially downgraded to kernel 5.19 but it didnt help. I could have come to the conclusion myself that it’s rather KDE than the kernel… :smiley:

But there seem to bei quite a few others now with similiar problems on ryzen cpus

1 Like

Report the bug to KDE & I reckon it’ll be fixed fairly shortly with the amount of users that use it that seem to be facing similar issues

I filed a bug report with KDE a while ago, and so far not much of anything, 4 days of complete silence. Maybe more chiming in will get someone on the case:

I’m having problems again…the above problem was fixed a couple of weeks ago. But since a couple of days (around the time of Kernel upgrade to 6.1) the second monitor has no display output even tho it gets recognized in xrandr. I tried deleting the kscreen folders (which helped the last time) but to no avail.
Also this time the second monitor also shows no signal when logged out/when booting.
Same setup (same cables, same docking station) is working fine on an Thinkpad T14 gen 2 running Windows 10 (AMD 4850h I think) plus both monitors working fine on my gaming rig running Windows 11.
This seems to be no general problem as nobody here or on reddit seems to have the same problem.

Maybe some of you guys have some suggestions on how to fix this.

autorandr was suggested as a workaround… so you could check using arandr p.e. to enable the display and save the settings … they are saved as a script that can be used by autorandr i think…

This is a different issue and needs troubleshooting from the start.
I would suggest you start a new topic and post info in text (not screenshots).

journalctl -b -p3 --no-pager --no-hostname
journalctl -b -u sddm --no-pager --no-hostname
inxi -SMGaz