Lost one of two displays for one user only

Operating System: EndeavourOS
KDE Plasma Version: 5.26.0
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 6.0.2-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 5700X 8-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1050/PCIe/SSE2

After the system went into standby, when I unlocked the screen one of 2 monitors (the primary one at 4K) is black, no mouse pointer, nothing! reboot doesn’t help. In display settings the monitor is present, but not activated. I find and select it from the drop down list, and can change the resolution, but the refresh rate is not selectable, and it reads 30Hz with an i next to it, I click the i and get "30 Hz is the only resolution this monitor can display (it can do 60Hz for sure). I log off and log on to a different user account and all is well, both monitors work, and as usual.

Conclusion: Something wrong with Plasma settings of that one user account only.

Now, for the last week or so (I run updates daily) Plasma has not remembered any window sizes or positions, nor Icon locations after moving on the desktop between reboots. They seem to be stuck in time from when I used them one week ago.

Since only one user account is affected it must be related to one or more user specific Plasma display settings related files, and Plasma is not making changes to it/them, but now somehow did, but in a very bad way! Maybe it’s a module it uses to record changes, but I cannot tell yet until I logon to the other user account open a few apps resize their windows, move a few Icons around… reboot and see if the changes took, but I don’t want it to break too!

Any Ideas?

Hey mate,
I seem to have a similiar problem: Second external monitor suddely stopped working after Kernel Update and so does this dude: Second Display won't show content after update - #16 by Mathias

Hopefully there will be a fix soon. It seems to happen mostly to ryzen users

The last one is the busiest, so I added a link to the bug report on KDE there. We need to get the KDE people on the case!! :thinking: :face_with_monocle: :man_detective:

Here it is:


You might want to investigate more, looking into the files inside these folders:

$HOME/.local/share/kscreen/  # files with monitor layouts
$HOME/.local/share/kscreen/outputs  # files with monitors

It seems that monitor IDs in layout files, stay the same, while monitor names may change (depending on various reasons, like GPU connectors, drivers etc., I guess).

You may want to try deleting one, or more/all files, to see if this fixes your issue (because they should be regenerated fresh).

I would archive the existing files, for later comparisons with the new ones, to possibly assist the devs find the source of the bug.

1 Like

Had this exact same problem happen occasionally when waking computer from sleep or after powermanager turned monitors off.

Deleting files as suggested by petsam from kscreen and kcreen/outputs fixed the issue after relogin.

I did compare contents of share/kscreen during the issue and after deleting the files and letting them regenerate.

At this moment it seems that theres new second file generated to share/kscreen which causes the problem.

I ran diff of that and the regenerated file which fixed the issue;

“enabled”: true,
“id”: “3066698bce3510a47b13c7e3e971c17a”,
“metadata”: {
“fullname”: “xrandr-Samsung Electric Company-S24F350-H4ZJB04424”,
“name”: “HDMI-0”
“mode”: {
“refresh”: 60,
“size”: {
“height”: 1080,
“width”: 1920
“overscan”: 0,
“pos”: {
– “x”: 2560,
– “y”: 0
– },
– “primary”: false,
– “rgbrange”: 0,
– “rotation”: 1,
– “scale”: 1,
– “vrrpolicy”: 2
– },
– {
– “enabled”: true,
– “id”: “3c060961d691fc9a2e25f496dec9bb52”,
– “metadata”: {
– “fullname”: “xrandr-LG Electronics-LG ULTRAGEAR-112NTZN2Y789”,
– “name”: “DP-0”
– },
– “mode”: {
– “refresh”: 164.95774841308594,
– “size”: {
– “height”: 1440,
– “width”: 2560
– }
– },
– “overscan”: 0,
– “pos”: {
“x”: 0,
“y”: 0
“primary”: true,
“rgbrange”: 0,
“rotation”: 1,
“scale”: 1,
“vrrpolicy”: 2

OK, deleted files. Now I am going to reboot:

Goodby cruel world…

:heart_eyes: :exploding_head: :sunglasses: :stuck_out_tongue_winking_eye: :upside_down_face: :partying_face: It worked! My neck thanks you!

I still want the Plasma folk to fix this! I do donate plasma every year!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.