Seagate drive format disaster, need help

So my friend have bought this Seagate 10 Tb USB drive

  1. He formatted it on Windows 10 with option of FULL format (meaning when it zeroes all blocks)
  2. Obviously it took extremely long, so at some pretty early point he canceled it
  3. Long story short, now it reports size of ~460 Gb, instead of 10 Tb

We’ve burned EnOS live USB :upside_down_face: and i’ve tried every other idea in my arsenal of ideas…
None worked and even sudo fdisk -lu /dev/sdd reports that size now :confused:

Any help is appreciated, i have never seen stuff like that before.

Delete all partitions on disk and start over?

1 Like

Yep, already tried from scratch from EnOS with gparted:

  1. Deleted all partitions
  2. Set gpt table from scartch

It sees only those ~460 Gb of available unallocated space

Clearly what he did with Cancel button back on Windows 10 have corrupted something in a process

A little funny! :confused: No idea what it is then!

Shooting in the dark, but maybe dd-zero the whole thing again?

1 Like

I am running out but two options. dd it or use the windows terminal to low level format it.

1 Like

@pebcak
@Elloquin
I’d appreciate a step by step dd example, since both of us have no direct experience with it so far :slight_smile:

@Elloquin
On Windows terminal you mean like diskpart?

diskpart
select disk 4
clean
create partition primary
select partition 1
active
format fs=ntfs
assign
exit

Yep, i’ve tried it too, no luck

This comes with disclaimer, please do a bit of searching, but with dd you could “low-level format” the disk by filling it with zeroes. Here is an old article but, I guess it sums it up . I have only done this on USB flashdrives.

1 Like

I’ll leave dd zeroing as last resort, since if it will decide to do all 10 Tb instead of those ~460Gb it will be a looooooooooooooooooooong ride…

1 Like

Sorry a bit late! If you are going to dd, you could add status=progress to the command line to have some visual feedback that something is going on. Be prepared that it will take a loooong time to finish.

2 Likes

gparted ->device -> create partition table -> gpt doesnt solve every bad format problem? yah you def gots issues

:innocent:

You could still try using dd to clear the GPT table and partitioning information. (You’ll need to specify the appropriate device at the drive level after of= … )

# dd if=/dev/zero of=/dev/sdX bs=512 count=1

Then use gparted or fdisk to create your GPT table … if this still doesn’t show you the extra space, I’d be worried about some sort of physical damage having occurred to the disk, but even cancelling windows formatting shouldn’t cause that.

2 Likes

I mean…It’s Windows 10 after all :rofl:
But thx :slight_smile:

1 Like

What that means exactly? I’m not sure i get from man…

It means it reads one block.

1 Like

Sounds like an RMA to me.

Stop messing around and send the broken drive back.

3 Likes

Yep that was my thoughts too…But damn, that’s first time i see stuff like that :confused:
Not best day for my friend :laughing:

Might be interesting to see what smartctl reports - but RMA is likely!

1 Like

Something else must have happened for the capacity to drop from 10TB to 0.5TB.

They didn’t swap out the drive inside the enclosure, did they? :zipper_mouth_face:

3 Likes