NVIDIA update on Sep 23rd broke my video/display

Yesterday’s NVIDIA update broke my video. Screen going dead some seconds after GRUB menu and loaded libraries.
My video card is a GTX3060.
Computer is alive and I can ssh into it… so need to roll back to libraries versions before that update.
Just in case someone hasn’t updated these NVIDIA libraries, be careful.


Some issues being reported on the Arch end too. So far the only solution is to downgrade your nvidia packages


I had issues with the new GPU drivers as well. After updating and rebooting, I can see the logs (when the system boots) and then a black screen, can’t even switch to a TTY.

Tried Arcolinux and the same issue which I expected, ended up reinstalling EndeavourOS offline and haven’t updated so I can’t use steam due to library issues.

Strange as i never seem to have any Nvidia related issues on my GTX 1060 when updating drivers.


I downgraded all the libraries to Sep 22nd and now it works nicely.
In case someone needs help doing the downgrade, these are the steps I followed:
I will upgrade all until a new version of the NVIDIA libraries come out.

It’s possible the latest driver affects your RTX 3060 but not my GTX 1060 since mine is an older card and some of the updates may not be be used.


Everything seems fine with my GTX 1060.

Though issues with 515.76 driver are being reported on nvidia’s end as well.


Had this issue this morning. RTX 3080.

Downgrading nvidia-dkms and nvidia-utils to version 515.65 fixed it

sudo downgrade nvidia-dkms nvidia-utils

Consider yourself lucky with the hardware and setup you do have then. At least once a year, an Nvidia update causes any issue like this with my own MX150. Some people are even unluckier and experience an issue like this more than once a year. I find it more strange you don’t ever have any issues, but then again that’s a good thing after all :wink: :broccoli:

Funny thing is, I just reinstalled and my nvidia-dkms 515.75 and have no issue… but on vanilla arch im having a hard time with this issue.

Yes it is strange because this is also dual boot with Windows and i never have any issues updating and losing any entry in the boot loader either that people seem to have on this computer or my other dual boot Windows with Ryzen. Yes the grub issue got me but i think that got most users. In fact on this one the grub issue didn’t surface and also not on my other two dual boot laptops. I only got it on my machine i use the most. Probably it was that i updated only at the right moment and missed all that. :man_shrugging:

Edit: Updating right now which has the latest kernel and nvidia drivers 68 updates in total. I’ll reboot and see if any issues.


[ricklinux@eos-xfce ~]$ inxi -Ga
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: none empty: HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:3e92 class-ID: 0300
  Device-2: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: ASUSTeK
    driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-08) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none off: DVI-D-1
    empty: DP-1, DP-2, HDMI-A-3, HDMI-A-4 bus-ID: 03:00.0 chip-ID: 10de:1b83
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
    s-diag: 554mm (21.82")
  Monitor-1: DVI-D-1 mapped: DVI-D-0 note: disabled
    model: ViewSonic VX2260WM serial: R2S084206306 built: 2008 res: 1920x1080
    hz: 60 dpi: 102 gamma: 1.2 size: 477x268mm (18.78x10.55")
    diag: 547mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.76 direct render: Yes
[ricklinux@eos-xfce ~]$ 
[ricklinux@eos-xfce ~]$ uname -a
Linux eos-xfce 5.19.10-arch1-1 #1 SMP PREEMPT_DYNAMIC Tue, 20 Sep 2022 15:17:59 +0000 x86_64 GNU/Linux
[ricklinux@eos-xfce ~]$ 

Edit3: All good!

[ricklinux@eos-xfce ~]$ sudo pacman -Syu
[sudo] password for ricklinux: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Starting full system upgrade...
 there is nothing to do
[ricklinux@eos-xfce ~]$ 

Edit: The Nvidia driver is 515.76. Was there also a 515.75 as reported above? :thinking: Maybe that’s a typo?

1 Like

I have a perfectly good 3070 ti sitting in a box because I was just finally tired of these issues. Great card, but sick of forever breaks. Now very happy on an AMD 6900.

1 Like

I have seen reports that a

sudo mkinitcpio -P

fixes this.

I had to downgrade two more packages: lib32-nvidia-utils libxnvctrl for steam to run. Found out with pacman -Qs nvidia that the versions didn’t match with nvidia-dkms nvidia-utils.

Could you elaborate on this? It’s rather annoying to recover from this since tty isn’t working.

You are right, Steam was no longer working and started working after I also downgraded lib32-nvidia-utils libxnvctrl

So the final command is sudo downgrade nvidia-utils nvidia-dkms lib32-nvidia-utils libxnvctrl

To get to a terminal, from grub type e to edit the grub config for a single boot. Then find the kernel line, remove the nvidia-drm bit at the end and add a 3 which boots to the terminal.


No problem on my 2060M on 515.76-1.
Full specs

inxi -Ga             
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: ASUSTeK
    driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-08) arch: Turing code: TUxxx
    process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 ports: active: none empty: HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1f15 class-ID: 0300
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: none bus-ID: 05:00.0 chip-ID: 1002:15d8
    class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 5-1:2 chip-ID: 13d3:56a2 class-ID: 0e02 serial: 0x0001
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP-1-1 model: Najing CEC Panda 0x002d
    built: 2018 res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.76 direct render: Yes

It seems this is a 30 series and 515.76 issue.

1 Like

3060 here. I had the same issue, after some hours tinkering via live+chroot I narrowed down the issue to kernel/header/nvidia. I downgraded my whole system back to 20/09, and everything works. Now I know the root-cause I just have to find out how to update everything but nvidia :slight_smile:


sudo pacman -Suy --ignore nvidia-utils --ignore nvidia-dkms --ignore lib32-nvidia-utils --ignore libxnvctrl

You can also use IgnorePkg on pacman.conf