Nvidia Update - Black Screen of Death - Fixes Don't Work

[root@EndeavourOS /]# inxi -Ga
12Graphics:
  12Device-1 NVIDIA GA106 [Geforce RTX 3050] 12vendor Micro-Star MSI 12driver nvidia 12v 515.65.01
    12non-free 515.xx+ 12status current (as of 2022-08) 12arch Ampere 12code GAxxx 12process TSMC n7 (7nm)
    12built 2020-22 12pcie 12gen 3 12speed 8 GT/s 12lanes 8 12link-max 12gen 4 12speed 16 GT/s 12lanes 16 12ports
    12active none 12off HDMI-A-1 12empty DP-1,DP-2,DP-3 12bus-ID 01:00.0 12chip-ID 10de:2507 12class-ID 0300

I think there is a newer driver version. Do you also have ibt=off set in your default grub command line in /etc/default/grub? Then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg
Then reboot and see.

1 Like

The current driver version for Nvidia is 515.76 so you may need to update your mirrors and then run the update command again. Maybe it’s not on your mirrors yet?

Sooo I ended up doing yet another clean install of Endeavour using the ‘offline’ option as others have done. I was able to boot in just fine, but I’m assuming that’s because grub wasn’t updated during the install. Let’s see what happens after I update my system. :slight_smile:
Thanks all,
Bryan

nvidia  515.65.01

?
this looks more like a partly updated system… if you say you get black screen after update and this is your installed driver…
But i bet the output is not from inside the system and instead from booting the LiveISO ?
And not chrooted into your installed system?

If you are affected by the BUG jonathan mentioned with the latest Nvidia driver modules you will nee dto downgrade drivers or fall back to nouveau to boot …

But all gone now as you reinstalled…

indeed… no issue booting if grub package and installed grub files are the same versions.
Offline will not have any issue with grub as long as you do not update grub… and latest ISO will not be affected by the month old grub issue at all…

Which ISO version are you using?

If your grub version before updating the offline install was older than r322, then you need to either not update grub, or run grub-install (with proper options) after the update.

EDIT: OK, Joe already mentioned about the same.

This is probably not an issue with GRUB then. By the time you see this text, GRUB has already done its thing and so it seems to be working fine.

Can you let us know what other packages got updated at the same time? It should all be written in

/var/log/pacman.log

You can access this file from the live ISO image.

OK, so: after updating my installation, I’m unable to start Endeavour again. The nvidia driver/utils were updated:

(515.65.01-2 -> 515.76-1)

…not that that is the reason I can’t start Endeavour, but someone had suggested I update the nvidia driver, and that didn’t fix the issue.

Here’s the pastebin of /var/log/pacman.log:

https://clbin.com/TCgih

Thanks!
Bryan

It seems to me if you updated to nvidia 515.76 and now it doesn’t work then you need to stay with 515.65. There is a issue that some of us are having with the current driver (515.76). Downgrade like Jonathan said and then you will be able to boot.

So the question is: what’s the easiest way to downgrade?

Can you please change the headline to this thread by taking out the word GRUB. Possibly interchange it with NVIDIA or NOVIDIA.

Thank you.

So I managed to boot into Endeavour by using a workaround in the bug report linked above (FS#75995). Before booting into Endeavour, I unplugged my HDMI cable. After a few seconds, I plugged it back in and switched to TTY2 (TTY1 was stuck, which is the issue). I then restarted my display manager service and then, voila-- I was in.

Of course, I’ll now proceed to downgrade, since this is a ludicrous workaround. :slight_smile:

FYI Nvidia engineers are working on the issue…

Bryan

So does this mean you have your monitor hooked to HDMI? I wonder if it’s hooked to a different port it works if you have it such as Displayport or Dvi? :thinking:

I believe someone did say they had a display port available and that fixed the issue…go figure :grinning:

I think it is just related to HDMI maybe?

I apologize I didn’t get back to you last night. But yes this is an HDMI issue or at least it seems that way. I haven’t tried displayport yet but I see people having success using it.

Can you try booting with HDMI cable unplugged, wait until login screen loads and then plug in HDMI cable?

Use app downgrade.
First you should check which nvidia package have version 515.76-1.

The following command should do the downgrade:

sudo downgrade $(pacman -Qs nvidia | grep /nvidia | grep 515\.76-1 | sed -E 's|^local/([^ ]+).*|\1|')

but note that I didn’t test it fully. So use it at your own risk. :sweat_smile:

It also asks if you want to add IgnorePkg to file /etc/pacman.conf, which means pacman will not upgrade it with other updates, but just warns about not updating it.

Or you can use the --ignore option in pacman, e.g.

sudo pacman -Syu --ignore nvidia-dkms,nvidia-utils

Hey, thanks for hanging in there with me on this, everyone-- I really appreciate it!

Bryan

1 Like

sudo downgrade nvidia-utils nvidia-dkms lib32-nvidia-utils libxnvctrl

Tested and it works on my side.

Link to the same issue