NVIDIA update on Sep 23rd broke my video/display

Guess I’ve gotten lucky, too. Same card as the Reddit OP (1070), only I use XFCE w/xfwm instead of AwesomeWM. Since my system was recently rebuilt, I’m using EOS’s script (from nvidia-installer-dkms) to maintain these drivers. Could that possibly be the reason?

at the end of kernel line, there is a nvidia-drm.modeset=1, should I replace it with a single 3? or just remove the nvidia-drm, leave modeset and use modeset=3?
IMG_3136

Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 515.76

Old GPU run well, then I’ll just leave out the “new” computer :wink: , we have to save electricity in Germany anyway :smiley:

1 Like

i think not … nvidia-drm.modeset=1 or =0 on and of…
remove all the complete option nvidia-drm.modeset=1 and ad 3 (alone) to the line instead.

1 Like

image

GTX or RTX? I am not a fan from Nvidia, just for info. :slight_smile:

Do all EOS+nvidia with proprietary drivers end up with nvidia-dkms instead of just the nvidia driver?

Weird—I’m running a 3060 Ti without the problem…I’m using the Zen Kernel…anyone else running Zen & have the problem?

I am really struggling with this:

  • Downgraded to 515.65
  • Rebuilt my mkinitcpio
  • Rebuilt grub (just in case)

I was getting kernel panics at one point, had to chroot in and sort it out. Luckily the iGPU works. Am at work. so limited to the info I can provide, but it is a Lenovo Legion 5 with a RTX3070/AMD iGPU.

TBH I have been using the iGPU on Wayland, only tried the RTX after reading this thread :rofl:

Any ideas? Can supply further info after work…

Did you downgrade just the nvidia driver or nvidia-utils? How about the kernel?

Yes, but didn’t downgrade kernel, must have missed that bit. Will check my cache as I can’t (easily) use the LTS kernel due to missing WIFI driver. (After Work!!)

Hopefully that helps you. I ended up downgrading everything back to September 21 and all was good.

Got hit by this today as well, but luckily I had my LTS kernel installed in parallel. Came here, saw and downgraded the nvidia stuff and back in business :slight_smile:

NVIDIA GM107GLM [Quadro M1000M]

1 Like

Do you know if it was nvidia 515.76-2 or 515.76-3? Im curious if the 515.76-3 does the same thing.

v2 or v3 not available yet?

image

My apologies, I thought they would be available as they are in the arch repos.

Maybe in testing? But that is the Arch Repos in the screen shot.

amd + rtx 3060 with linux-zen
nvidia-dkms 515.76-1
no problems here yet

Odd… this is what nvidia comes up with in the arch search.

image

It’s been this one

nvidia-dkms-515.76-1

and nvidia-dkms-515.76-2 isn’t offered to me yet?

Edit:
This morning my laptop didn’t boot up again? Maybe I accidentally booted into LTS last night. Anyway, downgrading the kernel fixed that one.
Got another crash when starting dual monitor which is most likely because I didn’t yet downgrade bbswitch. :-/

But that’s for later as I need to get some work done first…

…or may just stop upgrading until this is fixed. (Hands trembling, cold sweat, must not upgrade, must not upgrade :slight_smile: )

Same here, I am going by what yay/downgrade (downgrade also shows all available packages) displays.

1 extra/nvidia-dkms 515.76-1 (29.8 MiB 52.5 MiB) (Installed: 515.65.01-1)
    NVIDIA drivers - module sources

Let me update my mirrors, nope still the same.