No start only kernel-panic

Hello, there are several issues/ questions. First I will share the Problems: 2 laptops, one lenovo Z570, i7 with Optimus in only intel-mode, 8GB Ram, UEFIable but was formatted MBR and still is; three Mint, 18.3 and twice 20, one for working and one for experimenting. 2nd is lenovo ideapad 100, i3 with UEFI, 4GB Ram; unused Win10 and also two Mint20. So nothing unknown or rather new.
I wanted to install one / and one /home partition. From live-iso: On i7 this was not possible, I could mark the last option, but was told this is only for UEFI. Also, though there is an extended Partition-MBR- Bios and 3 primary ones, Calamares offered to install at free space outside! Free space was 178GB and after creating it should be 370GB. This would have been crashed the whole computer. Ok, only one partition. At the end grub, but because I was unshure it will destroy all other OS-starters choosed install to system-partition; grub will find the new OS from update-grub and then grub-install.
Done so. After restart at once Kernel-panic, because vm-linuz tries to start intel-u-code.img. No chance to switch, only hardware put off did it. Only fallback-mode started the OS. Later I removed the intel file in grub.cfg, more later rm it and run grub-mkconfig, but the same. Inbetween – to rm the intel-file I missed in thunar the option “start as adm”, standard in Mint. Ran sudo thunar, worked, it did the job but some error was showed and no prompt back. Q, x ,c also with Shift or return, nothing worked – one job running- of course but no chance to kill it.

Decided to have a running system and installed on i3. A little better, but must choose without installing to uefi-partition. Restart, same kernel-panic. Due to older version tried letting Endeavour grub-install, this started EndeavourOS but mixed up the two Mint20, also too many options(each menue not collected), screen full and some missed. Not useful, but back to own grub kernel-panic again.
Next step updating didn’t even start, error because file or format unknown. So installed Libreoffice, but instead offering a dependencing proved package or a snap- or flatpak one I had to choose; done always the default one, afterwards the system was crashed. Installed new, this time online, same but now new egoistic grub. I liked the default theme with one boarder down, it is now xfce and no offering of the default one. Still it is not possible to update from the “welcome window”.
Also it contains no option to create a second user. “useradd -D user” doesn’t work(user without capital letters).
The claim was to be more user-friendly. My conclusion is that the picture of the kitchen for newbies is wrong, it’s more a car which you have to enter through the backdoor, sorry no seats and the kings put a ruined starter.
ren

Whose claim??

You really shouldn’t do that.

Everything else was really hard to follow. Is there even a question in there somewhere?

3 Likes

At the end grub, but because I was unshure it will destroy all other OS-starters choosed install to system-partition; Q, x ,c also with Shift or return, nothing worked – one job running- of course but no chance to kill it.

Decided to have a running system and installed on i3. Not useful, but back to own grub kernel-panic again.
Next step updating didn’t even start, error because file or format unknown. So installed Libreoffice, but instead offering a dependencing proved package or a snap- or flatpak one I had to choose; Installed new, this time online, same but now new egoistic grub.

Thank you for your report. I’m sorry if you had some problems with the installation, EndeavorOS is just not Mint-Linux or any other distribution that protects you from making mistakes.

EndeavorOS is (as the name suggests) first and foremost an effort to understand and use Arch and Linux.

If you still want to get support here give at least some more info on your issue and read here to provide needed logs and information:

You can find some more Info on EndeavourOS here:

4 Likes

For me the claim is to deliver a functioning system, to learn more about arch. This is told on the official website. If it is ment only for hackers, we have a different understanding.

The question is “how to kill sudo thunar”, or to tell what is wrong with this, don’t do it doesn’nt help.

Endeavour OS definitely fits this. We’re not Kali Linux.

killall thunar

With some info as Joe posted, maybe we can figure out how to help.

2 Likes

How to do without prompt? Perhaps from a second terminal? But there must be a normal command to stop. Useful would be the command running thunar as adm or how to install the option “open as adm”. Also why did useradd not work?
This is to show the intel-ucode.img used from grub:

[2021-10-24T13:14:01+0200] [ALPM] running 'grub-update-after-kernel.hook'...
[2021-10-24T13:14:12+0200] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2021-10-24T13:14:33+0200] [ALPM-SCRIPTLET] Found theme: /boot/grub/themes/EndeavourOS/theme.txt
[2021-10-24T13:14:47+0200] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-linux
[2021-10-24T13:14:47+0200] [ALPM-SCRIPTLET] Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux.img
[2021-10-24T13:15:01+0200] [ALPM-SCRIPTLET] Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
[2021-10-24T13:15:04+0200] [ALPM-SCRIPTLET]   WARNING: Failed to connect to lvmetad. Falling back to device scanning.
[2021-10-24T13:15:51+0200] [ALPM-SCRIPTLET] Found Linux Mint 18.3 Sylvia (18.3) on /dev/sda1
[2021-10-24T13:16:14+0200] [ALPM-SCRIPTLET] Found Linux Mint 20 Ulyana (20) on /dev/sda2
[2021-10-24T13:16:37+0200] [ALPM-SCRIPTLET] Found Linux Mint 20 Ulyana (20) on /dev/sda8
[2021-10-24T13:16:57+0200] [ALPM-SCRIPTLET] done

You could start here:

2 Likes

You should never run any GUI application with sudo, not only on a “hacker distro”, whatever that means, but on any flavour of GNU/Linux. Never.

This is for several reasons, one of which is that it may mess up permissions of config files in your home directory, breaking other applications and creating strange errors which may manifest after many days, and are difficult to troubleshoot. But more importantly, GUI applications usually depend on many libraries, like widget kits, e.g .GTK or Qt, which in turn depend on dozens of other libraries, etc, etc… So, when you run even a simple GUI application with sudo, you’re running literally millions upon millions of lines of code as root, some of which were never designed to be run as root, and some never properly tested with root privileges. Obviously, this can cause all sorts of unpredictable, potentially system breaking side effects.

This is not specific to GUI applications, many terminal applications should also never be run with sudo. Elevating privileges with sudo should always be done with utmost care, only when it is necessary to do so, only with simple system utilities, and only when you know exactly what you’re doing.

So, when someone more knowledgeable than you tells you not to run thunar with sudo, it is wise to listen to that advice.

Also, EndeavourOS, just like Arch Linux upon which it is based, is a fully functioning system. Claiming otherwise just makes one sound silly.

4 Likes

Whats going on here? If you want to learn, explanations are needed. I am not a parrot. Also by reading my post you can see: I have just installed on two different machines Endeavouros, and got both times the same “not starting with kernel-panic”. This little fault that the welcome-window doesn’t come back is a sign for man forgets or couldn’t view something. There is nothing wrong with this, but it is to figure out the reason!
Thanks for your explanations, but it is only half-truth. First if I only want to read several files I need adm-rights. 2nd is this “open as adm” standard in Mint. They will know why. 3rd is there Space-FM which you can run as root easily.
At least the question is unanswered, how to start in thunar a root-window.
It is Win-like to blame the user for system-faults, I think the people here are more adult.
My i7-laptop runs Kernel 4.15 and 5.4 and in EOS 5.8 or 5.9. On all have mtrr warnings: CPU has inconsistent variable MTRR settings. It is only narrow memory-space, but 7times doubleused. So this is perhaps an older linux kernel issue with Intel-cpus. on i3 I havn’t still looked, but there is also at start an SB.PCIO message. Also there is No ASPM. May be this doesn’t matter, the machines work fine.
What I found is that grub tries to start the intel-ucode.img which results in kernel-panic on both machines. This happens for sure if in a dual-boot grub is run from non-EOS. What is this ucode for? Guess it is for starting in machine-code only or to tell the kernel some settings. Without this file EOS starts via initram.
Unfortunately I can not deliver inxi, it is not loaded; from Mint of course with other partitions. Also there is no persistent journalctl…Only -0. So I need the setting for persistence or can make a photo of the kernel-panic screen and mail it to someone who is allowed to use .png or .jpg.
ren

The simple answer is: you shouldn’t. Use the shell to do file management as root. You have all the utilities you need to do that safely: cp, mv, rm, mkdir, chmod, chown, etc… and a terminal text editor like vim or nano to edit root owned text files (or use a GUI one that has polkit support).

3 Likes

Mint/Ubuntu and EndeavourOS/Arch are literally years apart development wise. Mint is also geared for a novice user and as such allows things that a more advanced EndeavourOS/Arch user would never do.

This is not a system fault but a user error. The system is designed for a long list of reasons already explained to NOT allow this. The system is not at fault because it won’t let you do something that is considered bad and could break your system.

You can upload images directly to the forum. Click the button and select your image.
Capture

2 Likes

I meant the black-screen starting with kernel-panic.
For understanding: What I need but is not provided was if I find a file and will read its content, this is often not possible because root-permission is needed. I will go and get it anyway…!.
Thanks for advice to put an image, normally this isn’t allowed

intel-ucode are update files for Intel CPUs. Basically patches for your CPU, that get loaded while starting Linux. It’s a normal package, so it can be removed by using pacman. Keep in mind, you need to run

grub-mkconfig -o /boot/grub/grub.cfg

after that. But keep in mind that those microcode updates usually are a good thing to have installed, so you should install them again, if removing them doesn’t solve some problem you have.

Also I would suggest you compose a proper comment with all the necessary informations and a short and precise explanation of your problem. There is too much fluff around your comments explaining what exactly your problem is.

edit:
I just read this in one of your comments:

Without this file EOS starts via initram.

Did you manually delete the intel-ucode.img file? If yes, don’t do that. Use pacman for that. If you can’t get into the system use the live medium and arch-chroot into your installation and make the needed changes.

Many thanks for explanation. I have moved the ucode file into a new folder, because didn’t know its function. Would need the CPU update, but not during boot.
I solved the start problem. It is a grub issue. The mintgrub grabs the intel-ucode.img and tries to start with it instead of the initramfs file. Kernel-panic without an initrd file or with intel-ucode is the same. Only removing ucode file doesn’t help, the correct initramfs-linux.img has to be set instead.
Also and this is an EOS issue, doubles the EOSgrub during install all entries and doesn’t recognize every submenu. it let the origin entries and creates his own also- adds perhaps dis_ucode_lpr. Also in my case it mixes up the two different Mint20. So the screen is full, many entries two times, several unusable and several outside-means missing. [normal 4OS + 4OSadvanced, each mint-advanced contains 2kernel+2recovery entries, makes 8+12+2=22entries because of no submenu.]
Also I recognized: the “no internet connection” window does not only popup, it breaks each running process. Not fine
The useradd help is long, but for me an example would be helpful, it is special. Kofler was no help. Is there an order to see all user with their groups? Have now a second adm and a normal user, but next problem: normal user has xfce theme and not the EOSdefault.
ren

4.15? The LAST Debian kernel was 4.19. How old is this install?

Same question for EOS. Have you purposely kept those on from the repos, or did you install and never update again? Those are very odd kernels to be running. If it hasn’t been updated. . . Why? If you’re running those kernels specifically - why?

I’m really curious about your setup.

1 Like

I am really curious about your not mentioning that I found the reason for not starting. To tell the truth, the really problem is not solved! All ubuntu-families will create this kernel-panic in EOS, if started with their grub; because this intel-ucode.img is used instead of initramfs-linux.img. I am quite sure, that no Win user will directly change to EOS, so you will have dualboot situations normally with some other linux or virtuell machines. Why is this ucode not a .cfg-file? And otherwise, why has EOSgrub no submenues or recognize those?
Still I have corrected the start grub.cfg, but each OS has his own grub. So when install-grub is run, same problem again- as long as I give EOS the intel-ucode.img back. I can use EOSgrub and install the os-prober, but have to set submenues then and correct the entries permanent.
The 4.15 kernel belongs to mint18.3, a 5year supported one. It will be changed to the next new OS. My i7 will have its 10th birthday soon and I guess that newer kernels look more for newer CPUs. And this ACPI problem seems still not to be solved. Also is there Optimus with all known and unknown problems and a thermal issue in performance mode. The EOS installation is from a 3month old live-dvd, you are right it is kernel 8. The 5.4 Kernel is also LTS and continuous updated. First I want to have a starting system and next look after the next problems. I have told that it was not possible to update because error,the needed files aren’t reachable. Also the welcome window doesn’t open when choosed in menu.
ren

I don’t quite understand what Ubuntu has to do with all of this. What do you mean by “All ubuntu-families will create this kernel panic in EOS”? The ucode should not be used instead of initramfs-linux.img. The ucode is a kernel parameter that should ALSO be used.

As already mentioned, you should make a post that is precise in what your current setup is, with proper information. Your posts are incredibly hard to understand, because they are all over the place and don’t have any useful and precise information about your setup in them. I still only have vague idea what you are talking about and I am only reacting to the things I do understand.

edit:
Also a list of your devices, partitions, boot order and other installed OSs would be nice.

edit2:
Also it would be a good idea to upload your /boot/grub/grub.cfg file. That way we can see what entries there are in GRUB and what parameters they use to start the given OS.

1 Like
:: Synchronisiere Paketdatenbanken...
 core                            623,1 KiB  5,53 MiB/s 00:00 [--------------------------------] 100%
 extra                           623,1 KiB  6,99 MiB/s 00:00 [--------------------------------] 100%
 community                       623,1 KiB  6,99 MiB/s 00:00 [--------------------------------] 100%
 multilib                        623,1 KiB  7,33 MiB/s 00:00 [--------------------------------] 100%
 endeavouros                      22,8 KiB  0,00   B/s 00:00 [--------------------------------] 100%
:: Starte vollständige Systemaktualisierung...
Fehler: Konnte Datei /var/lib/pacman/sync/core.db nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/lib/pacman/sync/extra.db nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/lib/pacman/sync/community.db nicht öffnen: Unrecognized archive format
Fehler: Konnte Datei /var/lib/pacman/sync/multilib.db nicht öffnen: Unrecognized archive format
Fehler: Konnte den Vorgang nicht vorbereiten (Ungültige oder beschädigte Datenbank)
This is gone after updating the mirrors. Installed inxi, success, but
[dier@work-EnOS ~]$ inxi -Fxxc0z --no-host | eos-sendlog
bash: eos-sendlog: Kommando nicht gefunden.

Yes but it is .img and not Parameter like .cfg… As I told, Mintgrub takes the intel-ucode because it is an .img ! Of course it should not, but this was the reason for kernel-panic.
ren

That is a bug in very many derivatives of debian. Even though the problem and the solution was informed to them several years ago. They never took the solution, so debian derivatives still continue to produce faulty grub.cfg files for Arch based distros.

That means if you want to multiboot debian derivatives with Arch and Arch derivatives like EndeavourOS, you must make the EndeavourOS grub in charge of booting.

3 Likes

Please pass the LANG -C option when providing logs so they return in English for us to better assist you as well.

1 Like