I can't paste any file in my other local disk from home or a external usb

if u mean to say what if i run lsblk then it shows
image

the much i know,
last windows install was in the drive in which i currently have endeavour os.

the command is mount type it in a terminal and show the output.
and lsblk do not show the filesystem used you need to add option -f to it:
lsblk -f

/dev/sda1 is ntfs and labeled swap?
So sda3 is a windows installation, and sda5 is a data ntfs partition?
What is the partition you try to write to?
And please show the output of the command mount, and your fstab:
mount >> log.txt && cat /etc/fstab >> log.txt && cat log.txt | eos-sendlog
will do that for you and create a pastebin URL you can share here

q1. /dev/sda1 is ntfs and labeled swap?
yes
q2. sda3 is a windows installation, and sda5 is a data ntfs partition?
there is no windows installed right now only eos as a single boot, so sda3 and sda5 both are data ntfs partitions. The reason they are ntfs is i had only windows month back and i had important data in those partitions and that’s why i didnt change their FS.
q3.What is the partition you try to write to?
sda3 as well as sda5.

https://clbin.com/TzsLV

Do not run GUI applications with root privileges.

2 Likes

/dev/sda3 on /run/media/pushkarc/4E665F10665EF863 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
mounted read only… on ntfs this is the normal behavior i think, if mounting as user…

you can add them to fstab and give user the right to write:

By default, the above line will enable write support for root only. To enable user writing, you have to specify the user who should be granted write permissions. Use the uid parameter together with your user id to enable user writing:

/dev/NTFS-partition /mnt/windows ntfs-3g uid=userid,gid=groupid,umask=0022 0 0

userid uid can be find with id username username is your username here should be 1000
groupID should be the same 1000

I back up my folders and files to five (5) external hard drives. These drives are all formatted as EXT4 and are encrypted.

When I wish to back up my Documents folder, for example, I first open the Terminal and type su and then my password. Then I type thunar and, after maximizing thunar, I open File System, then open run, then open media, and then open the folder with the name of my computer which appears there and, within that folder, I see the external drive which was previously attached. There is also the usual message: “Warning: you are using the root account. You may harm your system.” This, of course, must be taken seriously.

But, using the root account, I can copy to my hard drive or from my hard drive without changing any permissions.

Probably some more experienced Linux users will condemn this process but it works perfectly for me and, using it, I can keep copies of everything I have on my computer (pictures, music, videos, documents, etc.) backed up and password protected. I even keep one of these hard drives stored in my safe deposit box at my bank.

I hope that this is of some interest to you.

Lawrence

Even though it works for you it’s wrong. As @Kresimir said it’s not good to run GUI application with root account is a big security issue. And if you have read up on hot change permission and set user right on a new drive you don’t have to use root to do simple tasks like copy-pasting files.

Also, don’t give this type of advice to other users it just defeats the purpose of having a secured system and using Linux. Having two accounts root and the user account is what makes Linux secure (there’s just more than just that).

sorry sir, i did that for just trying once if it works or not.
after this i wont do it again.

yes sir it would work as ur opinion but, i m a beginner can u explain or just make it simple for understanding me?

@pushkar you could try writing something on that drive in windows. then try again in linux. it happend to me that windows locked some drives and they got unlocked this way.

  • @pushkar are you dual booting with windows?
  • Do you need to have NTFS partitions?
  • Are you trying to use a Linux or Endeavour-only system?
  • Did you do a manual partitioning or auto partitioning while installing?

a1. no sir i have single boot of eos.
a2. last month i installed eos before which i used windows 11 and 10.
a3. if u mean to say as a single booted then yes or i dont know what to answer as i m a beginner in linux.
a4. manual partition with my brother’s help.

i have only one single boot of eos sir.

I may have a solution

$ lsblk -f
NAME        FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                                          
└─sda1      btrfs                        6a506fe3-a14b-4eb1-8853-ee71d2da0ece 
sdb                                                                                          
├─sdb1      ntfs         SYSTEM_DRV      92360AFD360AE259                                    
├─sdb2      ntfs         Windows7_OS     06F60E46F60E3689 
└─sdb3      ntfs         Lenovo_Recovery BAE0960CE095CECF                                    

if I mounted sdb2 i.e. Windows7_OS it was mounted as read-only (despite the label it is windows 10)
To fix I did

sudo ntfs-3g -o remove_hiberfile /dev/sdb2 /mnt
sudo umount /mnt

Note: from ntfs-3g man page
"remove_hiberfile
When the NTFS volume is hibernated, a read-write mount is denied and a read-only mount is forced. One needs either to resume Windows and shutdown it properly, or use this option which will remove the Windows hibernation file. Please note, this means that the saved Windows session will be completely lost. Use this option under your own responsibility.
"
If that is not acceptable do not do this.

change /dev/sdb2 and /mnt to match your system, I used /mnt as nothing else was mounted there
then mounting the disk again mount shows me
/dev/sdb2 on /run/media/xxxxx/Windows7_OS type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
previously it was
/dev/sdg2 on /run/media/xxxxx/Windows7_OS type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
HTH

1 Like

buddy,
beforehand i have cleary mentioned that i have single boot eos.

If you are not dual booting with Windows, why do you have 3 ntfs partitions on your computer? And why is one of them labeled swap? Is there an actual reason for this?

3 Likes

Sorry I was busy and kind of forgot to follow up. Thank you for replying. And it seems you have messed up the partitioning of your hard disk.

The best thing if you’re not going to dual boot is to have Linux file systems on your partitions. Windows NTFS is not a good file system by Linux standards but better under Windows standards.

I would advise you to do a reinstall if you’re willing to do that. If you’re going to do a reinstall it’s best to remove all the partitions from your hard drive before starting the installation. This can be done using GParted which is a GUI partition manager found in the Live Environment.

Once removing the partitions start enos calamaris installer and continue till where you get to the partitioning section. Once there you can do manual partitioning or use the auto partition function. If you wish to use hibernate then select to have swap file according to your need when you’re doing the auto partitioning.

If you wish to create partitions manually then you can use that too. If you are on a system that supports UEFI then make a new partition table which is of type GPT and then make a small partition size around 550 MB and select the file type as FAT32 and label it as /boot/efi. Then you can create your root / partition giving a size above 30 GB would be enough. Then you can make your /home parttion remember to minus the size you’re going to assign to your swap partition. As a rule of thumb, you can use this equation to get the size of your swap. size of your ram x 2 = swap partition size

Frome the screen shots I see you only have one hard drive so this partition table would be enough for you to have a good running enos system.