I can't paste any file in my other local disk from home or a external usb

I want to transfer some files from home or an external usb drive to my local disk but it says
“its in read-only.”
and i dont know how to make it write-read…
i tried doing sudo thunar,
and i got the same issue.


image

It isn’t clear to me what you mean by local disk - but it looks to me like you are trying to copy a file to an external disk.
What does mount show?
For example I mounted a disk ripped out from a windoze box, and it is mounted as readonly (ro,...

/dev/sdg2 on /run/media/xxxxx/Windows7_OS type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

i mean to say via local disk as another partion of my internal drive like sda` is as of home and then sda2 sda3. Like this way i want to copy in sda3.
and it show’s me error as
image
as write-only disk

it says the filesystem is mounted read-only. If this is an NTFS partition mainly caused by the reason that it is windows system disk and you have fastboot enabled, so it is in unclean state.

would give the info needed indeed…

if u mean to say what if i run lsblk then it shows
image

the much i know,
last windows install was in the drive in which i currently have endeavour os.

the command is mount type it in a terminal and show the output.
and lsblk do not show the filesystem used you need to add option -f to it:
lsblk -f

/dev/sda1 is ntfs and labeled swap?
So sda3 is a windows installation, and sda5 is a data ntfs partition?
What is the partition you try to write to?
And please show the output of the command mount, and your fstab:
mount >> log.txt && cat /etc/fstab >> log.txt && cat log.txt | eos-sendlog
will do that for you and create a pastebin URL you can share here

q1. /dev/sda1 is ntfs and labeled swap?
yes
q2. sda3 is a windows installation, and sda5 is a data ntfs partition?
there is no windows installed right now only eos as a single boot, so sda3 and sda5 both are data ntfs partitions. The reason they are ntfs is i had only windows month back and i had important data in those partitions and that’s why i didnt change their FS.
q3.What is the partition you try to write to?
sda3 as well as sda5.

https://clbin.com/TzsLV

Do not run GUI applications with root privileges.

2 Likes

/dev/sda3 on /run/media/pushkarc/4E665F10665EF863 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
mounted read only… on ntfs this is the normal behavior i think, if mounting as user…

you can add them to fstab and give user the right to write:

By default, the above line will enable write support for root only. To enable user writing, you have to specify the user who should be granted write permissions. Use the uid parameter together with your user id to enable user writing:

/dev/NTFS-partition /mnt/windows ntfs-3g uid=userid,gid=groupid,umask=0022 0 0

userid uid can be find with id username username is your username here should be 1000
groupID should be the same 1000

I back up my folders and files to five (5) external hard drives. These drives are all formatted as EXT4 and are encrypted.

When I wish to back up my Documents folder, for example, I first open the Terminal and type su and then my password. Then I type thunar and, after maximizing thunar, I open File System, then open run, then open media, and then open the folder with the name of my computer which appears there and, within that folder, I see the external drive which was previously attached. There is also the usual message: “Warning: you are using the root account. You may harm your system.” This, of course, must be taken seriously.

But, using the root account, I can copy to my hard drive or from my hard drive without changing any permissions.

Probably some more experienced Linux users will condemn this process but it works perfectly for me and, using it, I can keep copies of everything I have on my computer (pictures, music, videos, documents, etc.) backed up and password protected. I even keep one of these hard drives stored in my safe deposit box at my bank.

I hope that this is of some interest to you.

Lawrence

Even though it works for you it’s wrong. As @Kresimir said it’s not good to run GUI application with root account is a big security issue. And if you have read up on hot change permission and set user right on a new drive you don’t have to use root to do simple tasks like copy-pasting files.

Also, don’t give this type of advice to other users it just defeats the purpose of having a secured system and using Linux. Having two accounts root and the user account is what makes Linux secure (there’s just more than just that).

sorry sir, i did that for just trying once if it works or not.
after this i wont do it again.

yes sir it would work as ur opinion but, i m a beginner can u explain or just make it simple for understanding me?

@pushkar you could try writing something on that drive in windows. then try again in linux. it happend to me that windows locked some drives and they got unlocked this way.

  • @pushkar are you dual booting with windows?
  • Do you need to have NTFS partitions?
  • Are you trying to use a Linux or Endeavour-only system?
  • Did you do a manual partitioning or auto partitioning while installing?

a1. no sir i have single boot of eos.
a2. last month i installed eos before which i used windows 11 and 10.
a3. if u mean to say as a single booted then yes or i dont know what to answer as i m a beginner in linux.
a4. manual partition with my brother’s help.