No start only kernel-panic

Thanks so I am right. But it would be nice to have a notice for dual-booter. 2 days research for nothing. Also as long as EOS doesn’t have an os-prober this complicates the situation. And even with os-prober the function “submenu” is missed, because there are normaly 2 kernel with each 2 entries(normal+recovery) for every OS.
I found a way how to start, what is the solution provided to “Debian”???

You are actually totally wrong here and very confused. You cannot dual boot Debian/Ubuntu on the same drive using Debian/Ubuntu grub. This has nothing to do with endeavouros/ arch.

Sorry, the first was to show, that I could not update. Direct after install. Had updated the mirrors just before the install via “install window”. It reads:
Could file /var/lib/pacman/sync//core.db not open: unrecognized archive format. There is something forgotten in the installer As I told, updating the mirrors is the solution.
I wanted to send inxi, but command not found, same with sudo inxi. Means eos-sendlog is not implemented???
The logs are only pasted, where to set the LANG -C option?

Install inxi.

1 Like

It should have been installed by default it is in the EndeavourOS repo. Something very strange was done to this install.

1 Like

He says he’s using a 3 month old ISO, but wasn’t inxi included by default longer ago than 3 months?

1 Like

I have just seen the “no” of “no host” is marked, can this be the reason?


1 Like

The right thing to do is go to debian/ubuntu/mint forums and ask why their grub generation is wrong for Arch distros. It is their bug, and they are the only ones to fix it, or give any notices about it.

1 Like

It wasn’t. But in the window you can see that i have installed it and it is working. only sending does not work.

This is a huge group of linux -user, and among those will be your future user of EOS. For me this is not a question of deb but of service. And it is me, who have the trouble with installing EOS and not debian…

Demanding service from a group of enthusiasts who do this on their free time voluntarily is rude. A certain amount of research and self maintenance is required by all users. Your issue is because you chose to install Debian on the same drive as EndeavourOS. How many times do we have to tell you this before it sinks in. If you really want to is feature we cannot help you you need to seek the Debian devs as instucted.


If you want to dual-boot Arch, or an Arch-based distro, with Ubuntu/Debian/Mint (or many other Linux distros) you need to use the Arch-based distro’s GRUB to do so. Arch loads the microcode differently than most other distros do.

Since you seem to have some odd things missing in your EndeavourOS installation, your best course of action would be to download the latest EndeavourOS ISO and reinstall from that. Doing so will install Endeavour’s GRUB, will give you a more current system, will have the latest Endeavour tools included, and will overall be more likely to work properly for you from the start.


Can you please recognize, that I found a way to start all Os. And if EOS is running and it is now!, new occuring problems has nothing to do with debian/ubuntu/mint.
I demand nothing, but think we are all learning, making faults and should learn out of them.

I wouldn’t call missing packages and an inability to update working.


There’s something very odd about your install. I would download the latest iso and try again after passing the check sum. Inxi should not have needed installing.

We’re pretty content around here. The goal isn’t necessarily to take over the world, but to be the best distro for us and those like us. Our future currently is looking pretty good.

It’s definitely Debian. . . If you don’t believe us, use the EOS grub instead and see if you still have the issue.

1 Like

inxi has to be installed or the command won’t work. It may not be installed on your system.

yay -S inxi

inxi was installed: inxi- is actual. Had done it via pacman. Sorry it is not in EN, still do not know how to converse.

[dier@work-EnOS ~]$ yay -S inxi
[sudo] Passwort für dier: 
Warnung: inxi- ist aktuell -- Reinstalliere
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (1) inxi-

Gesamtgröße der installierten Pakete:  0,93 MiB
Größendifferenz der Aktualisierung:  0,00 MiB

:: Installation fortsetzen? [J/n] J
(1/1) Prüfe Schlüssel im Schlüsselring                       [--------------------------------] 100%
(1/1) Überprüfe Paket-Integrität                             [--------------------------------] 100%
(1/1) Lade Paket-Dateien                                     [--------------------------------] 100%
(1/1) Prüfe auf Dateikonflikte                               [--------------------------------] 100%
:: Verarbeite Paketänderungen...
(1/1) Installiere inxi                                       [--------------------------------] 100%
:: Starte post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[dier@work-EnOS ~]$ 
```and you can see, it reinstalled the same version. Tried again, but: sendlog command unknown.

What worked was the log-tools, I hope:
At the end is to see that persistend journal is not available!
who marked this end and not? It is good, but not from me

The iso you used is from sept 2020 I am surprised anything is working.


The DVD from a Linux-magazine is dated aug.21. Also the system is updated 3 days before.