How to increase scrolling mouse speed and enable autoscroll

One of the things Windows had right that GNU/Linux doesn’t is that first of all the scroll speed (when using your middle wheel mouse to scroll) is very slow. Is there a way to increase its sensitivity?

Additionally is there a way to enable autoscroll?

Which mouse do you have ?
Give the result of :

egrep "Name|Handlers" /proc/bus/input/devices | egrep -B1 'Handlers.*mouse'

My mouse is logitech.

Would this information be accurate if EndevourOS is running through virtualbox?

The solaar app can manage certain Logitech mice. Worth a try, I’m using it.

Do you mean autoscroll in Firefox?
This can be done in the FF settings.

And you might install imwheel, it;s in the repos.

1 Like

Is it open source, this driver?

Yes but that is only for firefox, on Windows a lot of applications support autoscroll and it would be nice if GNU/Linux supports the same thing.

Does it enable autoscroll for all applications?

Yes. And available with pacman.

1 Like

Oh that is pretty awesome

It looks like a systemwide app.

1 Like

So I have installed the software but it doesn’t appear that it can control the mouse sensitivity, it just gives me some information such as battery and encryption.

Ok so I ran this command to list out all my devices

xinput --list --short

After located my device ⎜ ↳ Logitech Wireless Mouse id=11 [slave pointer (2)] I tried to determine which part I have to alter to change the scrolling sensitivity.

xinput --list-props 11

And I got this output.

Device 'Logitech Wireless Mouse':
	Device Enabled (169):	1
	Coordinate Transformation Matrix (171):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Natural Scrolling Enabled (306):	0
	libinput Natural Scrolling Enabled Default (307):	0
	libinput Scroll Methods Available (310):	0, 0, 1
	libinput Scroll Method Enabled (311):	0, 0, 0
	libinput Scroll Method Enabled Default (312):	0, 0, 0
	libinput Button Scrolling Button (313):	2
	libinput Button Scrolling Button Default (314):	2
	libinput Middle Emulation Enabled (315):	0
	libinput Middle Emulation Enabled Default (316):	0
	libinput Accel Speed (317):	0.000000
	libinput Accel Speed Default (318):	0.000000
	libinput Accel Profiles Available (319):	1, 1
	libinput Accel Profile Enabled (320):	1, 0
	libinput Accel Profile Enabled Default (321):	1, 0
	libinput Left Handed Enabled (322):	0
	libinput Left Handed Enabled Default (323):	0
	libinput Send Events Modes Available (291):	1, 0
	libinput Send Events Mode Enabled (292):	0, 0
	libinput Send Events Mode Enabled Default (293):	0, 0
	Device Node (294):	"/dev/input/event6"
	Device Product ID (295):	1133, 16472
	libinput Drag Lock Buttons (308):	<no items>
	libinput Horizontal Scroll Enabled (309):

It seems like it is at 306 where I need to alter the scrolling speed.

I ran this xinput --list-props 11 306 3 but then it just reprints the same output rather than editing the file, is there something I can do?

Can you see the solaar icon on the taskbar? I have it there, it resembles a battery icon in the theming I have.
If you click that icon, on the second line there should be the name of the mouse. Click that line.
Then you should see a window with some text and two toggles (at least here they are visible):

  • Smooth Scrolling
  • Side Scrolling

Try to click that Smooth Scrolling toggle. Does that help with the mouse wheel?

See the man page:

  man xinput

I guess you have to use set-prop for setting new values.

Yes I do have it.


Strange, the first time when I installed this it was showing both the mouse and hte keyboard, now it is only showing the keybard. I removed the USB receiver and reconnected it and still the same issue over here.

Sure I will check it out and see what I need to do.

The wireless link can be challenging. The mouse and the unifying receiver need to be as close to each other as reasonably possible, preferably without any obstacles in between them.
And sometimes a reboot can help to get the mouse detected.

I have tried doing all of those but that did not work at all :frowning: I tried reinstalling it as well, same issue.

Is there some generic setting I can change where I can enable autoscroll and increase the mouse scrolling speed for any device?

I guess at least xinput is meant for that. TBH I haven’t used it much because solaar is working for me very well.
Maybe someone else here could give more help?

fwiw, I have other options…no side or smooth scrolling.


This is what solaar gives here:


At least you are having a better luck. What I have noticed is that on the top it shows that there are two links connected to the USB receiver but then below it only shows the keyboard.

Oh i will try and get this to work.

Is there a way to clear the cache or configuration files for the solaar drivers?