Why is mouse scroll wheel sensitivity/speed so "exotic" in Linux?

Hi all,

I have an Asus ROG Chakram and am annoyed at the speed with which I can scroll up/down pages in Firefox, Chrome, Terminal, etc… I wanted to speed up (i.e. increase the sensitivity) the rate with which the scroll wheel reacts.

Searching up on the subject, it appears that controlling scroll speed in Linux is not straight forward. There’s a couple of forum posts:

I also found a couple of posts on stackoverflow that all boil down to:

  1. Try imwheel
  2. Install a separate extension in each browser
  3. Install some special app (solaar) if available

Currently I’m using imwheel with:

None,      Up,   Button4, 4
None,      Down, Button5, 4
Control_L, Up,   Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L,   Up,   Shift_L|Button4
Shift_L,   Down, Shift_L|Button5

I am a bit concerned about the warnings at the bottom of the Arch wiki page on the subject but so far so good…

I’m quite surprised that we need to manually install a daemon program, manually set up its auto-start on login, manually configure the speed of the buttons using a text editor (followed by bouncing imwheel)… With all these advances in usability over the years, this seems like something that’s been “left out”…

My point is, I’m very surprised as to why this is not as simple as a slider in GNOME/KDE/etc settings. Is this really a “hard” problem to solve?

In the open source world, it doesn’t really matter if it is “easy” or not. It matters if someone who has the skill to implement it, also has the desire to do so.


System Settings → Input Devices → Mouse

1 Like

Is this KDE? I guess I should not have assumed this is the case there. I am using GNOME and I cannot find any such setting in the “Mouse and Touchpad” section. It only has “Mouse Speed” and “Natural Scrolling”…

Well I am using KDE, and I don’t see such a screen…

Operating System: EndeavourOS
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9
Kernel Version: 6.3.1-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 23.4 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2

I am currently using the damn keyboard to scroll the page at a reasonable speed. This only happened after the last update.

EDIT: Argh… a reboot fixed it. Hopefully this message helps other people.

Good that it now works.

Are you using Firefox? In Firefox you can change the scroll rate:

  1. In the address bar type: about:config
    Click on ‘Accept risk and continue’ button (or simular words)

  2. In the Search bar, type:


  1. Double click on the entry and change the value to anything 5 - 60 .

5 = Slow , 60 = Fast . I prefer 60 :slight_smile:

This tip should also work in Mac OS.

1 Like

Just to add to the (potential) complexity of the answers… I happen to have a Corsair mouse (and keyboard) and ALL imaginable settings come courtesy of the ckb-next daemon - including polling speeds for the mouse movement and its button sensitivity. It may trun out not to be DE specific…


Scroll speed setting is Wayland exclusive, it doesn’t appear under Xorg.

I was annoyed by Firefox scrolling too fast with mouse wheel, turns out I have to flip mousewheel.system_scroll_override.enabled to false. The setting you mentioned is already at 5.

1 Like

That’s because KDE has defaulted to using libinput for a few years now; it used to use evdev, which provides advanced mouse settings. You can get the old behavior back by doing the following:

Install the xf86-input-evdev package.

Create the following drop-in file:


Paste the following content into the file:

Section "InputClass"
    Identifier "evdev-mouse"
    MatchIsPointer "yes"
    Driver "evdev"

Log out/log in for it to take effect. Now you will have advanced settings for the mouse.