Etcher not working for latest release

Moderation Note: Moved from The September release and ARM has arrived

I have a problem burning an iso with balenaEtcher 1.5.108.

Tested 2 times. I will try with another program. Maybe a Linux computer too.

Please check this out here:

There’s no iso to burn, etcher, imager, etc won’t be used.

1 Like

If you try to burn the regular release, then check the file you have downloaded. I have just burn EndeavourOS on a USB stick with Balena-Etcher without any issue.
If you mean the ARM release, then see @fbodymechanic reply above.

2 Likes

I mean the regular release. The one before I get to work with balenaEtcher. 2020-07-16. There’s just something wrong here. Tests around a bit with programs.

Can you explain a bit more about what the issue is?

In other words, is the issue that you can’t use etcher to put the latest release on an ISO or is the issue that after installing the latest release, you can’t use etcher?

If it helps, both things work fine in my testing.

I got error on rufus too :confused:

Tested with another USB memory. I actually do not know what goes wrong.

Gonna check it out a little better. I have burned many USB sticks in my days. Sometimes it goes wrong.

OK, so you are on Windows and trying to write the ISO to a USB drive to install it?

Have you tried downloading it again to make sure the download isn’t corrupt? Do the checksums match?

I’m trying to burn in Windows. Maybe that’s wrong? :wink:

I’ll check the ISO file. May have to download it again!

1 Like

Of course it isn’t wrong…how else would you remove Windows… :innocent:

6 Likes

It was solved with 1.5.109 BalenaEtcher. Had 1.5.108 before.

Thanks to everyone for the help!

2 Likes

rufus will only work in dd mode, if it creates filesystem and format disk it can not work, ISO is already an image working out of the box needs copy at once to the device…
and etcher is working here without issue:




2 Likes

I probably burned in ISO mode with Rufus if I remember correctly. Thanks, now I know!

1 Like

I’m up:

Live for now. Tests if everything works!

9 Likes

The best way to test if everything is working is to install into a VM. But have fun experimenting! :+1:

2 Likes

I’ll just leave a link to my epic rant about Etcher here:

Take it for what it’s worth. It’s not entirely on topic, but it’s also not entirely off topic :wink:

5 Likes

I would go further:

Etcher

Warning! we do not recommend using etcher anymore as there are privacy concerns, etcher is Anonymously reporting errors and usage information. It is not clear if this is done also if you do not validate that you agree with it.

but who cares on our wiki?

6 Likes

Music to my ears :joy: :+1:

2 Likes

Well i know some people don’t like Etcher but i use it even though it’s not recommended because for me it works. I never have any issues with it. I just want you all to know my feelings are hurt! :sob: Now everyone knows. I’m so dissappointed. :worried:

6 Likes

I know I stopped using etcher a while ago. I’ve since migrated to popsicle and it works simple and without issue so far.

4 Likes

Has anyone tested Ventoy?

Starting to get tired of burning ISO files. Better to have everyone on a USB stick.

I have a fast and large USB memory that would fit well with that. A little luxurious perhaps.