EFI boot entry disappeared pt. 2

I’m having the same issue again.

This time it was triggered by me trying to boot into tails with an external USB. From that moment it’s impossible to boot into EOS.

Sadly this time the solution that worked in the past (clearing TPM, disabling it then disable secure boot) is not working.

As last time I can disable TPM finely but secure boot never works, meaning after saving and exiting it boots up there again with secure boot enabled.

Any clue? A bit panicked as I can’t access anything.

Also with @ricklinux we checked lsblk output and efibootmgr after fixing the original issue and everything was fine, but here I am again…

Are you able to boot on the live ISO? I can’t see what the image shows on the second image? If you go into the bios and check the boot order?

I managed to boot into the Tails USB.

This is what I see every time I boot. Just like last time, it sees the SSD and the boot entry disappeared

Secure boot needs to be disabled.
Edit: It looks like it is.

Is there no setting for boot order in the Bios?
Edit: I guess that is the setting for order of boot under bootable device.

On the HDD options it just lets me disable it.

Here what happens when I try to disable secure boot.

Okay. Does it boot on the EndeavourOS live ISO?

Edit: If you can get it to boot on the live ISO. I would like to see what it shows for efibootmgr -v

Nope, it sees the USB but when clicking gets into the same loop.

It sees the Tails USB finely, and it lets me boot into that one but after some time the system just crashes and the PC shutdowns.

I don’t know what you’ve done?
Edit: Try booting on the tails usb and post efibootmgr

I just tried to boot into the Tails USB and from there everything was lost, no idea how it happened.

Tails terminal doesn’t recognize that command, I already tried.

Here the lsblk output

You should be able to install efibootmgr

sudo apt install efibootmgr

Edit: If you can get efibootmgr installed and see what it shows.
Then i would remove all the entries in efibootmgr

Use this command and remove each boot entry.

sudo efibootmgr -b xxxx -B

Then see if it boots with out tails usb in it.

now apparently became impossible to boot into Tails either… this is so absurd. Sometimes it crashes while booting, sometimes I get this errors…

this is becoming a nightmare :sweat_smile:

tried to delete all entries, shutdown and restart without Tails USB. same error as before.

just now it only sees the HDD as one option and not two.

secure boot always bugged as before.

Just a thought: do you have any option to reset your Bios to default and see if it perhaps resolve the issue?

yes, tried and didn’t change anything (pressing f9 key and confirming)

1 Like

I wonder if your issue is similar to this one, a CMOS battery issue?

how do I reset firmware to factory?

pull out the battery, wait a few minutes then reinserting it and starting again or just starting with power cord?