EFI boot entry disappeared

Hey guys!

After updating, without doing any other weird action I lost my laptop with EOS running (was doing amazingly well for a few months).

Now, every time I boot I get this message

Twice, meaning after clicking enter I get it once again and then it shows

It then moves to the system screen as if I pressed F8 where I can see it reads the hard disk finely but the EFI boot entry is not there anymore.

For example, if I plug in a usb drive with tails it launches without issues.

How can I approach the issue? I don’t want to think about reinstalling fresh :sneezing_face:

What does this mean?

Did it crash or freeze as you were using it? That could be a hardware (ie disk) failure, which is why BIOS sees no boot device.

Are you single booting EndOS on the laptop or dual booting with W10?

Boot into a live environment and run

lsblk -f
efibootmgr

^ also fsck the drive, looks suspiciously like a drive failure.

No crash or failure of any kind. Just shut off and never came back up.

I’m single booting EOS - never dual booted.

Actually I started having issues running tails… it shows up in the boot selection options but fails to run… weird as it was working last night.

Also if I try to plug in usb drive with EOS live environment and boot it, it shows the same boot error.

Should I download another live ISO from other distro to try?

Wow, any clue how it might have happened and how to verify?

Should I download and try another distro live ISO as EOS from USB seems to have issues?

Boot of the live install media, fsck the drive, that will verify if the drive is OK.

How did it happen? Drives die. Especially mechanical drives, how old is it and what type?

https://wiki.archlinux.org/title/Fsck

The drive and laptop is basically brand new literally a few months.

It was a new SSD.

I will download Arco basic ISO and hopefully it will run from USB as EOS won’t run from the USB stick.

Only way to diagose is to run commands from a live environment.

Get that running first.

New SSDs can fail too, bad batch.

Or it could just be a bootloader config issue.

Unlikely to be total drive failure as it is new, but random things do happen, that is the “wonder” of computers. I have had power surges wipe the boot sectors on my work computers.

Wait what?
You seem to have bigger issues here somewhere. If EOS won’t run from an USB stick you either have a faulty USB stick, a faulty USB connection in the computer, or (highly unlikely) Arch Linux isn’t able to run on your hardware (which means no flavor of Arch ISO would work, not Arco, not Archlabs, not BlackArch, not… insert distro name here).

BUT for the main issue: Do you have secure boot enabled? Do your computer have a restore function? Is it possible that the Laptop detected a “non functioning Windows boot partition” and tried to “repair” it hence removing the Linux EFI option?

It is always a good idea if you are replacing Windows completely to erase ALL partitions on the drive, even the hidden restore partitions etc.

1 Like

If this is the case you could try supergrubdisk2.
Download it and boot from that, then you can pick a kernel to boot from and passing by your efi partition and grub.

I was more thinking chroot and re-install grub and/or re-order efi boot order.

I have never had need for a third party tool like that to fix grub related issues.

1 Like

Perhaps you could remove the quiet parameter from the kernel boot line to see if you get more messages regarding this issue.

You could bring up your grub boot menu. Press e and use the arrow keys to go to the line that begins with linux and delete “quiet”. Now press Ctrl-x to boot in “verbose” mode.

Sounds like a hardware issue. Are you able to boot into your Bios settings and check them. If it’s not booting up and recognizing a drive and also a usb drive? It has to see them in order to read them and boot from them.

If you are able to boot into a USB - run lsblk, find your drive, then run sudo fsck /dev/yourdrivename. This will report any errors in the drive (not fix them though)

Yes, this is what I see.


I tried to disable secure boot, save and exit but nothing if I open back the BIOS settings it shows as enabled again.

It does recognize external usb drives with tails or other os but it will not launch any of them giving again the boot error.

Nothing happens when pressing “e” Key :confused:

I’m not aware of any restore function though I will contact the manufacturer.

Secure boot is enabled and if I disable, save and exit it seems that when booting up again it reenables it automatically.

I don’t know if that’s possible, I deleted every partition with gparted before installing.

Tried this as well, it reads the USB but when trying to boot it it gives me the same error.

Do you use the EFI partition created by Windows?
It SHOULD work, but since it doesn’t for you, if you reinstall make a second FAT32 partition and point /boot/efi to that one instead. That one Windows shouldn’t be able to touch no matter what.