Zen kernel and custom compiled kernels: Internet wont work

Hello everyone, i compiled my own kernel for gaming (Linux-tkg-pds) which compiled fine, i updated GRUB, but after rebooting, NetworkManager is unable to detect my Internet connection (wired connection 1). This also happens on the linux-zen kernel. My system was installed with the online installer and the KDE DE. In other distros networking works fine, aside from kernel. Motherboard is a Aorus B450 Elite.

Hi @bl4ckfuture , could you have a check here in case is the same bug with r8169 driver ?

Do you have something on ?

ip link show

I will try, currently im on mainline kernel and networking works. lspci -v shows this
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 16)
DeviceName: Broadcom 5762
Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet
Flags: bus master, fast devsel, latency 0, IRQ 58
I/O ports at f000 [size=256]
Memory at fcc04000 (64-bit, non-prefetchable) [size=4K]
Memory at fcc00000 (64-bit, non-prefetchable) [size=16K]
Kernel driver in use: r8168
Kernel modules: r8169, r8168

EDIT: after a reboot, i found out that linux-zen and my custom tkg kernel are loading the r8169 kernel driver instead of the r8168 one

Ok bingo ! you have the same problem than me with the RTL8111/8168/8411 !1

So apparently your UDEV is not detecting the right chipset then put the r8169 dirver so just install the r8168 from your network card, arch just put it few days ago…

sudo pacman -S r8168 

On my side I stopped Network Manager.service and use dhcpcd then it works.

I’ll check and keep you updated, thanks!

You are welcome, yep, it seems this chipset is already known for this bug don’t worry it works well also with the latest dhcpcd.

In case the dhcpcd start before than the module of your card is loaded so you could add a file /etc/modules-load.d/realtek.conf


before do this to find which one to put in the file :

lspci -k

Tried, but still no dice, ip link show shows only the 'lo" link
EDIT: i’ve just seen your message, i’ll try again, thanks!

Do you have the dhcpcd installed ?
Cause if you have Network Manager and dhcpcd together they conflict…
Stop NetworkManager.service then install dhcpcd if you don’t have it, you will get it…

systemctl list-unit-files
systemctl stop NetworkManager.service
systemctl stop NetworkManager-wait-online.service
systemctl stop NetworkManager-dispatcher.service


sudo install -S dhcpcd
systemctl start dhcpcd
systemctl enable dhcpcd