DHCPCD 9.0.1-2 update issue

I will do this afternoon, I’m on the phone right now… is it the 9.0.2-1 version stable ?

1 Like

Yes, it is.

1 Like

Have you ensured that your device is connected to the power?
:zap:
:cowboy_hat_face:

After the check all my linksys and firmware, all was fine.
Then I tried on others OS, conexion was working well as usual…

So I got some infos debug in testing then I saw that the IP wasn’t well assigned !!

I release it :

sudo dhcpcd -k

then request a new one :

sudo dhcpcd

And it seems to work for now, need to reboot to see if I get it automatically now !

2 Likes

I was going to ask you if you cleared the dhcp on this router. I used to have one of those way back in the days!

@joekamprad my old Linksys doesn’t need electricity !!

So I’m on it to resolve it, I stopped the Network Manager.service then activate the dhcpcd one.
I tested on other OS, it works well, I downgrade to dhcpcd-8.1.7-1-x86_64.pkg.tar.zst it works well.

It seems that I have this driver r8169 where on my motherboard is 8168 !!

19:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
Kernel driver in use: r8169
Kernel modules: r8169

I will restart and see if the dhcpcd.service will start before the network module is loaded !!
If yes I will add a /etc/modules-load.d/realtek.conf

Thanks to ask @ricklinux I’m going right now to resolve this…

I just found that r8169 Realtec is not a reference !!!
But it works on all others OS…the dhcpcd update was fatal…

So does this mean you are switching to the r8168?

https://www.archlinux.org/packages/community/x86_64/r8168/

Nope I didn’t still, it works well now, no need to create a /etc/modules-load.d/realtek.conf
If I see some problems I will check this but now it’s working at start.

Just need to deactivate the applet NetworkManager

That driver was just two days ago from upstream realtek.

I just check yep it seems to not be bad to try this one !
Timing they just put it in now ???

It is current 5.6.6-arch1-1

I installed the r8168 driver…

Does it work with no issues?

was someone on telegram too with thew same lan chip new install and it was not detected at all…

2 Likes

Yep it works, the only problem is the NetworkManager that doesn’t want to stop, it always come back on, I believe it comes from udev kernel ??? The same with the NM Applet…

It seems to boot faster.

So the issue is r8169 used in spite of r8168 from a wrong material detection on the Linksys WRT54GS v1. 0.

1/ update dhcpcd at latest
2/ install r8168
3/ stop NetworkManager.service
4/ stop NetworkManagerApplet.service

blacklisted the r8169 ?

You can disable it, but tere is always a chance some app start it on demand like some panel app for internet connection, you may need to remove the app from panel or disable it to autostart…
sudo systemctl disable NetworkManager.service
or you can try
sudo systemctl disable --now NetworkManager.service

You could always mask the network manager then any program won’t be able to start it. If you need it back you can unmask it.

Interesting, this is new to me, how to mask a service?