XFCE login loop solved

@manfredlotz @bugnotme

I refer to my thread Can’t log into XFCE

I found a solution for my problem in the green forum (many thanks to aki42 over there).

I got login loops on Xfce4.
But after replacing libxfce4ui-devel with libcfce4ui, the problem is solved.

This also worked for me and my system is fully updated now.
I just don’t know why an AUR package (libxfce4ui-devel) was installed instead of the “official” package from extra repository.

1 Like

I am sure you can find out when it was installed, looking into pacman.log, and then look how it was triggered. :person_shrugging:

1 Like
cat /var/log/pacman.log

1 Like

Now it is clear why others like me didnt’ have the problem. Thanks for telling.

After reading the log file, I strongly suspect that this was a classic PEBCAK. Installed libxfce4ui-devel Nov 22, I have a vague recollection that at that time I was troubleshooting a Thunar issue and might have tried some 4.17 packages.
At least I learned something :wink:


Then you should mark this post as the real solution. :wink:

My experience with Xfce is it is always working unless the user (=me) breaks it.
That’s why I never troubleshoot Xfce. I have learned the lesson too. :wink:

I agree with @manuel. I’ve been using XFCE since I installed Endeavour. It never left me hagging. Unless I managed to mess things up. It’s rock solid until the person in front of the screen screws it up. I think (personally) XFCE is the most stable DE out of most of the DEs out there.

This is how Kde is rock solid! :rofl:

1 Like