Can't log into XFCE

Hello guys,
I just ran into the following issue.
I updated my system a few minutes ago and had to reboot, I get the login screen, type my passphrase and hit Enter, the screen goes dark for a moment and instead of starting my XFCE session I’m back to the login screen.
I can open a Gnome session (in fact I’m writing this in the Gnome session) without problems. So no user or password issues. And there’s no error message.

Finally I found the solution here: XFCE login loop solved

Try again

sudo pacman -Syu

Didn’t help.
pacman says all is up to date and nothing to do.

Here’s what pacman updated just before the issue

[2023-02-12T14:45:32+0100] [ALPM] upgraded boost-libs (1.81.0-2 -> 1.81.0-3)
[2023-02-12T14:45:32+0100] [ALPM] upgraded e2fsprogs (1.46.6-1 -> 1.47.0-1)
[2023-02-12T14:45:32+0100] [ALPM] upgraded dbus (1.14.4-1 -> 1.14.6-1)
[2023-02-12T14:45:32+0100] [ALPM] upgraded freetype2 (2.12.1-1 -> 2.13.0-1)
[2023-02-12T14:45:32+0100] [ALPM] upgraded cryptsetup (2.6.0-1 -> 2.6.1-1)
[2023-02-12T14:45:33+0100] [ALPM] upgraded chromium (110.0.5481.77-1 -> 110.0.5481.77-2)
[2023-02-12T14:45:33+0100] [ALPM] upgraded fakeroot (1.31-1 -> 1.31-2)
[2023-02-12T14:45:33+0100] [ALPM] upgraded eos-update-notifier (1.18-1 -> 23-1)
[2023-02-12T14:45:33+0100] [ALPM] upgraded libadwaita (1:1.2.1-1 -> 1:1.2.2-1)
[2023-02-12T14:45:33+0100] [ALPM] upgraded libimagequant (4.0.4-1 -> 4.1.0-1)
[2023-02-12T14:45:34+0100] [ALPM] upgraded linux (6.1.10.arch1-1 -> 6.1.11.arch1-1)
[2023-02-12T14:45:37+0100] [ALPM] upgraded linux-headers (6.1.10.arch1-1 -> 6.1.11.arch1-1)
[2023-02-12T14:45:37+0100] [ALPM] upgraded lmdb (0.9.30-1 -> 0.9.30-2)
[2023-02-12T14:45:37+0100] [ALPM] upgraded postgresql-libs (15.1-1 -> 15.1-3)
[2023-02-12T14:45:37+0100] [ALPM] upgraded python-orjson (3.8.5-1 -> 3.8.6-1)
[2023-02-12T14:45:38+0100] [ALPM] upgraded qt6-webengine (6.4.2-1 -> 6.4.2-2)
[2023-02-12T14:45:38+0100] [ALPM] upgraded sudo (1.9.12.p2-1 -> 1.9.12.p2-2)
[2023-02-12T14:45:38+0100] [ALPM] upgraded vala (0.56.3-1 -> 0.56.4-1)
[2023-02-12T14:45:38+0100] [ALPM] upgraded vte-common (0.70.2-1 -> 0.70.3-1)
[2023-02-12T14:45:38+0100] [ALPM] upgraded vte3 (0.70.2-1 -> 0.70.3-1)
[2023-02-12T14:45:39+0100] [ALPM] upgraded xfce4-notifyd (0.7.3-1 -> 0.8.0-1)
[2023-02-12T14:45:39+0100] [ALPM] upgraded xfce4-power-manager (4.18.0-1 -> 4.18.1-1)
[2023-02-12T14:45:39+0100] [ALPM] upgraded xfce4-session (4.18.0-1 -> 4.18.1-1)
[2023-02-12T14:45:39+0100] [ALPM] upgraded xfce4-settings (4.18.1-1 -> 4.18.2-1)
[2023-02-12T14:45:39+0100] [ALPM] transaction completed

Which display manager do you use? Does your passphrase contain characters which are different when using a US or DE keyboard? Example: y or z.

I use lightdm. There is no problem with keyboard settings or passphrase characters, I can log into a Gnome Session without problem but when I try to start a XFCE session I get back to the login screen.

Do you have a ~/.xsession-errors file showing error messages?

Yes, there is an error message in .xsession-errors
xfce4-session: symbol lookup error: xfce4-session: undefined symbol: xfce_screensaver_lock

But it’s all Greek to me

1 Like

Just guessing. I assume that xfce4-screensaver is installed

Perhaps check if somehow the xfce4 config is broken.

mv ~/.config/xfce4 ~/.config/

and try to login into xfce4 again.


this is the complete file/log?

Same problem on arch. Same dm, same steps. Downgrading xfce4-session package worked for me.


No, it’s not broken.
Vielen Dank für Deine Mühe!

Yes, it’s the complete log.

Worked for me too. Thanks for sharing and welcome to the purple community :enos_flag: :rocketa:

So what’s best practice now? Put xfce4-session on the ignore list until a new version shows up?

Interesting. On my system I have

xfce4-session 4.18.1-1

and no problem at all. What specifically does bring up the problem?

I really don’t know.
I ran yay and did a reboot because linux and linux-header packages were updated. After the reboot I typed in my password, hit Enter and the screen turns black for a few moments and instead of showing the XFCE desktop I’m back to the log-in screen.
I can reproduce this by updating to xfce4-session 4.18.1-1 again.

I have no problem on my desktop either, only on my laptop. I can’t find the right way to track errors from xfce4-session. Please share if you know.

I do not know for sure but if I have an error in xfce4 I usually look in

  • ~/.xession-errors
  • or use journalctl --since <date> or journalctl -xe (not sure if this gives more information)
  • or /var/log/Xorg.0.log if I believe it is an X error
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.