What happens in the EOS install process?

So, the main reason why I’m making this post is because I’m trying to create a minimal Arch VM to watch streams from, including twitch.tv, but I’m getting the infamous “browser not supported” message when trying to login, despite using Brave. I’ve already tried posting on the Arch subreddit, but haven’t gotten any useful answers. As the post says, the problem is specific to this Arch VM, but it’s also prevelant in all the other clones I have set up. The problem isn’t replicated on VMs running Windows, Mint, Manjaro, and, you guessed, Endeavour.

I’ve already tried comparing which packages are missing from my Arch VM compared to the EOS VM I spun up and just installed all of them (except EOS’s exclusives), but that didn’t fix the problem, which tells me that the problem is deeper than that; that there’s some sort of configuration EOS did that I didn’t. It might be network-related since what’s causing it is the twitch integrity check failing, but I don’t know yet. I’ve tried searching around on the repo but it really isn’t clear on where to look. I’m hoping I can be pointed in the right direction to be able to figure out what the EOS install process does differently. Thanks.

Simple answer, Twitch doesn’t allow Linux. One thing you could try is using the MS-Edge browser (in the AUR) for it, afaict. Some people have tried programming workarounds for that integrity-check, but currently none seems working in a desired way? (Example - Do not use this, see warning!)

I’m sorry, but this is just not true. As I said, VMs running Mint, Manjaro and EOS worked just fine.

Also, I tried giving you the benefit of the doubt and installing Edge, but that didn’t work either. It’s also worth adding here that no extra browsers work under my Arch VM, but under the others, other browsers do.

1 Like

Hm, sorry for mis-reading your OP then.

1 Like

It’s got to be a package, there’s very little EOS sets up beyond the package just outside of their apps. So if you aren’t installing those, I’m at a loss. They don’t touch the config files outside of wallpaper unless you use the themed xfce.

You could read thru the calamares script??

A workaround that might work would be to change your browser’s user agent.

  1. Launch Brave and navigate to the desired site
  2. Press: Ctrl-Shif-I
  3. At top right click on the 3 vertical dots > More tools > Network conditions
  4. At the bottom, uncheck the box: Use browser default > Custom… scroll up and down and choose another user agent.
  5. Try some and see if one or other will work.

If it doesn’t then…

@Azsorlex -
I’m sure you have ffmpeg and gstreamer installed? The gstreamer-pkg. has been flagged out of date just a few days ago.

This was my thought process as well, but I installed the packages that weren’t there and that still didn’t work. Even just a moment ago as a final hail mary, I did a pacman -Syu --needed of all (most) of EOS’s packages. No comparing missing packages, just all of them, rebooted, and that still did nothing.

I’ve loaded up the calmares repo, but where do I even look? There’s so much stuff in there.

forgive . i no use twitch or watch tv… seem work on my arm vm. i use librewolf

maybe i no understand thread …

BTW this no EOS. just Arch


The problem is logging in:

1 Like

Did you try changing the user agent on twitch.tv as described here?

Would be good to know what works and what not to know what to look for.

Run a diff on pacman -Qe from the guest and from the host and put it in the thread so we at least have a snippet of information to go off of. No one here has any idea how you set up your Arch installation; it is difficult to troubleshoot it for you without a single clue to go on.

This issue is not related to EOS any more than it is related to Linux Mint, which is to say the Calamares installation process is not the smoking gun you are making it out to be.

No idea don’t there shouldn’t really be anything special to cause what you’re saying is happening anyways.

It sounds like an xy problem, when really it’s probably a missing program or dependency.

just idea . you use " privacy.resistFingerprinting " i have problem before on few web site .

i turn off ,delete any cookie for site then restart browser . :pray: zero idea on twitch


Various browser-extensions and -hardening measures can prevent a browser-login to twitch.

Simple solution, get a clean browser(-window) and try logging in from there.

1 Like

I already have in the Arch thread. Here’s the paste

So play-back (without login) is not an issue?


I have, and that also didn’t work. The new agent was even reported in the integrity request.

1 Like

I guess the problem maybe is not browser related, on the contrary it’s audio driver or audio server related.
In win 10 VM, only with the following settings can the audio stream be detected by the host pavucontrol under pipewire server.
VM audio set up::
host audio driver = Alsa-audio
audio controller = Intel HD Audio
So please show your audio server with ‘pactl info’.
If pipewire server, please show your pipewire configuration.
All my guess is maybe twitch.tv just checks your vedio and audio format, then you are disqualified.
If i set audio controller = ICH AC97, win 10 media-player simply will not play.