Wanting to install on Oryx Pro with Coreboot

Hi all ! I’m looking at installing on Oryx Pro Hybrid with Coreboot . Is it possible ? This is my first NVMe drive . Looked at drive , and has 4 partitions . What is the proper set-up for this kind of drive . Do i need to keep any partitions intact . Will Coreboot cause any proplems .
I’ve always in the past just formatted hard drive and created my 3 partitions ( root / swap / home ) . Does all this change or stay the same . To much reading into this has just caused confusion and stress ! Still worse with hybrid video .
I’m ready , were do i start . Thanks!

hello , You can set your computer configuration. Thanks.

It through me off track when i seen 2 fat32 partitions on the drive . It was the EFI one i was worried about . Will do install shortly . THANKS

1 Like

Let’s wait until you have already done the installation and the steps you used to do so before we solve this thread :hugs:

Hello @Moonfrog
I am also interested in knowing how EndeavourOS will work on a system76 laptop with coreboot. Could you post the current partition setup if you haven’t installed yet?

lsblk -l

Results of install , sucess ! A few extra steps required . What i did .
1 - Formated drive
2 - Create Partition table , changed from MSDOS to GPT
3 - partition 1 , fat32 , 512mb , labeled boot/efi , set flag to boot .
4 - partition 2 , created ext4 n gparted and set as root through installer
5 - partition 3 , created ext4 in gparted and set as home through installer
6 - partition 4 , created swap
7 - closed gparted and started installer .
8 - must set fat32 efi partition to boot , not root .
9 - set the other partitions as root/home/swap , continue install .
ALL DONE !

  • note , had to install System76 drivers through yay for the tap fuction to work on touchpad . Still need to install video drivers , but everything else working great . Keyboard lights work .
    Sorry Ricklinux , i had already formated drive before reading your post . Here is what i remember . 4 partitions , 2 fat32 partitions one as EFI and second set as recovery . 3rd partition was ext4 for PopOS , and last was a swap file .

Hope this helps others .

3 Likes

Thanks for the update. The extra partition was for recovery. I was curious when you first reported two EFI partitions. Everything is normal as it should be from what you are reporting. I was curious if core boot would be an issue.
Thanks.

Glad you were able to get it installed. Please let us know how it works on that hardware. I’m sure it’s going to be awesome.

Looks like i will need help with RTX 2070 video card . Too many conflicting how-to’s . Do i use drivers from nvidea or from Arch . The more i read the more lost i get . The card is a RTX 2070 hybrid . I’m using KDE .
I downloaded the drivers from nvidea and got stuck trying to install . Started reading further to install and came across a how-to stating those drivers won’t work . Just need simple install instuctions . HELP ! Thanks .

Maybe you could try command:

  nvidia-installer-dkms -h

It would install nvidia-dkms from the Arch repository, and later updates come easily from there also.

Thank you Manuel , gonna try now . Will report back shortly

Note: you need to install linux headers too.
Either linux-headers or linux-lts-headers, depending on which one you have installed (or both).

Note that the -h option only gives help.

Normally you’d try first this:

nvidia-installer-dkms -t

to see if all is OK.

If it is, then you would do e.g.

sudo nvidia-installer-dkms

to install the drivers.

Check the other options for installing nouveau and bumblebee if they are what you want.

Note also that rebooting after install is necessary.

Some reading:

Well , problems already . Opened terminal and typed nvidia-installer-dkms -t , resulted in message command not found . Even tried as sudo and same results . Yes i made sure header installed . What’s wrong , what next ?

What is the terminal command i’m suppose to enter .
I’m i suppose to just enter nvidia-installer-dkms -t in terminal or is there something else i’m missing like pacman something . not sure . Yes i would like bumblebee also . Will continue reading the referred post while waiting for help .

It should be nvidia-instsaller-dkms -t

This runs in test mode.

Edit: for bumblebee

nvidia-installer-dkms -b -t

If the test runs with no errors then use.

sudo nvidia-installer-dkms -b

This will install with bumblebee.

Hello Rick , Thank you . Just tried that command and same results , command not found . Do i need to install something first . Is the installer a package needed to be installed first and run setup through terminal .

I thought it should be installed already? Maybe check if it is.

It says it’s installed by default according to the wiki.

Just searched with yay and no it is not installed . Installing now and will try again .