Want to experiment with Lightdm slick greeter?

By default, EndeavourOS uses LightDM for the log-in, and uses the lightdm-gtk-greeter. There is absolutely nothing wrong with lightdm-gtk-greeter, but if you’re like me and just have to tinker around, here is how to play around with lightdm-slick-greeter.

Open a terminal window, and as root install lightdm-slick-greeter and lightdm-settings from the AUR using yay
# yay -S lightdm-slick-greeter
Tell it to erase compiler only dependencies so it cleans up after itself.
# yay -S lightdm-settings
Now you should have 2 lightdm greeters installed. To see,
# ls -l /usr/share/xgreeters (This should list a .desktop file for each greeter)
-rw-r–r-- 1 root root 187 Sep 30 2018 lightdm-gtk-greeter.desktop
-rw-r–r-- 1 root root 131 Jul 11 20:50 lightdm-slick-greeter.desktop
Here is how you determine which lightdm greeter is active, lightdm-gtk-greeter is default
open mousepad as root
# mousepad /etc/lightdm/lightdm.conf
scroll down past “General Configuration”, down to “Seat Configuration” and then to the line
[Seat:*]
About sixteen lines below this is the “greeter-session” key (they call the config settings “keys”)
#greeter-session=example-gtk-gnome
The # indicates a comment, so this key is disabled and it uses the default of lightdm-gtk-greeter
So we need to uncomment this key by removing the # then specify the greeter to use
greeter-session=lightdm-slick-greeter (for the slick-greeter)
OR, but not both
greeter-session=lightdm-gtk-greeter (for the gtk-greeter)
save the file. Next, as root open mousepad again
# mousepad /etc/lightdm/slick-greeter.conf This file will not exist, so mousepad will create it
add the following lines to slick-greeter.conf:

[Greeter]
draw-grid=false
background=/usr/share/backgrounds/xfce/blue-mystic-logo.png

change background= to whatever background file you desire. Then save the file.
Now reboot (yes it’s necessary) the computer for this to take effect.
blue-mystic.png is available here, right click on it and “Save Image As”


Then as root, move it to /usr/share/backgrounds/xfce

After you reboot, Click on “EndeavourOS” on the panel, then “Settings” and you will see “Lightdm GTK+ Greeter Settings” and below it “Login Window”. Use Lightdm GTK+ Greeter Settings" for the gtk-greeter, and “Login Window” for lightdm-slick-greeter, which ever is active.

Pudge

I try to think, but nothing happens!

5 Likes

If you want to play around with putting EndeavourOS logos on existing background files for desktop or lightdm backgrounds, here is a zip package with the Logo in four different sizes.

Logos - four sizes

2 Likes

Hey, that’s a nice background! Thanks for sharing. :grinning:

Thank you for sharing the logos, for people who are interested in this you can also download the dark and light themed logos over here.

1 Like

I figured out how to take a screenshot of the LightDM login screen. Since I didn’t actually show what the Lightdm-slick-greeter looks like in action, here it is. Not only does it have the Endeavour Logo but also an Endeavour Motto I came up. Alright it’s a lyric I stole from a song. I just changed the I to we.

What do you think of the Motto

5 Likes

@Pudge slick-greeter is my favourite here also!
It’s so slick, and simple beautiful !

1 Like

We need some login screens like this. :+1:

1 Like

If you open “Menu” “Administration” “Login Window”, in the “Appearance” tab, at the bottom is an Category named “Optional Pictures” there is an option called “bottom left”. I found out that if you put a logo image file there, it appears in the bottom left no matter what background you use. It just overlays this image over the background in the bottom left of the screen. Like this:

The catch is, it can only be < 90 pixels tall and I don’t think there is any limit on width.
So, someone who is artistic and knows Gimp or Photoshop or whatever could come up with an image that has the logo at 85 pixels tall with EndeavourOS to the right of it instead of under it. Like in post five above, except without the motto.
Does anyone know what font the EndeavourOS in the logo is?
Plus we need “EndeavourOS” with black letters for backgrounds that are a light color in the lower left, and one with “EndeavourOS” in white letters for backgrounds that are a dark color in the lower left. The logo itself is in the middle of dark and light enough that it more or less stands out either way.

I’m going to play around with this when I get time. Anyone who wants to take a shot at this, see what you can come up with that would be similar to the fedora logo above.

I know the fedora login screenshot is heresy here, but it shows what can be done for the slick-greeter. Plus it shows another interesting point. Fedora Cinnamon uses Openbox for it’s window manager, and I believe Arch Cinnamon uses mutter. But that’s another story for another thread.

Definitely this slick puts EOS in beauty mode.
I will give it a shot this weekend
Thanks so much @Pudge

2 Likes

You are welcome my friend.

Thanks, it is great to get some feedback. :smiley:

Pudge

I try to think, but nothing happens!


a standard style one?

2 Likes

Oh ya … i like this for Xfce? Somebody better post the background for that one.

Wow, I like the logo that fits in the bottom left. :smiley:
I assume that the Endeavour logo in the lower left is an image that can be applied to any background through lightdm-slick-greeter-options in the Category named “Optional Pictures” in the option called “bottom left”.

May I ask how many pixels tall the logo is?
Nice work.

Pudge

Hello @Pudge I have been using the slick greeter and have installed it a number of times. Since i have been testing the installer now i can’t get it to show the background image and i don’t know why. Everything is correct and when i install slick greeter it sets up in lightdm.conf. I only have to add the slick-greeter.conf
I add the image to backgrounds folder where Cinnamon has the gnome folder with backgrounds. It only shows a black screen with dots in the background like the grub screen has. The image won’t display? I’m stumped…as i don’t understand why? Could it be the image? This is another fresh install of Cinnamon. There are no issues with it just the greeter background image. The greeter itself works. Any ideas?

Are you saving this image for the launch of the online installer? I think it will go great with Cinnamon desktop! :laughing: And set up with the slick greeter!

I am afraid that we start using to much AUR packages… adding one after the other will end in a growing Repository, and we do not want this.
Aside from this I do like the minimal buty of slick greeter.

1 Like


I am assuming you already used yay to install lightdm-settings.
Click on Menu in the panel, then Administration, then Login Window and get the above

At the top under Background

   Background             enter the pathname of the desired image
   Draw user backgrounds  turn off
   Draw a grid            turn off

Should work.

Pudge

1 Like

path to inage must be readable by lightdm, so folder must be simple under /usr/share/backgrounds, if picture is inside users home it will not show up.

2 Likes

I’ll take a look at it and try again. I never had any issue with it before. Now all of a sudden it won’t display the image. @joekamprad i am putting the file in /use/share/backgrounds

do you check permissions on the pictures?

ls -la /usr/share/backgrounds
  • r refers to the read permission.
  • w refers to the write permission.
  • x refers to the execute permission.

https://wiki.archlinux.org/index.php/File_permissions_and_attributes