Waiting for USB printer to come available

Trying to print in swaywm

kernel 5.18.3-arch1-1
printer brother MFCT910DW

worked nice in i3wm
but now in this new endeavouros installation, when I send to print, it doesn’t print.
CUPS job status says:
*Waiting for printer to become available."

Now, the interesting thing is that, when I reboot computer, just after login screen, printer prints whatever I sent to it on last session (although I suspect it is not using the right colors).

Tried

sudo systemctl restart cups.service

to no avail

Tried unplugging and plugging USB in another USB port, but nothing happens.
Tried turning off and then back on printer, but nothing happens.

Any ideas welcomed

thanks!

First of all did you install printing support when you installed EndeavourOS? There is a check box for that.

Edit: https://discovery.endeavouros.com/printers/printers/2021/03/

What’s in “/etc/cups/ppd/” and “/usr/share/cups/drv/” ?

Yes I did! (I left HP printing drivers unchecked though, as mine is not HP)
And printer did work some weeks ago, when I tested print after driver installs, it did print. And I also think I printed some documents, it might not have worked at first but after switchung USB port, it did

/etc/cups/ppd
MFCT910DW.ppd

/usr/share/cups/drv/
cupsfilters.drv  generic-ubrl.drv  indexv4.drv  splix-dell.drv     splix-samsung.drv  splix-xerox.drv
generic-brf.drv  indexv3.drv       sample.drv   splix-lexmark.drv  splix-toshiba.drv

How did you install the drivers and set it up. It should have been as easy as installing
the package from the AUR because it is hooked to usb.

yay -S brother-mfct910dw

Edit: After installing and printer is plugged into usb and turned on it should automatically find it. Otherwise go into print settings and you can add it if it doesn’t automatically and select usb as the port.

Screenshot_20220615_223558

the AUR package
https://aur.archlinux.org/packages/brother-mfct910dw
is not working fine.

More info here:

Printer is available and works. Just that not when I issue the print command.
I am not using KDE Plasma, so I manage through CUPS web interface

Sure you can install the printer through the CUPS web interface but you may be doing it incorrectly. Are you telling me the install of the AUR package works? Or it doesn’t build? If it does then check the cups web interface again. You may have to remove the printer and add it again but check what you are selecting. Sometimes it has more than one entry for a printer.

Edit: Also have you looked at the wiki as now there is a firewall also to contend with.

Edit2: I read over the previous post and the AUR package was loaded by @joekamprad so it should work.

Maybe I’m misunderstanding you? Are you trying to issue a print command from the terminal?

no, sorry. In this case I am using Okular and issuing the print order from there (as a regular user, no terminal whatsoever)

I thought you said you weren’t using KDE?

Edit: It works for me.

Edit: I just printed no problem.

The AUR package installs OK but printer won’t print in duplex mode. Haven’t tried it on this install of endeavourOS but have tried before, and reviewed the whole issue with @joekamprad in the forum link I mailed before. Finally talked closely to a brother service agent and then we concluded that for some strange reason the AUR package was not working ok, but if I install by using the rpm provided by brother, using rpm-tools, everything worked OK in my last EndeavourOS i3wm install.

You can check this exact comment at the forum post for clarification:

haha
Sorry
I am not using plasma (I am using Swaywm) but I do have a bunch of KDE stuff for dolphin, Okular, and something else, which I love.

That’s fine it’s just a little confusing when you don’t have ALL the information. So Is the issue duplex printing or not printing at all?

the actual issue is the one stated at the top of this thread:
not printing at all, unless I reboot system

The thing about duplex was a past issue, that was solved by not using the AUR package.

Well that has to be an issue with the usb port? Do you have usb autosuspend turned off? Or some other reason? Have you checked sudo dmesg and or boot logs when trying the printer using journalctl commands?

This should have been the topic then. :wink:

Edit: So does it print when you reboot but then when does it not work? After some time?

I haven´t done any specific usb port config
this autosuspend off you mean at the BIOS level? If so, I will check
I haven’t checked any journalctl/dmesg messages
would you recommend any specific commands to try? this would be just after sending the thing to print to cups?

does this mean something?

Jun 15 23:18:51 jo***-**gc kernel: usb 1-1: usbfs: interface 0 claimed by usbfs while 'usb' sets config #1

I think it might. Have you tried other usb ports?