Can't make Brother MFCT910DW to print

Then you won’t want to choose ‘Internet Printing Protocol (ipp)’
you will want to choose something under “Local Printers”
I THINK (I’ve never installed a Brother Printer on USB) the rest will be pretty much the same.
I think the ‘{current_make_and_model} IPP everywhere’ for the driver is the key item.

Yes systemctl is what you want to use. Don’t know why I said systemd? :man_shrugging:
I guess the elderly shouldn’t write posts after their bedtime. At least the keyboard isn’t a sharp or pointy object! :man_in_manual_wheelchair:


1 Like

the AUR PKGBUILD do not look right to me, it uses the right driver but the way it is installed is not looking complete to me, it only extracting one part of the driver package and it looks like to the wrong path…

1 Like

PKGBUILD needs to look like this:

# Maintainer: joekamprad (

pkgdesc="Brother MFC-T910dw CUPS driver"
arch=('i686' 'x86_64')
arch=('i686' 'x86_64')
depends=('cups' 'ghostscript')

  cp -R "$srcdir/opt" "$pkgdir/opt"
  install -d "$pkgdir/usr/lib/cups/filter/"
  ln -s "/opt/brother/Printers/mfct910dw/cupswrapper/brother_lpdwrapper_mfct910dw" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_mfct910dw"

  install -d "$pkgdir/usr/share/cups/model/"
  ln -s "/opt/brother/Printers/mfct910dw/cupswrapper/brother_mfct910dw_printer_en.ppd" "$pkgdir/usr/share/cups/model"
  install -Dm644 "$srcdir/opt/brother/Printers/mfct910dw/LICENSE_ENG.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE_ENG.txt"
  install -Dm644 "$srcdir/opt/brother/Printers/mfct910dw/LICENSE_JPN.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE_JPN.txt"


I noticed you had the line

arch=('i686' 'x86_64')

entered twice. Also, IF this is an official PKGBUILD that will appear in the AUR could you add aarch64 and armv7h to the architecture line.

arch=('i686' 'x86_64' 'aarch64' 'armv7h')


but sadly i am not at the AUR.

The error message is telling you it is missing a CUPS filter. Sometimes manufacturer’s Linux printer driver packages don’t unpack correctly and CUPS filters end up in the wrong folder. I have a suggestion: Use something like catfish to search your file system for -brother_lpdwrapper_mfct910dw. If you find it, copy & paste it into /usr/lib/cups/filter/. I use Thunar opened with root privileges to do stuff like this (sudo thunar). Once you have pasted in the missing CUPS filter, right click it and check permissions–make sure it can run as a program. After you’ve done all that, see if you can print a test page. I have to do this every time I set up my Kodak printer in Linux and it has always gotten my printer to work.

it was simply what you say so I do create a hopeful working package :wink:


thanks to everybody!
but I am a little confused. This is what I understand.
Pudge solution shouldn’t work because AUR package is flawed (in fact his steps are I think just what I did in first instance)
joekamprad created a PKGBUILD. I should use that to install the drivers?
Specific instructions or link on how to do that? :grimacing:
sorry for my newbieness

fecklesstech solution’s did not work for me.

But I managed to do it in a completely different way (I remembered looking old manjaro forum how I made it a couple of years ago)

Basically, I downloaded RPM version of Brother Driver Install Tool from here:
and then proceeded to sudo sh the file. (I had previously installed rpm-org from AUR)
Everything went smooth
Is this method unrecommended?

Not really, as the AUR packages for Brother printers typically fetch the drivers from the same site.
But you may need to manually check the updates from that same place if there are any.

I don’t like the idea of not using the PKGBUILD after joekamprad made the effort to script it though

PKGBUILD is of course a better solution in the long run.

I also have a Brother multifunction printer (but different model), and made a PKGBUILD for it by copying and modifying the closest model’s PKGBUILD in the AUR.

Learning how the PKGBUILD process works is a worthwhile “Endeavour” with Arch Linux. It is something unique to Arch Linux.

In a terminal window, create a temporary file in your home directory, such as Temp. Then cd into Temp.
Enter the following command
$ git clone
This will download the contents of @joekamprad 's github entry.
$ cd brother-mfct910dw
$ ls -l
should see PKGBUILD
as user, compile the PKGBUILD as such
$ makepkg -cs[i] PKGBUILD

the -c option = Clean up leftover work files and directories after a successful build
the -s option = Install missing dependencies using pacman.
the -i option = Install or upgrade the package after a successful build using pacman.
exclude the -i option to just build the package and not install it

I did the above commands, the PKGBUILD built the package without complaints

Since you have it working, you could leave out the -i install option, and just build the package. I would then save the package on a NAS or USB thumb drive in case you need to re-install the driver some day.

To install this package:
$ sudo pacman -U brother-mfct910dw-1.0.0-0-aarch64.pkg.tar.xz

the -U option
Upgrade or add package(s) to the system and install the required dependencies from sync repositories.

Use -U when built package are not in the Arch Repositories, in this case the package is in your home directory tree.

If the desired package is in the AUR and isn’t corrupt, you can install it with yay
$ yay -S package_name
and yay will do essentially the same thing as above.



that’s great. Would you suggest contributing this PKGBUILD to the AUR? Is that too difficult to do? In the meanwhile I commented the existing AUR package

contributing to AUR will need also to maintain the PKGBUILD and not like simply uploading it:

just see that PKGBUILD has no Maintainer :::

But let’s hope the one with the non working PKGBUILD on the AUR will see your comment and change it so you and others with that device can use it…

I do simply add it to the AUR:
so you can now install with yay:
yay -S brother-mfct910dw


that’s amazing. Definitive solution here. thanks a lot!

I was just curious how complicated it is to load a PKGBUILD into the AUR;)


Although everything else did work OK, Duplex is not working for me with the driver installed with this AUR package. Tried to find why with Brother specialist but couldn’t work it out. Finally made it work by directly installing the brother rpm package (you have to install community repo rpm-tools first)

Thanks for the follow-up info! :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.