Waiting for USB printer to come available

the AUR package
https://aur.archlinux.org/packages/brother-mfct910dw
is not working fine.

More info here:

Printer is available and works. Just that not when I issue the print command.
I am not using KDE Plasma, so I manage through CUPS web interface

Sure you can install the printer through the CUPS web interface but you may be doing it incorrectly. Are you telling me the install of the AUR package works? Or it doesn’t build? If it does then check the cups web interface again. You may have to remove the printer and add it again but check what you are selecting. Sometimes it has more than one entry for a printer.

Edit: Also have you looked at the wiki as now there is a firewall also to contend with.

Edit2: I read over the previous post and the AUR package was loaded by @joekamprad so it should work.

Maybe I’m misunderstanding you? Are you trying to issue a print command from the terminal?

no, sorry. In this case I am using Okular and issuing the print order from there (as a regular user, no terminal whatsoever)

I thought you said you weren’t using KDE?

Edit: It works for me.

Edit: I just printed no problem.

The AUR package installs OK but printer won’t print in duplex mode. Haven’t tried it on this install of endeavourOS but have tried before, and reviewed the whole issue with @joekamprad in the forum link I mailed before. Finally talked closely to a brother service agent and then we concluded that for some strange reason the AUR package was not working ok, but if I install by using the rpm provided by brother, using rpm-tools, everything worked OK in my last EndeavourOS i3wm install.

You can check this exact comment at the forum post for clarification:

haha
Sorry
I am not using plasma (I am using Swaywm) but I do have a bunch of KDE stuff for dolphin, Okular, and something else, which I love.

That’s fine it’s just a little confusing when you don’t have ALL the information. So Is the issue duplex printing or not printing at all?

the actual issue is the one stated at the top of this thread:
not printing at all, unless I reboot system

The thing about duplex was a past issue, that was solved by not using the AUR package.

Well that has to be an issue with the usb port? Do you have usb autosuspend turned off? Or some other reason? Have you checked sudo dmesg and or boot logs when trying the printer using journalctl commands?

This should have been the topic then. :wink:

Edit: So does it print when you reboot but then when does it not work? After some time?

I haven´t done any specific usb port config
this autosuspend off you mean at the BIOS level? If so, I will check
I haven’t checked any journalctl/dmesg messages
would you recommend any specific commands to try? this would be just after sending the thing to print to cups?

does this mean something?

Jun 15 23:18:51 jo***-**gc kernel: usb 1-1: usbfs: interface 0 claimed by usbfs while 'usb' sets config #1

I think it might. Have you tried other usb ports?

I’m not sure if there is an auto suspend issue or not? You can disable usb auto suspend completely by using a kernel parameter. You could try it i suppose. You add it to the default grub command line and then update grub. If it doesn’t work or causes other issues then you’d have to remove it and update grub again.

usbcore.autosuspend=-1

Edit: I would suggest trying other usb ports first.

1 Like

i am with @ricklinux looks a bit like something is going to “sleep” if it is working after a reboot…
Could be the USB port tor the printer… i see similar issue here with my HL-L2350BW and i do not use any driver installed and instead using IPP driverless love network (WIFI) and if printer is a in deep sleep i can not wake it up with try to print…

Yes, I’ve switched between all 3 USB ports but CUPS keeps waiting for printer to become available.

OK, as I’ve already tried other USB ports, I’ll try this, but first by editing boot parameters temporarily on boot, and then check.
Will report back
thanks!

ok. tried this boot grub parameter (editing grub at boot). problem persisted.

also checked BIOS options about USB suspend. there were none.