Waiting for USB printer to come available

I’m not sure if there is an auto suspend issue or not? You can disable usb auto suspend completely by using a kernel parameter. You could try it i suppose. You add it to the default grub command line and then update grub. If it doesn’t work or causes other issues then you’d have to remove it and update grub again.


Edit: I would suggest trying other usb ports first.

1 Like

i am with @ricklinux looks a bit like something is going to “sleep” if it is working after a reboot…
Could be the USB port tor the printer… i see similar issue here with my HL-L2350BW and i do not use any driver installed and instead using IPP driverless love network (WIFI) and if printer is a in deep sleep i can not wake it up with try to print…

Yes, I’ve switched between all 3 USB ports but CUPS keeps waiting for printer to become available.

OK, as I’ve already tried other USB ports, I’ll try this, but first by editing boot parameters temporarily on boot, and then check.
Will report back

ok. tried this boot grub parameter (editing grub at boot). problem persisted.

also checked BIOS options about USB suspend. there were none.

Ok. Nothing worked
until I
installed the printer again using KDE network manager GUI app
using driverless option
and selecting MFC-T910DW CUPS


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.