Vulkan not found ERROR_OUT_OF_HOST_MEMORY

Basically my Vulkan cannot run because im “out of memory”

✘ mixel@mixel-ms7a33  ~  vulkaninfo 
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.199/vulkaninfo/vulkaninfo.h:689:vkCreateInstance failed with ERROR_OUT_OF_HOST_MEMORY

My Gpu memory also isnt full

Fri Dec 10 16:58:50 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 495.44       Driver Version: 495.44       CUDA Version: 11.5     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:26:00.0  On |                  N/A |
|  0%   56C    P0    27W / 200W |   1697MiB /  6075MiB |     21%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

Also my ram also isnt full

               total        used        free      shared  buff/cache   available
Mem:            15Gi       5,0Gi       4,6Gi       559Mi       6,0Gi       9,8Gi
Swap:          8,0Gi          0B       8,0Gi

And Lutris is saying that my GPU is “unknown”

2021-12-10 16:36:41,445: Starting Lutris 0.5.9.1
2021-12-10 16:36:41,481: No cores found
2021-12-10 16:36:48,341: Startup complete
INFO     2021-12-10 16:36:48,342 [startup.check_driver:53]:Using NVIDIA drivers 495.44 for x86_64
INFO     2021-12-10 16:36:48,342 [startup.check_driver:57]:GPU: Unknown
INFO     2021-12-10 16:36:48,342 [startup.check_driver:73]:GPU: 10DE:1C03 1462:3281 (nvidia drivers)
WARNING  2021-12-10 16:36:48,376 [startup.check_vulkan:132]:Vulkan is not available or your system isn't Vulkan capable

In conclusion somehow vulkan isnt working anymore.
Yesterday there was an update for the nvidia drivers which could have broken it but im not sure.
In general yesterday everything went smooth without any errors.
I also checked if some dependencies magically disappeared but I tried reinstalling them but they were all already installed.
If someone has a clue I would be happy to hear them.

1 Like

Which Kernel?
Try LTS

How do I switch to lts?
I never did that

install:

sudo pacman -S akm

Then run it, it’s :enos: GUI Kernel manager, pretty straightforward to use :upside_down_face:

Just choose LTS, reboot and choose it on startup in menu

For some weird reason my ethernet doesn’t work on the lts kernel
I installed it and removed the old (newest) kernel
But I just can’t get the lts kernel to get my ethernet to work
Does that have something to do with the switch I’m using?

What was the update? If things worked fine before, but don’t work after, then that’s likely to be the problem.

Yeah but what is the way to revert a package update?

Start by identifying which packages were updated.

Well first I would either have to get the normal kernel again to have internet access or fix that in the lts kernel since it doesn’t detect my ethernet for some reason

Did you uninstall the normal kernel? Why?


Why not just check which packages you updated yesterday?

I don’t know how to do that :confused:
I know that Pacman has a log which one it updates but I don’t know where it is located

/var/log/pacman.log

You can assume system log files should be in /var/log/ .

These are my pacman logs from yesterday&today

These are from yesterday

[2021-12-09T19:22:55+0100] [ALPM] upgraded filesystem (2021.11.11-1 -> 2021.12.07-1)
[2021-12-09T19:22:55+0100] [ALPM] upgraded lib32-vulkan-icd-loader (1.2.199-1 -> 1.2.202-1)
[2021-12-09T19:22:55+0100] [ALPM] upgraded liblouis (3.19.0-1 -> 3.20.0-1)
[2021-12-09T19:22:55+0100] [ALPM] upgraded libmwaw (0.3.20-1 -> 0.3.21-1)
[2021-12-09T19:22:56+0100] [ALPM] upgraded libx11 (1.7.2-1 -> 1.7.3-1)
[2021-12-09T19:22:57+0100] [ALPM] upgraded linux (5.15.6.arch2-1 -> 5.15.7.arch1-1)
[2021-12-09T19:22:59+0100] [ALPM] upgraded linux-headers (5.15.6.arch2-1 -> 5.15.7.arch1-1)
[2021-12-09T19:22:59+0100] [ALPM] upgraded vulkan-icd-loader (1.2.199-2 -> 1.2.202-1)
[2021-12-09T19:23:00+0100] [ALPM] upgraded nvidia (495.44-14 -> 495.44-15)
[2021-12-09T19:23:00+0100] [ALPM] upgraded qt5-base (5.15.2+kde+r262-1 -> 5.15.2+kde+r263-1)
[2021-12-09T19:23:00+0100] [ALPM] upgraded r8168 (8.049.02-40 -> 8.049.02-41)
[2021-12-09T19:23:00+0100] [ALPM] upgraded vulkan-headers (1:1.2.200-1 -> 1:1.2.202-1)
[2021-12-09T19:23:00+0100] [ALPM] upgraded xfsprogs (5.14.0-1 -> 5.14.2-1)

Some are from today.

[2021-12-10T14:01:43+0100] [ALPM] upgraded libx11 (1.7.3-1 -> 1.7.3.1-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded qt5-wayland (5.15.2+kde+r36-1 -> 5.15.2+kde+r37-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded signon-kwallet-extension (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded kaccounts-integration (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded libakonadi (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded akonadi (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded kmime (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded akonadi-mime (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded ksmtp (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded libkgapi (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded kmailtransport (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded kpimtextedit (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded kidentitymanagement (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded kcalutils (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded grantleetheme (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:43+0100] [ALPM] upgraded libkleo (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded akonadi-contacts (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded akonadi-calendar (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded akonadi-notes (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded akonadi-search (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded amdvlk (2021.Q4.1-1 -> 2021.Q4.2-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded archlinux-appstream-data (20211122-2 -> 20211210-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded ark (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded libkcddb (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded libkcompactdisc (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded audiocd-kio (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded baloo-widgets (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded libkdepim (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded kimap (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded kldap (21.08.3-2 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded pimcommon (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded calendarsupport (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded cantarell-fonts (1:0.303-1 -> 1:0.303.1-1)
[2021-12-10T14:01:44+0100] [ALPM] upgraded dhcpcd (9.4.0-1 -> 9.4.1-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded kio-extras (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded dolphin (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded dragon (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded elisa (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded eventviews (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded ffmpegthumbs (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded libkipi (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded libkdcraw (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded gwenview (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded kalarmcal (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded kamoso (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:45+0100] [ALPM] upgraded kate (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kcalc (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kcharselect (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kdeconnect (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kmbox (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kdepim-runtime (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kipi-plugins (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded konsole (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kpmcore (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded kwalletmanager (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded lib32-amdvlk (2021.Q4.1-1 -> 2021.Q4.2-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded libkexiv2 (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded okular (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded partitionmanager (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:46+0100] [ALPM] upgraded print-manager (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:47+0100] [ALPM] upgraded spectacle (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:47+0100] [ALPM] upgraded steam (1.0.0.73-1 -> 1.0.0.74-1)
[2021-12-10T14:01:47+0100] [ALPM] upgraded yakuake (21.08.3-1 -> 21.12.0-1)
[2021-12-10T14:01:47+0100] [ALPM] transaction completed

These look related to a Vulkan issue. Try downgrading each of these and see if it helps.

The packages are likely still in your /var/cache/pacman/pkg directory, or you can use the downgrade tool.

Yeah I thought so too
Wdym with the downgrade tool?

sadly I only find the newer versions which I installed in /var/cache/pacman/pkg



I think this is incorrect isnt it?

Read the page I linked to - it explains all of this.

I read the page and I don’t know what I’m not understanding :confused:
In the /var/cache/pacman/pkg are only the new installed packages
for example the vulkan-headers-1:1.2.202-1 which is the new package
There isn’t a vulkan-headers-1:1.2.199-1 existing in the directory
these also apply to the other packages.
And if I try to downgrade them I only see the size of the package and that it tries to reinstall them and there isn’t any net change which is suppose to happen (right?)

OK, so if you only have the current version of packages in you cache then you can’t downgrade the packages from there.

I thought the EnOS page had more information, but there’s more on the Arch wiki page:

https://wiki.archlinux.org/title/Downgrading_packages

Specifically, either download the packages from the Arch Linux Archive, or install and run the downgrade tool (there are some other options on the above page).