Vulkan not found ERROR_OUT_OF_HOST_MEMORY

So I downgraded every package with the downgrader (https://aur.archlinux.org/packages/downgrader-git/)
But it still says that my host is out of memory
also after a fresh reboot (which I did right now)

mixel@mixel-ms7a33  ~  vulkaninfo 
ERROR at /build/vulkan-tools/src/Vulkan-Tools-1.2.199/vulkaninfo/vulkaninfo.h:689:vkCreateInstance failed with ERROR_OUT_OF_HOST_MEMORY

And the downgrading tool was really simple to use and I’m 100% sure I selected the right packages but it still doesnt work :confused:

Also for the time being I booted my windows to play games and Vulkan is working without any issues.

Which packages?

  1. lib32-vulkan-icd-loader
  2. vulkan-icd-loader
  3. vulkan-headers

Then I tested it again and it still didn’t work so I also downgraded vulkan-tools
But same result after that
In the meantime I also tried the LTS kernel and the Zen Kernel.

On Windows vulkan is working as intended. So it has something to do with linux and probably the packages I updated

For some reason I tried reinstalling the normal nvidia drivers (out of frustration because maybe it could magically fix the error)
And I was greeted that a Kernel Module nvidia-drm was already loaded and so the installation failed (?)
heres the log:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Dec 11 13:12:50 2021
installer version: 495.44

PATH: /usr/local/sbin:/usr/local/bin:/usr/bin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

nvidia-installer command line:
    ./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Unable to load: nvidia-installer ncurses user interface

Using: nvidia-installer ncurses v6 user interface (widechar)
-> Detected 16 CPUs online; setting concurrency level to 16.
ERROR: An NVIDIA kernel module 'nvidia-drm' appears to already be loaded in your kernel.  This may be because it is in use (for example, by an X server, a CUDA program, or the NVIDIA Persistence Daemon), but this may also happen if your >
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com

I remember changing something with the nvidia driver so that it loads first. It should be this https://wiki.archlinux.org/title/NVIDIA#Early_loading.
Maybe that is my problem.

Is this just unrelated or could it actually be the cause of the problem?

I’d like to preface this that I am on vanilla Arch, and this is the only place I found that mentions this issue.

Hey, I’m having the same issue. But I don’t have an NVidia card. I only have an Intel card built into my Thinkpad. Vulkan not supported. The out of memory error with vulkan-tools.

I’ve tried the same downgrading icd-loader (and its 32-bit companion), and my kernel (zen).

I’ve made no headway into solving this, but I am rebuilding mesa for the vulkan-intel driver.

You’re not alone.

You could maybe try removing all the vulkan pakages and start from the begining?
https://wiki.archlinux.org/title/Vulkan#Selecting_vulkan_driver

Also, might try vulkaninfo with VK_LOADER_DEBUG=all might show you something interesting.

Hi bro i had the same Error, and i find the solution, the new installation of nvidia-drivers ubicates the file “nvidia_icd.json” in “/etc/vulkan/icd.d/”, but lutris when searchs for icd loaders checks in “/usr/share/vulkan/icd.d/xxxxxxx.json” so open in your file manager “/etc/vulkan/icd.d/” and look if “nvidia_icd.json” is there, in my case was there, so i copy the json of nvidia_icd loader to usr/share/vulkan/icd.d/ like this:

[winches@ArchZen-AMD64]$ sudo cp /etc/vulkan/icd.d/nvidia_icd.json /usr/share/vulkan/icd.d/

note: when you write the command let one space between the file to copy and the folder of destination:
“sudo cp /etc/vulkan/icd.d/nvidia_icd.json [one space here] /usr/share/vulkan/icd.d/”

that fixes my vulkan’s problem in lutris, sorry about my english i’m native spanish of argentina , i have arch-linux with kernel zen but i think is the same problem, i hope this fix your issue.

1 Like

PD: if it does not works try the command:

VK_ICD_FILENAMES=/etc/vulkan/icd.d/nvidia_icd.json lutris

Thank you for your reply.
Sadly I already reinstalled them a couple of times already
I downgraded/reinstalled/upgraded:
-vulkan-headers
-vulkan-icd-loader
-lib32-vulkan-icd-loader
-vulkan-tools
Is there any package I’m missing?

Also what do you mean with VK_LOADER_DEBUG=all?

I hope I will fix it soon :slightly_smiling_face:
If I find a solution I’ll try to inform you if you want to

Only thing I really found that it was a bug from 2016 which was fixed but otherwise I really didn’t find anything interesting or helpful

Okay I checked for some weird reason I have the vulkan folder in /usr/share/vulkan but there is no vulkan folder in /etc/
So I copied the vulkan folder into /etc/ and rebooted but still getting the same error :confused:

I also tested some games now but it seems that vulkan is still not working since they always crash

Sorry, it’s an environment variable. To temporarily set it, just type it in to your terminal before you run the program. VK_LOADER_DEBUG=all vulkaninfo


Sadly I’ve been done in with the same error today when I wanted to run FF XIV through lutris. First that my host OS doesn’t support vulkan and then to download DXVK. My debug log is in attachement. I am using vanilla arch and yesterday stuff was working.

Done the same step also didn’t help. That won’t be the factor sadly.

Okay ladies and gentlemen. For whatever reason there were AMD vulkan drivers on my host OS. I did not install them personally so that’s a weird one. Long story short removing amdvlk package solved my vulkaninfo nn working. Whole pipeline created successfully. Lemme see if games work too.

3 Likes

Holy it really fixed it!
I’m getting an output again from vulkaninfo (and all games work again!)
I just really don’t know how and why it installed amdvlk

Fixed for me too doing this. Though I have an eGPU, which I forgot to mention. Shame. I’m sure it’ll be fixed soon enough.

so all problems are in the environment variables, there are not set

amdvlk is in my files too and i didn´t install it, arch linux is not secure at all?