USB audio Devices Not Listed

Having lots of problems with USB audio devices, tried a couple different headsets and 3 different sets of speakers.

I plug the device in, I hear a “click” from the speakers/headphones as if they are connected, but they don’t show up as an audio device.
Running “usb-devices” seems to list them.

Beyond that I’m not sure how to even begin troubleshooting this. please help?

1 Like

Can you provide some more information? :hugs:

1 Like

Trying to follow the instruction above, installed pastebinit, generated the system log files, but it’s hanging when trying to upload the log files with
cat /tmp/journal | curl -F 'f:1=<-' ix.io

OK let’s start simple. Can you post the output of inxi -Fxxxza --no-host from a terminal?
If you don’t have inxi installed install it yay inxi.

that i can do
Right now none of the USB-audio devices are plugged in,

[james@Kalevala ~]$ inxi -Fxxxza --no-host
System:    Kernel: 5.8.5-arch1-1 x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux root=UUID=747ba70d-b809-4fcc-9602-bd38af1655ba rw rootflags=subvol=@ 
           quiet cryptdevice=UUID=f7a34f29-bad0-4929-a8e4-d9cb72bd01d2:luks-f7a34f29-bad0-4929-a8e4-d9cb72bd01d2 
           root=/dev/mapper/luks-f7a34f29-bad0-4929-a8e4-d9cb72bd01d2 
           resume=/dev/mapper/luks-f7a34f29-bad0-4929-a8e4-d9cb72bd01d2 loglevel=3 resume_offset=1980300 nowatchdog 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: EndeavourOS 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 1407 
           date: 04/02/2020 
CPU:       Info: 12-Core model: AMD Ryzen 9 3900 bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) model-id: 71 (113) 
           stepping: N/A microcode: 8701013 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 158467 
           Speed: 3300 MHz min/max: 2200/3300 MHz boost: enabled Core speeds (MHz): 1: 3300 2: 3300 3: 3300 4: 3300 5: 3300 
           6: 3299 7: 3300 8: 3300 9: 3299 10: 3300 11: 3299 12: 3300 13: 3299 14: 3299 15: 3300 16: 3300 17: 3300 18: 3300 
           19: 3299 20: 3300 21: 3299 22: 3299 23: 3300 24: 3299 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] vendor: XFX Pine 
           driver: amdgpu v: kernel bus ID: 0a:00.0 chip ID: 1002:731f 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu FAILED: ati 
           unloaded: fbdev,modesetting,radeon,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") s-diag: 777mm (30.6") 
           Monitor-1: DisplayPort-0 res: 2560x1440 dpi: 93 size: 698x393mm (27.5x15.5") diag: 801mm (31.5") 
           OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.38.0 5.8.5-arch1-1 LLVM 10.0.1) v: 4.6 Mesa 20.1.6 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 0a:00.1 
           chip ID: 1002:ab38 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0c:00.4 chip ID: 1022:1487 
           Sound Server: ALSA v: k5.8.5-arch1-1 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI 
           modules: r8169 port: f000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 10.01 TiB used: 3.06 TiB (30.6%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T2B0C-00PXH0 size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 211070WD scheme: GPT 
           ID-2: /dev/sda type: USB vendor: Western Digital model: WD Elements 25A3 size: 9.10 TiB block size: 
           physical: 4096 B logical: 512 B serial: <filter> rev: 1030 scheme: GPT 
Partition: ID-1: / raw size: 931.01 GiB size: 931.01 GiB (100.00%) used: 226.74 GiB (24.4%) fs: btrfs dev: /dev/dm-0 
           ID-2: /home raw size: 931.01 GiB size: 931.01 GiB (100.00%) used: 226.74 GiB (24.4%) fs: btrfs dev: /dev/dm-0 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: file size: 16.00 GiB used: 1.66 GiB (10.4%) priority: -2 file: /swap/swapfile 
Sensors:   System Temperatures: cpu: 42.4 C mobo: N/A gpu: amdgpu temp: 51.0 C mem: 52.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 537 Uptime: 22h 24m Memory: 15.60 GiB used: 7.38 GiB (47.3%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           alt: 9 Packages: 1439 pacman: 1434 lib: 358 flatpak: 5 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.06 

1 Like

Do you use your motherboards on board audio for anything?

I am right now simply because the USB devices aren’t working. Borrowing a pair of Analog headphones

Did you have it enabled at the time you had the USB devices plugged in? At any rate disable onboard audio in BIOS and try the USB device again.

3 Likes

That seems to work!!
Though it seems very much a “workaround” rather than a “fix” if that makes sense

Well what we did was basic trouble shooting 101. Keep it simple. By disabling in BIOS we eliminated any device conflict as there is now only one source for audio output. It is a workaround but what it now points to (which was really the point of the exercise) is that KDE plasma had the wrong output device selected in pulse audio. If you had onboard and USB running at the same time it may have been set to onboard as opposed to USB/headphones. Plasma just received a large set of updates and sometimes the selected audio device can reset. If you want to test further enable it in BIOS again and see if the USB devices still work. If not you know where to look trouble shooting wise as a next step. :wink:

3 Likes

Thank you! I appreciate it so much!!

3 Likes

Just wonder, what’s you USB audio-device?

1 Like

As said in the original post, I’ve tried se4veral, 2 different sets of headphones, and 3 different sets of speakers

Yeah but i was wondering which ones exactly…
Maybe it doesn’t matter if that’s all of them anyway.

ok and we’re back to not working
turned my speakers off for a while, took a nap came back, powered them on, nothing.
tried unplugging & replugging the USB cable, nothing

onboard audio is still disabled in the BIOS

Reboot.

I dont want to reboot everytiem I turn off my speakers…

As before what device shows as being used in pulse audio? Screenshot?

None


Top Right Corner

Right so you turned them off and they disconnected. You will need someone else to chime in here. Personally I would just turn the volume all the way down or mute them and leave them on.