Update Blues

So most every single update I spend a great deal of time getting my install to function properly again. I poke around the forum, find a couple of potential fixes, reboot, retry, and try again. At this point the last update I received killed the option to start EoS. Several attempts to get things minimally functional on my part have failed. So here we are.

I am running the latest Endeavour as far as I can tell but whose to say at this point. It is a dual boot system that runs Mint without so much as a hiccup on a separate partition. It is an ancient AMD system with a larger SSD and 8 GB of ram. Has an older Nvidia card, and with the recent updates, I expect this is where the issue lies.

So here we are. Anyways, what commands can I run and where to provide the needed details to diagnose what is happening? I seem to be able to get the terminal working and have a fully running Mint version I am browsing and playing on. Not complaining just wanting to resolve this issue. I know the community is helpful here and sadly my Linux skills are not great. I do read, research, and attempt to fix my own issues but am not having any luck at this point and decided to post to ask for assistance.

Thank you either way. :slightly_smiling_face:

inxi -Fxxxz is a good start for more information.

However, the most important thing would be describe what isn’t working exactly

As far as what doesn’t work; Endeavouros. Hangs on boot part way in. So, run the command you provided. Let me get the info.

So I ran the command and have output I cannot copy and paste. Is there a way to send / pastebin the information?

Run the following command and post the Link.

inxi -Fxxxz | eos-sendlog

The results of inxi Fxxxz.


  Kernel: 6.0.2-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0 Console: tty 2
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: CG1330 v: Rev X.0x serial: <superuser required>
    BIOS: American Megatrends v: 0403 date: 06/21/2010
  Info: 6-core model: AMD Phenom II X6 1045T bits: 64 type: MCP smt: <unsupported> arch: K10
    rev: 0 cache: L1: 768 KiB L2: 3 MiB L3: 6 MiB
  Speed (MHz): avg: 826 high: 958 min/max: 800/2700 boost: enabled cores: 1: 958 2: 800 3: 800
    4: 800 5: 800 6: 800 bogomips: 32560
  Flags: ht lm nx pae sse sse2 sse3 sse4a svm
  Device-1: NVIDIA GK104 [GeForce GTX 760] vendor: Micro-Star MSI driver: N/A arch: Kepler pcie:
    speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1187 class-ID: 0300
  Display: server: X.org v: driver: X: loaded: modesetting
    alternate: fbdev,nouveau,nv,vesa dri: nouveau gpu: N/A tty: 240x67
  Message: GL data unavailable in console. Try -G --display
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK M4A785TD driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: NVIDIA GK104 HDMI Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e0a class-ID: 0403
  Sound API: ALSA v: k6.0.2-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK M4A785/P7P55
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: e800 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.82 TiB used: 20.52 GiB (1.1%)
  ID-1: /dev/sda vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: MBR
  ID-1: / size: 712.57 GiB used: 20.52 GiB (2.9%) fs: ext4 dev: /dev/sda7
  Alert: No swap data was found.
  System Temperatures: cpu: 32.0 C mobo: 35.0 C
  Fan Speeds (RPM): cpu: 1595 psu: 0 case-1: 1339
  Power: 12v: 11.85 5v: N/A 3.3v: 3.28 vbat: N/A
  Processes: 136 Uptime: 23m wakeups: 0 Memory: 7.76 GiB used: 400 MiB (5.0%) Init: systemd
  v: 251 default: graphical Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1032
  Shell: Bash (login) v: 5.1.16 running-in: tty 2 inxi: 3.3.22

What do you get for systemd-analyze blame

Can we see exactly what is on the screen when it hangs during the boot process?

You might try installing the LTS kernel and booting off that since your hardware is older.

8.768s dev-sda7.device
7.368s systemd-modules-load.service
4.443s systemd-tmpfiles-setup-dev.service
4.290s systemd-journal-flush.service
3.511s firewalld.service
3.329s lvm2-monitor.service
2.127s power-profiles-daemon.service
2.016s cups.service
1.839s systemd-udevd.service
1.690s avahi-daemon.service
1.666s systemd-logind.service
1.437s dbus.service
 867ms user@1000.service
 860ms systemd-random-seed.service
 809ms NetworkManager.service
 373ms systemd-tmpfiles-setup.service
 318ms polkit.service
 244ms systemd-timesyncd.service
 197ms systemd-journald.service
 149ms dev-hugepages.mount
 149ms dev-mqueue.mount
 148ms sys-kernel-debug.mount
 147ms sys-kernel-tracing.mount
 130ms systemd-sysctl.service
 121ms tmp.mount
 120ms kmod-static-nodes.service
 118ms modprobe@configfs.service
 118ms modprobe@drm.service
 117ms modprobe@fuse.service
 104ms systemd-udev-trigger.service
  63ms systemd-update-utmp.service
  34ms systemd-remount-fs.service
  32ms systemd-user-sessions.service
  23ms user-runtime-dir@1000.service
  21ms alsa-restore.service
   1ms sys-fs-fuse-connections.mount
   1ms sys-kernel-config.mount

I’m away at work but yes I’ll post an image. Once it hung with a graphical interface line and the latest was a network something. I have them written down at home. It just strikes me odd since I’ve had this issue only after updates. I’m sure it’s in large part due to its age too. I’ll update this post later today. Thanks.

Is mostly likely hanging because there is no driver loaded. It isn’t even using noveau open source. The GTX 760 isn’t supported by current drivers and needs the 470.xx version legacy drivers.

I think you may be on the correct path. I do remember reading about that and looked at Nvidia drops 700 (Kepler) into legacy branch (470xx) but i seem to be unable to correctly get back to that branch. What would be the correct path? Buy a more modern system to mess with this OS or just hold back on updating and such? I’m a bit over my head trying to get the driver reverted so any basic step by step anywhere?

1 Like

we have a helper script for this:

yay -S nvidia-inst
nvidia-inst --legacyrepo 


1 Like

I’ve ran the commands and now after re-boot sticks on some network manager script. Honestly I am going to have to give up on this. It ran fine the last install that was fresh until the last update. Not to complain but Mint runs as I have stated previously so I suppose I do not know enough as to the why aspect but it runs using the same hardware. I’m not sure what they do different but in this case it runs and this will not.

I’ve gone over and over with commands, tweaks, following links, and etc but all I end up with is being more frustrated. I love this OS when it works but I am spending more time attempting to get a viable install than actually using it. Understand I am not blaming Endeavouros in any way and the support in this community is second to none but I am going to have to step away for awhile now. If I can gather enough parts I’ll test out a different system with a non-nvidia card to see how that goes.

Thank you all for the assistance and I really do appreciate the effort. I’ll give it some time and try additional systems. Cannot make it work on the existing Linux machine sadly.


i am not sure if these legacy drivers are also affected by ibt issue?

where you have to add ibt=off to kernel boot parameters?

Hi Drifter dont give up. There are a lot of knowledgeable people here …I am having the same problem…

I have spent the last few days reading and fooling with my Endeavor system. I have the LTS kernel 5.15 for fallback, which is good, I also have the 6.xx kernel, but the problem is that after the 470xx Nvidia package update to what’s needed for the 6xx kernel, I get the message during DKMS that the NVidia driver for the 6x kernel doesn’t support my NVidia GT 730 video card so. Sure enough on verbose boot on the 6xx kernel it reaches starting the graphic environment and then stops. Still of course ctl alt F2 works and things run fine there but… Have tried a number of things to get the 470 driver to work with the 6x kernel to no avail…so my question is …can it be done. What avenues do I have going forward…one I suppose is to install nouveau (did I really spell that incorrectly?). Its an older system with an Asus Tuf gaming board, I7-4790 CPU. Its a wonderful system that does most of what I need doing… of course the temptation is to be an early adopter on an Intel Arc A770 :rofl: I am SO tempted!!! Aside from that I dont see much of a way forward other than consigning a perfectly good hardware platform to the dustbin. Its certainly a good enough platform to do photo editing and software defined radio…and the BIOS even recognizes an M2 SSD on the PCIe buss–but I would like to know if there is a way to use the current graphics card with the newer kernel…

Any help or suggestions, including a lobotomy (me or the machine…ahhhh both!) would be deeply appreciated.

You can try adding ibt=off to the default grub command line in /etc/default/grub and then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg Then reboot & see if it makes any difference.

There’s no shame in that at all. Dump Nvidia and avoid it at all costs. That will make your life significantly easier.

I ran Linux Mint for years, it’s a fantastic distro. I would also recommend checking out Pop_OS.

We’ll be here if you care to dive in again! Cheers!

nouveau open source driver should work to on kepler cards… and this should not have an issue with latest kernel.

nvidia-inst -n is there to reset to nouveau driver

1 Like

Thanks very much for this. Will post back results.

Result was the same “reached target graphical interface” and stopped.

nvidia may not boot on Linux 5.18 (or later) on systems with Intel CPUs due to FS#74886/FS#74891. Until this is fixed, a workaround is disabling the Indirect Branch Tracking CPU security feature by setting the ibt=off kernel parameter from the bootloader. This security feature is responsible for mitigating a class of exploit techniques, but is deemed safe as a temporary stopgap solution.

1 Like