Unusual Installation Problem With Keyboard

b4s4a2 nsta33at56n /r6b3e0 W5th eyb6ard

The above is what I get when I type the title of this post without using the Fn key (where necessary).

I have a computer on which I would like to re-install EndeavourOS. I previously had it installed, but something went wrong and I wanted to reinstall the system.

But the keyboard no longer works correctly, no matter what I do. In order to get correct letters, SOMETIMES (for CERTAIN letters or symbols) I have to hold down the Fn key when typing the letter,
other times not.

Here is how one of the previous sentences types WITHOUT holding down the Fn key:

Here 5s h6w 6ne 6f the /rev564s sentences ty/es WTT h63d5ng d6wn the Fn 2ey.

I installed Xubuntu and the keyb6ard w6r2ed /erfect3y. WHAT 5s going wr6ng w5th the ENDEAVOUROS insta33at56n?



The first thing to do is try another keyboard unless you have already done that?

Some special key like NumLock or similar has been accidentally pressed? If so, press it once again.

Could a function key be on when pressed to give something different?

I guess depends on the keyboard.

But actually I had a similar issue than Lawrence when installing EndeavourOS to an old laptop a few months ago. I must have pressed a wrong modifier key, and the rightmost part of the keyboard gave strange values. Then I found the modifier key… and all was great again!

That’s kind of what i meant … an F key or such that when pressed changes something.

Keep hold on fn + Numlock keys it will have to resolve it…knowing Numlock differs depending keyboard could be F7 F8 or whatever !

Hello All.

I’m now on my main computer on which everything works correctly. When I posted the question, I was using the ZaReason Ultralap 6440 computer on which I can’t get EndeavourOS to work properly.

I was using the live disc and, to log in to this forum, I opened a Terminal and just typed my forum login password using the Fn key where appropriate to get the correct letters/numbers/symbols. (I couldn’t see the letters/numbers/symbols to just type the login; I didn’t know which required the Fn key and which did not.) Then I copied that password into the login box and I was logged in.

I started this post and, believe me, it took “forever” just to type my question.

This is the strangest thing I’ve ever seen.

Here are the specifications of this laptop computer:

Model: ZaReason UltraLap 6440-i5
SKU: SKU165181
Weight: 3.60 lbs
Linux Version: No operating system
Processor: i5-8250U (included)
Dual Memory: 32 GB DDR4-2133
Video Card: Intel UHD 620 (included)
M.2 SSD: 1TB M.2 SSD
WiFi: Intel® Wireless AC Dual-Band (2.4/5ghz)
Bluetooth: (included)
Battery: 6-cell (included)
AC Adapters: 1 (included)
Card Reader: SD/MMC (included)
Webcam: HD webcam (included)
Super Key
Tux logo
Warranty: 3 years

Please let me explain my history with this computer.

We bought it in April 2019 and originally I installed Antergos. (I always buy my computers with no OS installed, much preferring to do it myself.) When that system ended, I replaced Antergos with EOS. (As I mention below, we have two of these and I did the same thing with both.)

A couple of months ago, it went “screwy” for some reason. We do not use this computer very often at home; it is used when we travel. This one is my wife’s. Actually we have two of these Ultralaps and the one I normally use has never given me any major problem (there is one minor problem which, if I can’t figure out how to fix it, I’ll start another subject here).

Anyway, back to this, my wife’s, Ultralap, I tried to reinstall EOS from the October release and got nowhere - this is when the keyboard problem first turned up.

I waited until the December 3 release was introduced and tried to install from that. Same result (“screwy” keyboard).

So yesterday I tried again with the December 22 Offline installer. By this time I had gone into the UEFI and set everything to the Defaults (making certain that Secure Boot was disabled).

I even used the partition manager to wipe everything off the computer but still got the result which brought me here.

I have to say that, between trying the December 3 ISO and the December 22 one, I installed Xubuntu to see if the same thing happened with the keyboard.

It did NOT. The keyboard worked PERFECTLY.

So that’s when I thought that perhaps the problem had fixed itself and I decided to reinstall EOS.

But — well, here we are.

It CAN’T be a NumLK key. It CAN’T be anything in the UEFI. At least as far as I can tell.

So here is my “big” question:

WHY does the keyboard work perfectly with Xubuntu but not with EOS?

I told you that this was the strangest thing I have ever seen.

By the way, my wife had “done something” to HER main computer (a ZaReason Custom [Verix equivalent]) - she ALWAYS manages to “do something” to her computers - so, rather than trying to figure out what she had done (“I didn’t do ANYTHING”) I reinstalled EOS on that computer yesterday and everything went perfectly. (My main computer is exactly the same model and I have not had any EOS problems at all since I installed the system back in July.)

I may have three choices.

If someone here can tell me what’s going on with that Ultralap (and please remember that MY Ultralap - same model - is still working almost perfectly), then I can fix it.

Or I can try installing Manjaro (but who knows if that will work?). I am not particularly keen on that system but, for my wife, it would be an acceptable alternative as it works almost the same as EOS.

Or, finally, I can send the whole computer back to ZaReason (I bought a 3-year warranty) to see if they can figure it out or do something to fix this keyboard problem.

I thank everyone who has relied to me so far (and I am well aware that none of you had complete information). I do appreciate VERY MUCH everyone who tries to help.

I hope that there is some “simple” answer to this problem.

Thanks again.


what is your locale? as LiveISO is set to En-US per default what you can change from panel right (changing keyboard layout)


looks similar

How did you test that key and other keys that were suggested above? As you can see from the above discussion, I had a similar issue (with exactly the same character changes that you have) but with a totally different laptop. It was caused by only one keyboard modifier key. Your BIOS settings about the keyboard may give more clues.
And journal info might be useful too: https://endeavouros.com/docs/forum/how-to-include-systemlogs-in-your-post/

That is not easy to find out. But Ubuntu and Arch use very different generation of software, especially the kernels. That might have something to do with it.

@lhb1142 Are you able to try this:

sudo loadkeys us

I guess it should be:
sudo loadkeys us

1 Like

You are right! My mistake. :frowning_face:

We all make mistakes, and that was one on the smallest I’ve ever seen! :innocent:

@lhb1142 Laptop keyboards that don’t have dedicated keypads typically have an “embedded keypad” on the right hand that is enabled with an Fn+key combination. If you look closely at what is being typed, you can see that numbers are replacing letters on the right hand. If you inspect your keyboard, you should notice small numbers in the upper right corner of the keys, in the same color as the label of your Fn key. The trick is going to be finding the key that toggles the embedded keypad. Good luck!

Why does it “work correctly” with (K/X/L)Ubuntu? As pointed out, it could be a kernel option to reset all modifiers. Dunno. :man_shrugging:

EDITed to clarify the suspected location of the numbers on the keys after seeing a picture of the device online. I couldn’t see the Fn keys well enough to guess which one might toggle the embedded keypad.

1 Like

Trust me … i can easily make BIG mistakes! :rofl:

1 Like

Is there a setting in xfce (e.g., a control panel setting) that enables numlock on login/ startup? I use plasma, which does have such a function available. Also, if memory serves, some bios have a setting for enabling numlock on boot.

Good luck with solving this!

If numlock was set in the Bios or Uefi on boot it would be the same on any installation though. That wouldn’t change and also you would be able to see that on the keyboard. I’m also having difficulty understanding if it was function key why it’s okay on one OS and not on another. That doesn’t make sense to me. :thinking:

Edit: Some keyboards do have a firmeware to save settings although I’m mostly thinking of RGB backlighting type.

sudo loadkeys us

This may work but then again after a restart it may revert back if if it’s some other issue?

Yes there is (https://docs.xfce.org/xfce/xfce4-settings/4.14/keyboard) but I guess we are now talking about a different thing.

We are talking about a key combination that toggles part of your keyboard with the numeric pad. That key combination needs to be found. And that info is available only at your computer… :wink: