[SOLVED] Here is Another "Beaut" - This Time Involving Pace

I have two ZaReason UltraLap 6440 computers (as explained in another thread here: https://forum.endeavouros.com/t/unusual-installation-problem-with-keyboard/3123) and the one in question on this thread (the other one) is having a problem with the Pace program.

I had Pace installed, along with many other programs, and for months everything worked fine.

Theun, last week, I updated this computer (after several days of not using it) and, among other updates, there were several from the AUR, including Pace.

Pace would not update. I got an error message. When I excluded Pace from the updating (which I always do in the Terminal with yay), everything else updated perfectly.

I rebooted and tried to update Pace again. No go.

So then I did what in retrospect might have been wrong. I went into Pamac-AUR-Git and REMOVED Pace.

I rebooted and tried to do a fresh install of Pace (using yay -S pace).

Well, since I’m here, you can guess that THAT was no go too.

I just tried again and here is the message I receive:

[ultralap-6440-i5-1@ultralap-6440-i5-1 ~]$ yay -S pace
:: There are 3 providers available for pace:
:: Repository AUR
** 1) pace 2) pace-cli-git 3) pace-git **

**Enter a number (default=1): **
:: Checking for conflicts…
:: Checking for inner conflicts…
[Aur: 1] pace-1.2.2-1

** 1 pace (Build Files Exist)**
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> A
:: Deleting (1/1): /home/ultralap-6440-i5-1/.cache/yay/pace
:: Downloaded PKGBUILD (1/1): pace
** 1 pace (Build Files Exist)**
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> **
:: Parsing SRCINFO (1/1): pace
==> Making package: pace 1.2.2-1 (Sun 12 Jan 2020 03:48:19 PM EST)
==> Retrieving sources…
** -> Downloading pace-1.2.2.tar.gz…
** % Total % Received % Xferd Average Speed Time Time Time Current**
** Dload Upload Total Spent Left Speed**
100 44524 100 44524 0 0 119k 0 --:–:-- --:–:-- --:–:-- 119k
==> Validating source files with sha256sums…
** pace-1.2.2.tar.gz … Passed**
==> Making package: pace 1.2.2-1 (Sun 12 Jan 2020 03:48:20 PM EST)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
** -> Found pace-1.2.2.tar.gz**
==> Validating source files with sha256sums…
** pace-1.2.2.tar.gz … Passed**
==> Removing existing $srcdir/ directory…
==> Extracting sources…
** -> Extracting pace-1.2.2.tar.gz with bsdtar**
==> Sources are ready.
==> Making package: pace 1.2.2-1 (Sun 12 Jan 2020 03:48:22 PM EST)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> WARNING: Using existing $srcdir/ tree
==> Starting build()…
+ exec meson setup --prefix /usr --libexecdir lib --sbindir bin --buildtype plain --auto-features enabled --wrap-mode nodownload -D b_lto=true -D b_pie=true . build
The Meson build system
Version: 0.53.0
Source dir: /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2
Build dir: /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2/build
Build type: native build
Project name: pace
Project version: 1.2.1
Appending CFLAGS from environment: '-march=x86-64 -mtune=generic -O2 -pipe -fno-plt’
Appending LDFLAGS from environment: [’-Wl,-O1,–sort-common,–as-needed,-z,relro,-z,now’]
Appending CPPFLAGS from environment: '-D_FORTIFY_SOURCE=2’
Appending CFLAGS from environment: '-march=x86-64 -mtune=generic -O2 -pipe -fno-plt’
Appending LDFLAGS from environment: [’-Wl,-O1,–sort-common,–as-needed,-z,relro,-z,now’]
Appending CPPFLAGS from environment: '-D_FORTIFY_SOURCE=2’
C compiler for the host machine: cc (gcc 9.2.0 “cc (GCC) 9.2.0”)
C linker for the host machine: cc GNU ld.bfd 2.33.1
Vala compiler for the host machine: valac (valac 0.46.5)
Host machine cpu family: x86_64
Host machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (1.6.3)
Run-time dependency gio-2.0 found: YES 2.62.4
Run-time dependency gtk±3.0 found: YES 3.24.13
Run-time dependency gtksourceview-4 found: YES 4.4.0
Program desktop-file-validate found: YES (/usr/bin/desktop-file-validate)
Program appstream-util found: YES (/usr/bin/appstream-util)
Configuring config.h using configuration
Found pkg-config: /usr/bin/pkg-config (1.6.3)
Build targets in project: 33

Found ninja-1.9.0 at /usr/bin/ninja
ninja: Entering directory build'** **[128/128] Linking target test/pace_applicationwindow.** **==> Starting check()...** **ninja: Entering directory build’
[0/1] Running all tests.
** 1/23 Validate desktop file OK 0.02 s **
** 2/23 Validate appstream file OK 0.70 s **
** 3/23 Pace.ConfigLine OK 0.01 s **
** 4/23 Pace.ConfigComment OK 0.02 s **
** 5/23 Pace.ConfigKey OK 0.02 s **
** 6/23 Pace.ConfigSection OK 0.03 s **
** 7/23 Pace.ConfigRepository OK 0.02 s **
** 8/23 Pace.ConfigFile OK 0.02 s **
** 9/23 Pace.Cli OK 0.05 s **
**10/23 Pace.RowLabel OK 0.13 s **
**11/23 Pace.RowComboBoxEntry OK 0.18 s **
**12/23 Pace.RowLabelEntry OK 0.18 s **
**13/23 Pace.RowLabelLabel OK 0.18 s **
**14/23 Pace.ListBox OK 0.22 s **
**15/23 Pace.ListBoxRowMirror OK 0.18 s **
**16/23 Pace.ListBoxRowOption OK 0.17 s **
**17/23 Pace.ListBoxRowRepository OK 0.27 s **
**18/23 Pace.RepositoryForm OK 0.22 s **
**19/23 Pace.ListBoxMirrors OK 0.22 s **
**20/23 Pace.ListBoxOptions OK 0.22 s **
**21/23 Pace.ListBoxRepositories OK 0.22 s **
**22/23 Pace.SelectorMirrorlistFiles OK 0.22 s **
**23/23 Pace.ApplicationWindow OK 0.17 s **

Ok: 23
Expected Fail: 0
Fail: 0
Unexpected Pass: 0
Skipped: 0
Timeout: 0

Full log written to /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2/build/meson-logs/testlog.txt
==> Entering fakeroot environment…
==> Starting package()…
ninja: Entering directory `build’
[0/1] Installing files.
Installing data/ar.com.softwareperonista.Pace.desktop to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/applications
Installing data/ar.com.softwareperonista.Pace.appdata.xml to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/appdata
Installing actions/ar.com.softwareperonista.Pace.policy to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/polkit-1/actions
Installing src/pace to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/bin
Installing src/pace-file-writer to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/bin
Installing /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2/data/pace.1 to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/man/man1
Installing /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2/data/pace-completion.bash to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/bash-completion/completions
Installing /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2/icon/ar.com.softwareperonista.Pace.svg to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/icons/hicolor/scalable/apps
Running custom install script '/usr/bin/meson --internal gettext install --subdir=po --localedir=share/locale --pkgname=pace’
Installing /home/ultralap-6440-i5-1/.cache/yay/pace/src/pace-1.2.2/build/po/es.gmo to /home/ultralap-6440-i5-1/.cache/yay/pace/pkg/pace/usr/share/locale/es/LC_MESSAGES/pace.mo
==> Tidying install…
** -> Removing libtool files…**
** -> Purging unwanted files…**
** -> Removing static library files…**
** -> Stripping unneeded symbols from binaries and libraries…**
** -> Compressing man and info pages…**
==> Checking for packaging issues…
==> Creating package “pace”…
** -> Generating .PKGINFO file…**
** -> Generating .BUILDINFO file…**
** -> Generating .MTREE file…**
** -> Compressing package…**
==> Leaving fakeroot environment.
==> Finished making: pace 1.2.2-1 (Sun 12 Jan 2020 03:48:36 PM EST)
==> Cleaning up…
**[sudo] password for ultralap-6440-i5-1: **
loading packages…
resolving dependencies…
looking for conflicting packages…

Packages (1) pace-1.2.2-1

Total Installed Size: 0.21 MiB

**:: Proceed with installation? [Y/n] **
(1/1) checking keys in keyring [----------------------------------------------------] 100%
(1/1) checking package integrity [----------------------------------------------------] 100%
(1/1) loading package files [----------------------------------------------------] 100%
(1/1) checking for file conflicts [----------------------------------------------------] 100%
error: failed to commit transaction (conflicting files)
pace: /usr/bin/pace exists in filesystem
pace: /usr/bin/pace-file-writer exists in filesystem
pace: /usr/share/appdata/ar.com.softwareperonista.Pace.appdata.xml exists in filesystem
pace: /usr/share/applications/ar.com.softwareperonista.Pace.desktop exists in filesystem
pace: /usr/share/bash-completion/completions/pace exists in filesystem
pace: /usr/share/icons/hicolor/scalable/apps/ar.com.softwareperonista.Pace.svg exists in filesystem
pace: /usr/share/man/man1/pace.1.gz exists in filesystem
pace: /usr/share/polkit-1/actions/ar.com.softwareperonista.Pace.policy exists in filesystem
Errors occurred, no packages were upgraded.
[ultralap-6440-i5-1@ultralap-6440-i5-1 ~]$

I also tried installing pace-git but that didn’t work either.

Based on the error messages I show above, can anyone tell me exactly what to do so that I can install Pace? I’m sure the solution must be something relatively simple but I don’t know what it is and I don’t want to take a chance on messing up this computer which is working perfectly otherwise.

Thanks for any help.


1 Like

It must be errors in the downloads or existing package db. I would try sudo pacman -Sc and answer yes for first and no for second question. Then run sudo pacman -Syy and sudo pacman -Syu Then try to install it again.

Edit: I would also update the mirrors first… I have had to do this a number of times myself at times.

There are file conflicts, and pacman does not allow you to install because of them.
So simply delete those conflicting files and try again.

Thank you Manuel. Your solution worked perfectly. (And thanks too to Ricklinux.)

All I can say is “Yay” (pun intended). I have Pace installed on this computer once again.

Now I have three (3) more questions:

  1. HOW did this problem happen?

  2. WHY did it happen?

  3. WILL (or CAN) it happen again?

It really was a simple fix (though I posted this question here because I didn’t want to take a chance on damaging my system).

I do not want to be a “pest” but I thank you for any answers to my three (3) questions above.


1 Like

Great that your system is OK again!

This kind of an issue unfortunately sometimes happens with AUR software. As you know, AUR stuff is not officially supported by Arch nor EndeavourOS devs. It is stuff maintained by other users, and thus AUR software quality varies a lot depending on the maintainer.

To get the right picture, there are lots of great maintainers in AUR, but some are not, and they have their reasons for that. Like any open source stuff, people usually don’t get paid for doing this, and for many devs that is a compelling reason.

I guess that answers all of the 3 questions. And to further clarify, it is very much possible to happen again with this or some other software from the AUR.

Dear Manuel,

Thanks for replying to me. I understand your answer perfectly.

But then this brings up another question:

I myself have four (4) computers which I use every day (my wife has two but they don’t matter in this question).

I updated ALL FOUR on the same day one right after another but the problem occurred only on one of them. The other three all updated perfectly. (I do not remember in which order I updated the four computers.)

That’s REALLY puzzling!

But at least I’ll know what to do if this ever occurs again.

Thanks again.


1 Like

Did you happen to have pace installed on that particular machine already before? That might explain it.

Anyway, as said before, pacman doesn’t allow a new package install if files with the same name already exist.
And pacman doesn’t allow partial updates either. This means that if one package update fails, then no package will be updated.

The reason for these seemingly restrictive pacman rules is to keep a system in a consistent state as much as possible. A bad update may, for example, make the machine unable to boot.

Yes, as I mentioned in the initial post, Pace was installed on all of my computers. It was just on this one that it would not update. This particular computer had not been updated in several days (the others all had been) but I still don’t understand just why Pace gave such a problem on this computer and not on any of the others.

It’s really strange - but at least it’s fixed now.

Thanks again.


1 Like