Unable to update after updating mirrors

Hi friends.

I did yay to see what updates were available, and saw that there were about 120 new packages, I cancelled with ctrl+c.

I thought it would be a good idea to update the mirrors before doing yay, as it would install faster or something, by logic.

Then I updated the Arch and EOS mirrors from the Welcome application.

Then I went back to yay, but now I get this and I can’t upgrade, nor do I get the available packages:

error: GPGME error: No data
:: Synchronizing package databases...
 endeavouros                              7,5 KiB  11,7 KiB/s 00:01 [-------------------------------------] 100%
 core is up to date
 extra is up to date
 multilib is up to date
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)
 -> error refreshing databases - exit status 1

It was my fault for not updating the packages before the mirrors.

Any idea what mirrors I broke, and how to fix them?

Thanks in advance.


I forgot to mention that this is the configuration I chose for the Arch mirrors:

1 Like


sudo rm -r /var/lib/pacman/sync/

sudo pacman -Syu

For more info: https://wiki.archlinux.org/title/Pacman#error:_GPGME_error:_No_data

1 Like

Thanks friend, but unfortunately it didn’t work.

sudo rm -r /var/lib/pacman/sync/
sudo pacman -Syu
:: Synchronizing package databases...
 endeavouros                              7,5 KiB  12,7 KiB/s 00:01 [-------------------------------------] 100%
 core                                   121,1 KiB   413 KiB/s 00:00 [-------------------------------------] 100%
 extra                                    7,9 MiB  15,3 MiB/s 00:01 [-------------------------------------] 100%
 multilib                               138,3 KiB   576 KiB/s 00:00 [-------------------------------------] 100%
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

Try the rest of the suggestions in the link I shared above.

1 Like

Thanks and sorry friend, I didn’t see it.

My English is bad but, I think I understand that all files must be “gzip”, correct?

So there are 2 files there that are not gzip, does that mean they are broken? How can I fix them?

I’m sorry I’m very noob.

$ file /var/lib/pacman/sync/*
/var/lib/pacman/sync/core.db:            gzip compressed data, from Unix, original size modulo 2^32 593920
/var/lib/pacman/sync/endeavouros.db:     HTML document, ASCII text, with very long lines (4070)
/var/lib/pacman/sync/endeavouros.db.sig: HTML document, ASCII text, with very long lines (4070)
/var/lib/pacman/sync/extra.db:           gzip compressed data, from Unix, original size modulo 2^32 32931840
/var/lib/pacman/sync/multilib.db:        gzip compressed data, from Unix, original size modulo 2^32 655360

I am not sure what to do next, as it does not say what to do with those files that are not “gzip”.

If removing sync files doesn't help, check that the sync files are gzip compressed data using file /var/lib/pacman/sync/* before attempting to update. A router or proxy might corrupt the downloads. 
1 Like



Good question! :thinking:

Try and see if you can install the package rate-mirrors:

sudo pacman -U https://mirror.moson.org/endeavouros/repo/endeavouros/x86_64/rate-mirrors-0.17.1-1-x86_64.pkg.tar.zst

Report back!

1 Like

Thanks friend, but it didn’t work either. :frowning:

sudo pacman -U https://mirror.moson.org/endeavouros/repo/endeavouros/x86_64/rate-mirrors-0.17.1-1-x86_64.pkg.tar.zst
error: GPGME error: No data
error: database 'endeavouros' is not valid (invalid or corrupted database (PGP signature))
loading packages...
error: failed to prepare transaction (invalid or corrupted database)
1 Like

Could you post the output of:

pacman-conf -r endeavouros


1 Like
$ pacman-conf -r endeavouros
Usage = All
SigLevel = PackageRequired
SigLevel = PackageTrustedOnly
SigLevel = DatabaseOptional
SigLevel = DatabaseTrustedOnly
Server = https://mirror.nimatarlani.com/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.moson.org/endeavouros/repo/endeavouros/x86_64
Server = https://ftp.belnet.be/mirror/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.alpix.eu/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.accum.se/mirror/endeavouros/repo/endeavouros/x86_64
Server = https://de.freedif.org/EndeavourOS/repo/endeavouros/x86_64
Server = https://endeavouros.ip-connect.info/repo/endeavouros/x86_64
Server = https://md.mirrors.hacktegic.com/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.urbanwave.co.za/endeavouros/repo/endeavouros/x86_64
Server = https://fosszone.csd.auth.gr/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.gigenet.com/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.nxtgen.com/endeavouros-mirror/repo/endeavouros/x86_64
Server = https://mirror.archlinux.tw/EndeavourOS/repo/endeavouros/x86_64
Server = https://mirror.funami.tech/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.albony.xyz/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.jlu.edu.cn/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.freedif.org/EndeavourOS/repo/endeavouros/x86_64
Server = https://mirror.jingk.ai/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.sjtu.edu.cn/endeavouros/repo/endeavouros/x86_64

It is possible that this may be related to the “keys” (or something like that), which need to be kept up to date?

I updated the mirrors without first updating my EOS and the keys. I have read several users on our forum commenting something similar some time ago.

I think, I’m not sure, maybe that’s why those packages broke, for not having those keys updated?

1 Like

Remove the line above from your /etc/pacman.d/endeavouros-mirrorlist



You did it, it worked!!! :partying_face:

Thank you very much friend!!! :smiley:

I removed the 2 mirrors that had the same name “nimatarlani”, above and below.

I would never have guessed that I would have had to get to that file.

Thank you again!!! :'D

# EndeavourOS mirrorlist, ranked by eos-rankmirrors at 14/06/24 17:35:28.
Server = https://mirror.nimatarlani.com/endeavouros/repo/$repo/$arch
Server = https://mirror.moson.org/endeavouros/repo/$repo/$arch
Server = https://ftp.belnet.be/mirror/endeavouros/repo/$repo/$arch
Server = https://mirror.alpix.eu/endeavouros/repo/$repo/$arch
Server = https://mirror.accum.se/mirror/endeavouros/repo/$repo/$arch
Server = https://de.freedif.org/EndeavourOS/repo/$repo/$arch
Server = https://endeavouros.ip-connect.info/repo/$repo/$arch
Server = https://md.mirrors.hacktegic.com/endeavouros/repo/$repo/$arch
Server = https://mirrors.urbanwave.co.za/endeavouros/repo/$repo/$arch
Server = https://fosszone.csd.auth.gr/endeavouros/repo/$repo/$arch
Server = https://mirrors.gigenet.com/endeavouros/repo/$repo/$arch
Server = https://mirrors.nxtgen.com/endeavouros-mirror/repo/$repo/$arch
Server = https://mirror.archlinux.tw/EndeavourOS/repo/$repo/$arch
Server = https://mirror.funami.tech/endeavouros/repo/$repo/$arch
Server = https://mirror.albony.xyz/endeavouros/repo/$repo/$arch
Server = https://mirrors.jlu.edu.cn/endeavouros/repo/$repo/$arch
Server = https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo/$repo/$arch
Server = https://mirror.freedif.org/EndeavourOS/repo/$repo/$arch
Server = https://mirror.jingk.ai/endeavouros/repo/$repo/$arch
Server = https://mirror.sjtu.edu.cn/endeavouros/repo/$repo/$arch

# Mirror ranking info at (UTC) 14/06/24 15:35:28:
# The following fields are shown for each mirror:
#   mirror:          The mirror address
#   update-level:    Ordinal number of the latest update (larger is newer)
#   fetch-time:      Measures the speed of the mirror (smaller is faster)
# mirror                                                             update-level  fetch-time  
# ~~~~~~                                                             ~~~~~~~~~~~~  ~~~~~~~~~~  
# https://mirror.nimatarlani.com/endeavouros/repo/$repo/$arch        <!DOCTYPE     html>       0.584417
# https://mirror.moson.org/endeavouros/repo/$repo/$arch              2201          0.133645    
# https://ftp.belnet.be/mirror/endeavouros/repo/$repo/$arch          2201          0.195309    
# https://mirror.alpix.eu/endeavouros/repo/$repo/$arch               2201          0.204003    
# https://mirror.accum.se/mirror/endeavouros/repo/$repo/$arch        2201          0.207488    
# https://de.freedif.org/EndeavourOS/repo/$repo/$arch                2201          0.247994    
# https://endeavouros.ip-connect.info/repo/$repo/$arch               2201          0.295327    
# https://md.mirrors.hacktegic.com/endeavouros/repo/$repo/$arch      2201          0.297298    
# https://mirrors.urbanwave.co.za/endeavouros/repo/$repo/$arch       2201          0.459475    
# https://fosszone.csd.auth.gr/endeavouros/repo/$repo/$arch          2201          0.504128    
# https://mirrors.gigenet.com/endeavouros/repo/$repo/$arch           2201          0.556784    
# https://mirrors.nxtgen.com/endeavouros-mirror/repo/$repo/$arch     2201          0.603846    
# https://mirror.archlinux.tw/EndeavourOS/repo/$repo/$arch           2201          1.024453    
# https://mirror.funami.tech/endeavouros/repo/$repo/$arch            2201          1.080863    
# https://mirror.albony.xyz/endeavouros/repo/$repo/$arch             2201          1.292895    
# https://mirrors.jlu.edu.cn/endeavouros/repo/$repo/$arch            2201          1.452941    
# https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo/$repo/$arch  2201          1.473931    
# https://mirror.freedif.org/EndeavourOS/repo/$repo/$arch            2201          1.580472    
# https://mirror.jingk.ai/endeavouros/repo/$repo/$arch               2201          2.217322    
# https://mirror.sjtu.edu.cn/endeavouros/repo/$repo/$arch            2201          8.486478    
1 Like

You are welcome! Glad you got it resolved!

:enos: :wave:t5:


The mirror is removed from the mirrorlist now.


If the EOS mirrorlist is not good, then user needs to remove file
sudo rm /etc/pacman.d/endeavouros-mirrorlist.pacnew
and then run


Thanks friend, I didn’t know this, so I can use it in the future.

By the way, does running eos-rankmirrors in the terminal have the same effect as pressing Update Mirrors (EndeavourOS) from the Welcome application?:


For Update Mirrors (Arch, reflector-simple), you have to select countries, so I guess you can’t do it from the terminal (I mean, I don’t know).

Yes it does.

The same terminal command is reflector-simple.

1 Like

If you’re unsure about maintenance and updating mirrors, we have a very very helpful giude that can give you a start on how to go about doing these things. You should check it out.

1 Like

I got this issue as well and followed your advice

Edit: okey Never Mind i got it working(i can be a stubborn bastard sometimes).
i did go in to the folder as ROOT(with: su -c dolphin ) and renamed “endeavouros-mirrorlist.bakup to endeavouros-mirrorlist” then sudo pacman -Syu update and it resoolved it now i can update the mirrors and update my system again! i just live this info here for the future ^^ .

(old) but sadly i still get:


==> eos-update --aur
eos-update: package updater with additional features
Updating native and AUR apps…
[sudo] password for scorp10n2000:
error: GPGME error: No data
:: Synchronizing package databases…
endeavouros 15.5 KiB 35.8 KiB/s 00:00 [---------------------------------------------------------------------------------------] 100%
core is up to date
extra is up to date
community is up to date
multilib is up to date
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

Press ENTER to close this window:

do i need to go in and find the file an manually remove the faulty mirror?
i did and it did not help i removed the entire file( endeavouros-mirrorlist) (because F it).
now how do i put back the bakup mirror list(endeavouros-mirrorlist.bakup) or put a new one in?

also tere was no `endeavouros-mirrorlist.packnew only endeavouros-mirrorlist and bakup one.

right now i only get:


==> eos-rankmirrors: error: error detected at function Main, line 674:
no local /etc/pacman.d/endeavouros-mirrorlist found, please install package ‘endeavouros-mirrorlist’.
Usage: eos-rankmirrors [options]

–help, -h
This help.

–ignore ‘’
Mirrors to be ignored from the result.
This is useful for e.g. ignoring non-functional mirrors.
The is a list of words separated by a pipe ‘|’ character.
Each word should be a unique part of a mirror address.
Note that the list should be enclosed in single quotes
if it includes more than one word.
eos-rankmirrors --ignore=‘funami|pizza’

How much information will be shown when a mirror fails.
Supported values: see file /etc/eos-rankmirrors.conf, setting

–no-save, -n
Don’t save the generated mirrorlist.

–prefer ‘’
List of preferred mirror addresses.
Adds given mirror addresses as the first in the EndeavourOS mirrorlist.
The is a list of mirror addresses separated by
a pipe ‘|’ character.
Note that the list must be enclosed in single quotes.
eos-rankmirrors --prefer=‘https://endeavour.remi.lu/repo/$repo/$arch

Add the original mirror list into /etc/pacman.d/endeavouros-mirrorlist.
Supported values: “yes” (default) or “no”.

Show the ranking data in /etc/pacman.d/endeavouros-mirrorlist.
Supported values: “yes” (default) or “no”.

Primary key for sorting the mirrors.
Supported key values:
age (latest first)
rate (fastest first)
Default: age.

–timeout, -t
Set the timeout value (in seconds) for checking a mirror.
Default: .

For testing purposes.
Uses information in local /etc/pacman.d/endeavouros-mirrorlist as the base for ranking.

Show more detailed output.

Advanced options:
Save only the mirrorlist without the ranking statistics.

Temporarily add a mirror URL for ranking (for testing purposes only).

Press ENTER to close this window:

and can’t run update mirrors.

Edit: okey Never Mind i got it working(i can be a stubborn bastard sometimes).
i did go in to the folder as ROOT(with: su -c dolphin ) and renamed “endeavouros-mirrorlist.bakup to endeavouros-mirrorlist” then sudo pacman -Syu update and it resoolved it now i can update the mirrors and update my system again! i just live this info here for the future ^^ .

1 Like

Thank you very much friend, I will try it!

Oh that’s great, I’m interested, can you share it please? Thank you!