Unable to install EndevourOS

endeavouros-2019.12.22-x86_64.iso I am using this particular ISO, I used Etcher to burn the ISO to my USB drive and I booted into EndevourOS. When I booted into this distro I was greeted with some options whether to install endevour, update the app etc.
image

I clicked on install EndevourOS, and the installer started prompted me if I want offline or online installer, I selected online installer.

image

On the welcome page, it shows what language to install, but beneath it, it showed me waiting for two modules please wait and I waited for like 5 minutes and nothing happened. I tried to restart the installer but the installer would not open up. I restarted my PC and again booted into live mode and I tried to update the app (which worked fine) it still did not work, same issue.

I am able to connect to the Internet just fine but I don’t know why the installer is not working. I have installed other distros such as Manjaro with the same installer and it works just fine.

Edit: On VirtualBox, this ISO works just fine. But on my main computer I can’t install it at all.

First, check your ISO file with the md5sum.
At the bottom of this page :

I got this output endeavouros-2019.12.22-x86_64.iso: OK

So what else could be wrong? Its quite strange on my virtualbox it is working fine but on my other main PC it does not work the installer.

Can you show an informative picture about the exact place where is seems to stop working?

Ok so on my main PC it will show waiting for 2 modules instead of 27 modules and it will not do anything other than to show the loading animation (I took this image of the VM setup but this is where the problem occurs on my main PC).

There could be many things causing trouble, e.g.

  • ISO burning issue, how did you burn the ISO to the USB stick?
  • Secure Boot, did you disable it?
  • internet connection, does command ping 8.8.8.8 give any reply?

If possible, a more informative picture is the one at the real hardware, since it may show a terminal output too. You should update the Welcome app from the button Update this app! first and then try to install, and then take the picture/screenshot about the issue and show it here.

If it works on VirtualBox and not on bare metal so it could come from Bios setup !
After ISO check then as @manuel said check your BIOS setup with the secure boot disable.

And follow the @manuel help to bring us the error message here that we could see exactly know, what it is !

Yes using the Etcher software I have used it many times with no problems.

It doesn’t exist in my BIOS (it’s an 11 year old PC).

I haven’t tried that but I did use firefox and I did use Google just fine.

That is exactly what I did but it does nothing.

I will do that very soon.

Sure give me a few minutes

Take the time you need…

1 Like

Right now I am in liveISO. Ok so I reinstalled Etcher (there might have been an update I am not too sure) and I did reburn the ISO to my USB drive. I booted into live mode and the same issue happened.

I rebooted my PC and this time I did a full system update in live iso (sudo pacman -Syyu) and I then opened the installer but nothing happened. Nothing opens up.

Also for the ping 8.8.8.8 I did do that and it does work fine all though it seems to do keep pining forever

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=55 time=13.2 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=55 time=12.8 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=55 time=20.2 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=55 time=14.5 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=55 time=11.6 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=55 time=16.2 ms
64 bytes from 8.8.8.8: icmp_seq=7 ttl=55 time=13.3 ms
64 bytes from 8.8.8.8: icmp_seq=8 ttl=55 time=11.3 ms
64 bytes from 8.8.8.8: icmp_seq=9 ttl=55 time=14.0 ms
64 bytes from 8.8.8.8: icmp_seq=10 ttl=55 time=17.5 ms
64 bytes from 8.8.8.8: icmp_seq=11 ttl=55 time=9.91 ms
64 bytes from 8.8.8.8: icmp_seq=12 ttl=55 time=11.9 ms
64 bytes from 8.8.8.8: icmp_seq=13 ttl=55 time=11.8 ms
64 bytes from 8.8.8.8: icmp_seq=14 ttl=55 time=14.9 ms
64 bytes from 8.8.8.8: icmp_seq=15 ttl=55 time=10.4 ms
64 bytes from 8.8.8.8: icmp_seq=16 ttl=55 time=10.4 ms
64 bytes from 8.8.8.8: icmp_seq=17 ttl=55 time=11.2 ms
64 bytes from 8.8.8.8: icmp_seq=18 ttl=55 time=13.1 ms
64 bytes from 8.8.8.8: icmp_seq=19 ttl=55 time=9.24 ms
64 bytes from 8.8.8.8: icmp_seq=20 ttl=55 time=12.8 ms
64 bytes from 8.8.8.8: icmp_seq=21 ttl=55 time=18.0 ms
64 bytes from 8.8.8.8: icmp_seq=22 ttl=55 time=33.7 ms
^C
--- 8.8.8.8 ping statistics ---
22 packets transmitted, 22 received, 0% packet loss, time 21034ms
rtt min/avg/max/mdev = 9.241/14.181/33.665/5.041 ms

This is the output.

Edit: When I start the Endevour welcome launcher I then select start the installer option, and when I pick both the offline and the online installer I get this on the terminal.

Well, I think we need to know if you use Legacy or UEFI mode ?

Need to see your partition also, did you use GParted to partition your disk ?
Could you give the result from :

sudo fdisk -l

Don’t forget to check our great Wiki :


You have also a fast and easy possibility to create your Live key with this command even if with Etcher it has to work fine but if your ISO is ok no need to redo it, just for info :

sudo dd bs=4M if=/path/to/endeavouros-x86_64.iso of=/dev/sdX status=progress && sync

Ok so I did another reboot, and this is what I see on the installer. even on my laptop this runs just fine. Both of my computers are connected to the exact same modem.

I am using legacy for sure.

Nope I just straight away started the installer.

I ran the command and it seems to be just hanging. Its not outputting anything.

Sure I will do that.

I will keep that in mind thanks.

I will check this out as well.

Edit: I had a look at the first article but I don’t think it has anything related to my current issue. as I can boot in just fine but I can’t run the installer properly.

Also with the 2nd article it does suggest to use Etcher for Windows. And that is exactly what I am using.

There seems to be something weird going on with the way how my other partitions are mounted. When I ls both the /mnt and the /media directories nothing was mounted. I did try to mount sda2 (that is where Windows 7 is installed) sudo mount /dev/sda2 /mnt and it just hanged and did nothing. But on file explorer the partitions are shown but when you click on it it does nothing.

If sudo fdisk -l shows nothing, then the problem is with disks.
Boot with the USB stick once again, start a terminal, and without trying to install, show the output of commands:

  df -h
  lsblk -fm
  sudo fdisk -l

Try to run as many of them as possible. If any of them fails, try the others anyway.

And now that you have this: /home/liveuser/endeavour-install.log
please show it here.

EDIT: seems that it contains nothing useful?

Yep so if it’s your disk we want see how you partition it exactly, what is your scheme ?
Something is wrong there…a Shootscreen from GParted that you have by default on the Live would give us a better comprehension !

Like it is still running the command but it is not even showing anything.

Filesystem      Size  Used Avail Use% Mounted on
dev             3.9G     0  3.9G   0% /dev
run             3.9G   51M  3.9G   2% /run
/dev/sdb1       1.7G  1.7G     0 100% /run/archiso/bootmnt
cowspace         10G  304M  9.8G   3% /run/archiso/cowspace
/dev/loop0      1.6G  1.6G     0 100% /run/archiso/sfs/airootfs
airootfs         10G  304M  9.8G   3% /
tmpfs           3.9G  100M  3.8G   3% /dev/shm
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
tmpfs           3.9G   28K  3.9G   1% /tmp
tmpfs           797M   16K  797M   1% /run/user/1000
NAME FSTYPE LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT   SIZE OWNER GROUP MODE
fd0                                                                                  4K root  disk  brw-rw----
loop0
     squash                                                  0   100% /run/archi   1.5G root  disk  brw-rw----
sda                                                                              465.8G root  disk  brw-rw----
├─sda1
│    ntfs   System Reserved
│                 F4A4D5B6A4D57B94                                                 100M root  disk  brw-rw----
├─sda2
│    ntfs         7AE2E80CE2E7CA89                                               249.9G root  disk  brw-rw----
├─sda3
│    ext4         fc67e9f5-eb0f-4f77-9452-2a0c8f10fccb                             100G root  disk  brw-rw----
└─sda4
     ext4         0003193e-e9c6-4db8-8293-702391495ec1                           115.8G root  disk  brw-rw----
sdb  iso966 ENDEAVOUROS
│                 2019-12-22-21-33-31-00                                           1.9G root  disk  brw-rw----
├─sdb1
│    iso966 ENDEAVOUROS
│                 2019-12-22-21-33-31-00                     0   100% /run/archi   1.6G root  disk  brw-rw----
└─sdb2
     vfat   ARCHISO_EFI
                  DB17-1E0E                                                         64M root  disk  brw-rw----
sr0                                                                               1024M root  optic brw-rw----

Unfortunately it just hanged.

Sorry what do you mean by this?

This file doesn’t exist, probably cause I didn’t run the installer after the reboot.

I am using MBR as I have a legacy BIOS. So I have two ntfs partitions for Windows, and there are 2 more ext4 partitions (I think 2 more or 1 parition I can’t remember) and that is for the previous GNU/Linux distro which still exists.

I ran gparted but it is taking forever and my hardddrive did spin a bit but that was all it is still doing the same thing.

Over here in file explorer

When I click on these partitions then nothing happens.

Nothing more than try to run all those terminal commands. If some fail, run the others anyway. And you did just that.

True. And the contents you showed previously shows nothing useful. Except the start and stop time are the same, but I guess you stopped it?

Can you explain what exactly you have on partitions sda3 and sda4?

And some more questions are:

  • how did you shutdown Windows? It may be that Windows has somehow locked the partitions…
  • is fastboot enabled in BIOS? Is Windows hibernated?

Yeah i did that mate.

Yeah eventually I did leave it on for a very long time.

I believe sda3 is the root partition for Kubuntu and sda4 is for the /home parition.

I am not too sure what fastboot enabled means. But my BIOS has restarted to its defaults as the CMOS battery is dead and I sometimes do have blackouts. So I don’t at all change any of the BIOS’s settings. And Windows is not hibernated.

What is strange is that I have used other distros that use this similar installer and they have worked just fine. I have no idea what EndeavourOS is not working :confused: