Issues running EndeavourOS

So after when I managed to install EndeavourOS on that same PC, there are several issues.

So when i selected the first option, it will keep cycling between these three things (not sure what they are).

So when I tried to use the 2nd boot option (honestly I have no idea what does fallback initramfs means) I was able to get into the loggin screen and I was able to loggin and as soon as I logged in I saw this page:

And everytime I clicked on Update System or if I closed the application and opened up the terminal it will freeze up the OS. Also the start button does not work. And when I tried to launch firefox it would attempt to open it up but nothing happens.

Surprisingly when I booted into the normal mode then finally I can boot into the login screen but then when I inserted my password it did not work I was stuck on the login screen and I could only move the cursor, none of the buttons worked including the shutdown button etc.

What is strange is that in the live mode everything was fine, but after installing the entire OS pretty much does not work, not too sure why?

Boot it up and use the first entry. Wait and let it load … if it loads to the desktop and the welcome screen comes up. The first thing to do is update the mirrors. Then after saving that updated mirror list. You want to click on Detect Package Issues. This will uninstall anything not required for your hardware that is automatically loaded such as Broadcom for wireless and it will also shutdown one service that i running that causes issues. Other than that it is already right up to date. Until something new shows up as it is rolling release.

I booted into the first entry and something similar happened but a bit different.

Should I boot into the fallback mode?

I will give that a try.

Boot into the first entry always. The fallback mode is for when there is some issue with the init i think. You can open the eos-welcome screen by either start menu, other or from the terminal by typing eos-welcome. Then run the mirror update and the detect issues. Once done that then boot normal and use always the first entry.

So surprisingly again I got to the login screen when I did a normal boot (not fallback boot) but when I typed my password nothing happens. THe cursor can move around but like I can’t click on anything. How would I be able to update the mirrors if I can’t do this in normal boot mode?

Did you not check the box to use the same password for root when you installed. It asks at the bottom when you select everything.

I did check that box.

Sorry I will be back soon, thanks for all your help :slight_smile:

So are you able to log into the desktop?

If it’s the same password as your user account then just open the terminal and go to root and see.
sudo su

Great that you got it installed!

And now that you have it, you probably want to install the LTS kernel and try using that. So boot to the system using either the first or second boot entry. Then login and start a terminal and give these commands:

  sudo pacman -Syu
  sudo pacman -S linux-lts linux-lts-headers
  sudo grub-mkconfig -o /boot/grub/grub.cfg

and at boot, select the LTS kernel.

Hopefully that works better (but no guarantees unfortunately). Sometimes newer kernels drop support for some old hardware.

I am only able to log into the desktop if I boot into the fallback mode, if I boot into the normal mode it will either not boot up at all or when I get into the login mode, when I enter my password it would freeze up.

With the normal mode I can’t even log in. With the fallback mode, I can’t even access the terminal without freezing up the system but I will try and update the mirrors as @ricklinux has suggested and see what happens.

There are some ways to get to the terminal-like environment without a GUI.
For example, if you boot with the fallback entry, when the login screen shows up, press a key combination


That should take you to a TTY, which is a terminal like environment.

There you can login and give the terminal commands.
Note that no GUI command can run in that environment.

1 Like

I will give that a try if I have problems next time.

Ok so when I boot into the fallback mode, then I updated my mirror list and I ran detect hardware issues but there was no issues at all. Then surprisingly I could launch terminal without any issues which was good. So I did a full system update and I added the LTS version to my PC.

I have issues though when I boot into the LTS version if I then launch terminal or stuff it shwos it is loading but nothing happens. So LTS with fallback seems to be teh only thing working. All though the only thing that causes it to still crash is when I try and add icons to the taskbar which is weird. But everything else works fine as I am able to install addtional programs without any issues.

Do you know why there are so many issues with EndeavourOS? Its kinda disappointing no offense. I really want to understand what were the issues going on. And so I want to understand a bit better what does fallback mode do and why does it only work with LTS?

@ricklinux So you mentioned that you have similar hardware to mine, are you using the main Linux kernal or the LTS?

There may actually be more than one issue. Basically I think it is a hardware compatibility issue caused by either new software or settings. You said Kubuntu was running fine with that hardware. Kubuntu has an older kernel, which may be one of the reasons.

Then a big thing may be the graphics driver, as Nvidia is no more supporting 340 series. So nouveau driver may be the best option for that hardware.

Then there may be some kernel parameters that should be set somehow differently than what you now have. Maybe the Kubuntu install could have shown those kernel parameters (in file /boot/grub/grub.cfg)?

Still another potential reason may be some hardware that should be blacklisted. Often the things to blacklist are graphics drivers, but could be something else too.

One simple thing to try is using the TTY which I mentioned before. You can use Ctrl-Alt-F2 after you login to the desktop. And get back to desktop, press Ctrl-Alt-F1 or Ctrl-Alt-F7 (typical key choices).
If that works without any problem (besides GUI programs can’t run there), then it leads to believe that the graphics drivers (and maybe the new kernel too) are the main issue.

Then once again, the logs are an extremely important way to discover potential issues.
Now that you can login, could you show some journal logs? See more at

1 Like

OK so with Kubuntu I believe I was using Linux 5.0 last time and it was ok. Whereas on EndeeavourOS I am using LTS 4.19 (I think so) and it has issues unless if I boot into LTS fallback.

Kubuntu was lagging even more than EndeavourOS.

Should I run Kubuntu in live mode and fetch that file?

Should I attempt to boot into normal mode LTS and then fetch the boot logs?

I meant the installed Kubuntu system, not the live ISO system. So that would require re-installing Kubuntu, and it is a long shot anyway. But that involves lots of additional work.

Yes. That might give some more clue about the issue(s). But if normal LTS mode fails, try fallback and fetch the journal logs.

1 Like

I have absolutely no issues on any of the kernels, or on any of the desktops. I have installed EndeavourOS which is Arch and every other distro of Arch going including doing it the long way and everything else in between.

As i said before i feel it’s a hardware issue. They are the hardest to pinpoint. There are not so many issues with EndeavourOS. There are issues with your hardware working properly. I don’t have the hardware in front of me which makes it more the reason why we need information. That information comes from diagnostic tools and logs. My suggestion is replace the your motherboard battery. It’s not even $5.00 cdn and you could update the Bios. That’s entirely up to you. I always do and always have even with my current hardware which is new. You need the battery replaced first before attempting to flash a new Bios to the chip. The last bios version for that board is F6 dated 2009/06/18. You can update it via Windows. Make sure you know how to do it and follow the instructions from the Gigabyte site.

At least replace the battery.

Getting back to the hardware. You could be having this issue due to the graphics card and Nouveau. I’m just not sure at this point without more information. Please follow what @manuel advises you as he has more knowledge on commands and diagnostics tools and code.

I think the issue could be your video card isn’t playing nice with Nouveau but it’s hard to determine without going through more processes and diagnostics to determine. For myself it’s easy as i just pop in another card to test. :grin:


Hey man so I did what you have suggested and I have saved the outputs in a text file. The problem is that I tried to post it within the comments section, but it was too large. Can I please post a link to you via Megasync which links to the text file?

Maybe? I remember when I got this PC Windows XP and Vista would breakdown very easily and crash and not work properly etc (I didn’t at the time use an Nvidia card though). Only when Windows 7 came out (it was released a year after I bought this PC) when it was installed, it ran just fine all though once in a few years it breaks down and requires reformatting.

What is strange though is that why is it that Windows 7 is more stable than EndeavourOS?

I have the logs stored on a text file, but I can’t seem to post it over here, can I upload it through a cloud provider?

I will actually do that as soon as I get the chance to buy it. Is it a coin battery that is fitted in?

Yes it is laggy but at least other distros were a lot more stable, it wasn’t be as buggy as EndeavourOS which is strange.

Oh lol for me I don’t have a spare card to try out.