Tip: Turn off Firefox 89-90 "Proton" Design

If Firefox 89’s new design isn’t for you - there is a way to turn it off! Navigate to:

about:config

Search for proton and set this setting to false:

browser.proton.enabled

That’s it! Back to the old look! Restart the browser to take full effect.

Before: Firefox 89 (Default)

After: Firefox 89 with Proton Off

19 Likes

Oh, wow. I’ve been suffering with that for the past three Nightly versions and yet the fix was a single toggle. My eyes thank you. :hugs:

5 Likes

Thanks, I hate the big buttons. :green_heart:

1 Like

Well, I used proton for nearly two months or so and I’m used to it now. Like for Gnome 40. I kicked dash-to-dock and I prefer Gnome without it now.

I’m not a young geek… I’m 47 since february, so…

4 Likes

I definitely prefer it to the old design. I run Beta on Windows, so I have had it for a month already there.

1 Like

the only thing that I don’t like about the proton design is the floating tabs approach. The added info you get for example on Youtube with proton is great.
Unfortunately, you can’t change the tab bar layout only …

1 Like

I’m also keen on the new design. Of course I was using the compact mode before the update, and after the update the compact mode remained active. I understand the compact mode is no longer accessible unless you tinker inside the about:config area.

With the compact mode active, very little has changed in buttons size and spacing, but the overall crispness of the icons and the new dialog aesthetics comes like a breeze after the interface has caught a bit of dust after so many years.

2 Likes

It is also worth pointing out that the tabs aren’t thicker than Gnome’s top bars. And the new tabs harmonies more with the Gnome over all design language.

(I use Xfce, but it is worth pointing out that that’s obviously something they are going for).

I am sorry, but I hardly see a difference between the two screenshots :grinning:
Honestly, what is this all about? :wink:

6 Likes

Line spacing, buttons instead of tabs… You know, those little things that can make some people (or at least me) very edgy.
It’s that bloody trend when UI designer thinks that everyone is using a tablet with a touchscreen (big buttons for big fingers) instead of a proper desktop with keyboard and mouse (spacing is a bloat :grinning: Now the main menu requires a scrollbar).
If they release it as an optional theme then it’s ok but it should not be default.

6 Likes

I just don’t like half of my screen real-estate being wasted on useless UI. It’s the content of the web page that I’m viewing that should be the focus. Good UI stays out of the way, yet it is there when needed.

When it comes to Firefox, the entire browser UI (tabs and the main toolbar) should not be taller than 60 pixels, though I would prefer it be even smaller than that.

It is the vanity of designers that is the biggest problem, in my opinion. They think that I want to look at their crappy UI design. No, I want a functional UI. If it gets in my way, I don’t care how pretty it looks. And I don’t care if it looks ugly, as long as it stays out of the way enough that its ugliness is not in my face.

10 Likes

Hey!! :japanese_ogre:

As wise man once said… https://prinzhorn.github.io/skrollr/examples/gradientsmotherfucker.html

1 Like

After setting browser.proton.enabled to false and restarting the browser, lo and behold, I got the old menu back with icons and all!

I should mention that this is in Firefox beta if that would make any difference.

Firefox is still the best browser going and it doesn’t really bug me much. I make minor changes only. The preferences i do set specifically to what i want.

I’m not on beta here, but I also got the old menu with icons after setting browser.proton.enabled to false. I’m pleased that Firefox is offering us a choice between the two designs.

1 Like

Good to know that the option is there for the stable Firefox as well. For the moment I am sticking with the old design. However I don’t mind the new design either. So I may revert to that later on.

Some of you might find this useful if you want the icons back. I think one of the issues with relying on the about:config options is that it is going to be removed eventually.

Yep, I was initially confused when I opened a fresh session this morning (stable FF). :face_with_raised_eyebrow: A restart restored the icons and we’re back to the old menu!

1 Like

I liked the new design with Alpenglow theme . It looks so nice :smiling_face_with_three_hearts::smiling_face_with_three_hearts::smiling_face_with_three_hearts:

I presume you disabled Title Bar too .

Yeah, not only on Firefox. The titlebar is the most useless part of the GUI ever.


EDIT: I do this:

2 Likes