The command pacman returned error code 1 [SOLVED]


I have been trying to install Endeavor OS for the first time, but I have been getting an error,

Installation failed - package manager error: The package manager could not make changes to the installed system. The command

returned error code 1

I looked through this post, but I wasn’t able to find pcurses anywhere in the installation menu options. I am using EndeavourOS_Apollo_22_1.iso.

What could be going wrong? Would be happy to give any more information as required.


Can you share the entire install log so we can see what happened?


Potentially related, Apollo ISO bug is fixed for most users and also a workaround for those who need it

1 Like

Thanks for the prompt reply @dalto. I tried installing today morning and it installed successfully! I guess the issue has been resolved as mentioned in the link give by @jonathon. Thank you both once again for your help :slight_smile:


I order to mark a thread as solved, you could click the … under the post that solved the issue and check the box “Solution”. In this way the forum software will also recognize it as such and others searching in solved threads looking for a solution to similar problem would find it more easily.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.