Installation failed - package manager error: The package manager could not make changes to the installed system. The command <pre>pacman</pre> returned error code 1

This has happened on multiple times…

Using Ventoy — which I’ve done many times before with no trouble.

After updating to the latest Ventoy

After using diff usb — not using Ventoy, but using gnome-disk-utility (my old favorite)

All of my attempts have been done the same way I’ve installed many times before… updating mirrors first, even pre-partitioning with Gparted (ext4), etc, etc, etc

Obviously the error comes later in the install process

Error (as in post title):

Installation failed
package manager error:

The package manager could not make changes to the installed system. The command

returned error code 1.

Thanks for EOS! Thanks for your kind assistance!

Verify the image checksum.

You can get better installer logs by running sudo -E calamares in a terminal.

1 Like

checksum checked

will try terminal command

EOS already provides full logging by default. However, the version of Calamares that was on the last ISO had a limitation in pacman output logging. It was fixed after the ISO was released.

The only way to get more detail than that is to change the packages module installed on the ISO.


after using sudo -E calamares:

wow this seems way diff error that pacman error

log at states

2022-04-01 - 15:46:46 [1]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
ERROR: Installation failed: “The installer failed to format partition /dev/sdb6 on disk ‘SPCC Solid State Disk’.”

Once an install fails, you need to reboot before you can install again.

Have you tried an offline install?

1 Like

will need to reboot then…

was wanting to install KDE, so that’s why the online install

will try offline XFCE upon reboot to experiment

THANKS TO ALL FOR INSTANT ((((FRIENDLY)))) TECH HELP!!! unheard of in most other forums!!!

1 Like

Too many parentheses.


Actually, it may be pcurses.

When you do the online install and get to the screen where you can make selections, uncheck pcurses


too many ???

anyway you all are very friendly! thanks!

offline worked!

I will try to uncheck pcurses on this next online install attempt


1 Like

Does this need an iso refresh? If something is trying to bring this in then this is going to hit a lot of people.

1 Like

No, we can fix it without a refresh if that is what the issue is.


Gotta love seeing the hotfix implementation the devs added being put to good use in situations like this :smiley:



unchecking pcurses was the fix!!!

((((((( THANKS SO MUCH! )))))))


should I install pcurses now that I’m up and running?

1 Like

Nope. It was dropped from the repos today. That is what caused the issue.

1 Like


You guys/gals are AMAZING!

1 Like

Glad we could help.

Welcome to the community!

1 Like

Guys I am not able to install endeavour os it keeps telling the same error and I am not able to find pcurses during installation. Can someone help me ?

1 Like