System freezes randomly

Since installing EndeavourOS on my computer I have been experiencing frequent freezes. I haven’t identified any specific conditions for them to happen, they seem to be totally random. The image and audio just freezes, not reacting to any input, the disk activity LED on my computer stops blinking and sometimes a strange buzzing from inside the computer case is heard.
I have ignored this issue for a few months but it seems to be getting more frequent so I decided I have to do something with it. I’m not an expert, still a newbie (although using Linux for about 13 years now) so I’ve tried some solutions I’ve found on Arch Wiki and this forum. The first guess was GPU drivers so I disabled DPM in boot options (solution from Arch Wiki). That didn’t work. Then I tried this: EndevourOS randomly freezing - #5 by buffy That also didn’t work.
I still don’t know if this is a hardware issue or a system issue so would you please be so kind and help me solve this problem?
Some logs that may be useful: https://paste.ubuntu.com/p/V4P5SyVgdB/

Some initial steps:

  1. Update your BIOS;
  2. Try a number of different kernels (including linux-lts);
  3. Test your RAM;
  4. Test your disk;
  5. Ensure all components are seated correctly;
  6. Run a CPU burn test;
  7. Check temperatures and clean fans and vents;
  8. Check your power supply is providing a clean and consistent supply, consider investing in a spike protector or UPS.

Without more information people will likely just repeat the same things back to you - you need to help others help you.

2 Likes

I’d add to @jonathon’s recommendations also that i’d exclude anything i possibly could - disconnect every unnesessary components, leaves just:

  • PSU
  • Motherboard
  • CPU
  • 1 plank of RAM
  • If you have CPU with video output - use it for initial test, instead of dedicated GPU
  • System drive

If you check all this components and they’re fine - add other ones one by one, and see what fails.

I’d say most likely offenders:

  1. Failing SSD / HDD
  2. Faulty RAM
  3. PSU

But it’s impossible to tell without component exclusion / tests.

1 Like

Thank you for your advice. I’ve just updated BIOS and replaced the power supply (I had a spare one), I’ll see if it works. If not, then I’ll try all the other steps you mentioned. Sorry for asking stupid questions but how do I test RAM and disk, run a CPU burn test and check temperatures?

I had the same problem. My Lenovo T410 was running in the software rendering session only. My nvidia card is not supported but works with xorg that was not installed by default, so I had to install it and configure it first. Then, I installed a couple of xf86-… drivers, e.g. xf86-video-intel, xf86-video-nouveau. Finally, I had to disable the hardware acceleration in the browser. If it doesn’t work for you and you are using the nouveau driver, you can try the nouveau.noaccel=1 boot parameter to disable the hardware acceleration altogether.

The standard for this task is memtest86. I have it installed as a grub menu entry (memtest86-efi 1:9.2build2000-1). If is excecuted like that it runs before Linux. Actually without any OS.

It checks your RAM and it that takes a long(!) time. If it is too slow for you then let it run over night. But I would not recommend to stop it before at least one full test cycle is completed.

1 Like